Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 2 of 2

  1. #1

    earthquake 3.5 bog problem

    As the title says. Its runs awesome for 5 minutes. Then will bog as I try to give it full throttle. I have tuned many rc cars and this ones seems to be tuned dead nuts on. For the first 5 minutes I can go full throttle and no bog. Then out of nowhere it starts to bog. Any ideas or suggestions would be great.

  2. #2
    ijpom's Avatar
    Join Date
    Aug 2014
    Location
    Western Chicagoland
    Posts
    84
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback
    Hi Joe and welcome to RCU,

    Sounds like the engine has not reached operating temperature in the first 5 minutes and is tuned too lean for the temp at that point.
    I found that the large nitro engines don't reach their operating temperatures in half a tank the long way. Same symptoms as yours.
    Expect to warm the engine up in the first tank, then re-fill while running, and start you high speed tuning runs from there.

    At this point you should probably richen up the HSN 1/2 to a full turn to make it past the 5 minute mark.

    Hope that helps.
    Redcat Hurricane XTR
    Redcat Monsoon with EX 28


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
RCU Reviews
All times are GMT -6. The time now is 05:26 PM.

SEO by vBSEO 3.6.1 ©2011, Crawlability, Inc.