Go Back  RCU Forums > RC Cars, Buggies, Trucks, Tanks and more > Redcat Racing Support
Reload this Page >

I'm having problems with my volcano 1/18 v2 when I turn it on a red lite blinks

Redcat Racing Support Moderated Support Forum for all Redcat Racing Cars, Trucks & Buggies

I'm having problems with my volcano 1/18 v2 when I turn it on a red lite blinks

Reply

Old 06-09-2018, 10:25 AM
  #1  
newrcguy1986
Junior Member
Thread Starter
 
Join Date: Jun 2018
Posts: 1
Default I'm having problems with my volcano 1/18 v2 when I turn it on a red lite blinks

When I turn on my volcano 1/18 v2 the red lite blinks for min then goes away then I have to turn off and back again to get it to go again but only stays on for sec
newrcguy1986 is offline  
Reply With Quote
Old 06-10-2018, 09:10 AM
  #2  
RustyUs
 
RustyUs's Avatar
 
Join Date: Oct 2012
Location: central PA
Posts: 4,167
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Sometimes a flashing red LED means low voltage cutoff has been reached on ESC. Make sure batteries are fully charged. Sometimes a flashing red LED on receiver means signal has been lost. Try to bind transmitter and receiver again.

Contact manual for troubleshooting solutions. When all else fails, and the manual is of no help, contact manufacturer.
RustyUs is offline  
Reply With Quote

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service