Redcat Racing Support Moderated Support Forum for all Redcat Racing Cars, Trucks & Buggies

Servo failure

Reply

Old 10-06-2018, 05:00 PM
  #1  
WH1_T-type
Thread Starter
 
Join Date: Aug 2013
Posts: 10
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Servo failure

just bought a brand new TR MT8E BE6S. Put two 3S batteries in it and took it out on the street. Second pass and lost steering. Right as I realized it the truck struck a curb. No steering, front LEDs stopped working, and front left wheel popped off.

Anyone have experience with Redcat warranties? I submitted a claim and I hope they will cover it.
WH1_T-type is offline  
Reply With Quote
Old 10-07-2018, 12:20 PM
  #2  
WH1_T-type
Thread Starter
 
Join Date: Aug 2013
Posts: 10
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Little bit of trouble shooting and component swapping and I have found that the issue is actually the wire that goes from the ESC to the side of the servo. From there it is split and provides power to both the Servo and the lights. When it is skipped the Servo and LEDs both work. Am going to remove the wire and slice the heat shrink open to check the solder job as well as do continuity checks on the wires.
WH1_T-type is offline  
Reply With Quote

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service