Redcat Racing Support Moderated Support Forum for all Redcat Racing Cars, Trucks & Buggies

New Redcat Volcano Epx Radio problem?

Reply

Old 12-26-2018, 08:06 PM
  #1  
xcimo
Junior Member
Thread Starter
 
Join Date: Dec 2018
Posts: 2
Default New Redcat Volcano Epx Radio problem?

What does it mean if the green status light on the radio goes completely off? The truck works for a little while then the green light goes off and nothing works anymore. Normally the green light on the radio comes green even when the truck is off. However when this happen even powering on/off the radio only comes back one with the red power led on... Eventually (30min?) later the green led comes back and the truck start working again...

The manual only mention the status led being solid green if the battery are full or blink if they are running low. Nothing about being completely off.

Hope someone's knows.

Otherwise good truck I bought two for Christmas, one blue one red, interesting the radio is different, the blue one take 8 battery, this one (the one with issue) has 4 battery.

Thanks
xcimo is offline  
Reply With Quote
Old 12-27-2018, 04:15 AM
  #2  
RustyUs
 
RustyUs's Avatar
 
Join Date: Oct 2012
Location: central PA
Posts: 4,405
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Sounds like you got a loose connection in transmitter's battery tray. Those FlySky radios are some of lowest cost, if not the cheapest radios out there. Every once in awhile one will be DOA from all the stories I hear. Normally they work fine. I had a FlySky transmitter fail on me after about a month of use. The trigger potentiometer quit working. Quality assurance is just not there. Get in touch with Redcat. They might hook you up with a new radio if indeed there is a problem with the radio straight outta the box.

If I had to take a guess as to why two different transmitters, running change in production.
RustyUs is online now  
Reply With Quote
Old 12-27-2018, 03:39 PM
  #3  
xcimo
Junior Member
Thread Starter
 
Join Date: Dec 2018
Posts: 2
Default

Called their support and they think it's the radio (remote). They have already shipped me a new remote but also included a radio receiver, ecu and servo. All under warranty.

So far I'm happy. Hope it works.

Last edited by xcimo; 12-27-2018 at 06:24 PM.
xcimo is offline  
Reply With Quote
Old 01-06-2019, 03:57 PM
  #4  
Bclay81
Junior Member
 
Join Date: Jan 2019
Posts: 1
Default Redcat Will not bind

Redcat volcano binding light does not keep flashing after bind plug is inserted
Bclay81 is offline  
Reply With Quote
Old 01-06-2019, 04:23 PM
  #5  
RustyUs
 
RustyUs's Avatar
 
Join Date: Oct 2012
Location: central PA
Posts: 4,405
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

The binding plug should be plugged into the receiver before powering on transmitter. While holding the bind button down on transmitter, power the transmitter on. The receiver's LED should stop flashing when it binds with transmitter.
RustyUs is online now  
Reply With Quote

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service