Redcat Racing Support Moderated Support Forum for all Redcat Racing Cars, Trucks & Buggies

Gen 8 Scout fried 2 esc's and haven't ran 15 minutes yet.

Reply

Old 04-04-2019, 02:21 PM
  #1  
Dean P.
Thread Starter
 
Join Date: Dec 2014
Posts: 1
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Gen 8 Scout fried 2 esc's and haven't ran 15 minutes yet.

I bought a new Gen 8 on Sunday. Drove hour and half to purchase one because I really liked the looks, portals, and fwd motor setup. Got home put a battery in it, didn't drive 30 feet and I noticed one back tire wasn't pulling. Take wheel off to find rim turned to white powder at hub. No big deal, just a bad rim casting. Next day get home from work, put battery in and crawl my little course. Didn't get 10 minutes of running and truck just stopped moving. Pick up truck and it freaks out going FWD to Reverse at lightning speed. Before I can get battery unplugged esc let's out little puff of smoke. Drove 45 minutes to closest hobby shop today. Bought a axial esc. Installed esc and battery in scout and everything seemed great. Walked out to course and attempted again. Made it to fourth obstacle and same thing again...truck trying to tear itself apart going FWD to Reverse at lightning speed. Axial esc held out almost long enough for me to get battery unplugged, but not quite. It let out MASSIVE cloud of smoke. Now I am at a loss. I'm scared to put another esc in it because I believe its radio system frying esc's. Guess I should have bought Traxxas, or Axial.
Dean P. is offline  
Reply With Quote
Old 04-06-2019, 03:40 AM
  #2  
RustyUs
 
RustyUs's Avatar
 
Join Date: Oct 2012
Location: central PA
Posts: 4,437
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Wouldn't hurt to get Redcat involved in the issue, and see what they say.
RustyUs is online now  
Reply With Quote

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service