Redcat Racing Support Moderated Support Forum for all Redcat Racing Cars, Trucks & Buggies

"OFFICIAL"Redcat Racing TRUCK thread

Reply
Old 10-24-2006, 06:53 PM
  #2626
abjones413
 
abjones413's Avatar
 
Join Date: Sep 2006
Location: Worcester, MA
Posts: 321
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: OFFICIAL Redcat Racing TRUCK thread

TruckFreak, if your a senior in mechanics class, then you should know that that is normal wear and tear on the top of the piston and there's no need to polish it. It won't increase or decrease performance in the least. It's just the result of where the explosion takes place. The only thing you need to make sure of is that the sides of the piston and the cylinder wall aren't scratched. That's where you'll lose power. As long as you use a fuel filter, you should be in the clear, unless of course you drop a bunch of dirt in the top of the head while the glow plug is out... Doh!
abjones413 is offline  
Reply With Quote
Old 10-25-2006, 01:30 PM
  #2627
TruckFreak
 
Join Date: May 2006
Location: hermitage, TN
Posts: 25
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: OFFICIAL Redcat Racing TRUCK thread

Yeah that's what my instructor said I just wanted to be sure since these types of engine's mess up easily
TruckFreak is offline  
Reply With Quote
Old 10-25-2006, 02:37 PM
  #2628
Blackfoot
 
Join Date: Aug 2006
Location: Findley Lake, NY
Posts: 490
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: OFFICIAL Redcat Racing TRUCK thread

HELP PLZZZZZ

Im rebuilding the Tsunami. I need to know what the part number is for the front drive shaft cups. The ones on the trans and front diff, I removed the shaft when the front diff puked and never removed the cups. They must have loostened up and fell off. I also pulled the DX .18 and dropped in a O.S. .18 CV-RX for a lil more umph (actually alot). Ive got the page with the parts for the Tsunami, but they are crappy pics and no description.

Also is the 2 speed available as a whole? The add to cart is blanked oyt. The set screw fell out and the spring went with it. Ive been tryin to drive it but its locked in 2nd gear.

Then. I have had problems with the screws that hold the front knuckels in. The ones on the bottom front a-arm. I cant find a screw that fits correctly. I had alot of problems right after I bought this. Its been sitting on the shelf for months. now with winter coming on strong. I want to get it back running again
Blackfoot is offline  
Reply With Quote
Old 11-10-2006, 06:43 AM
  #2629
Bananaboat
 
Bananaboat's Avatar
 
Join Date: Apr 2006
Location: CampinasSao Paulo, BRAZIL
Posts: 116
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: OFFICIAL Redcat Racing TRUCK thread

Guys,

did anyone find a hear axial holder made of allum ?? Is there hope ??? hauhahuahua


Regards,
Bananaboat is offline  
Reply With Quote
Old 11-11-2006, 07:44 PM
  #2630
aldune
 
Join Date: Sep 2006
Location: Reedsport, OR
Posts: 5
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: OFFICIAL Redcat Racing TRUCK thread

I finally received the parts to convert my earthquake center diff to the hurricane style, They are quite differnt
does anyone have a link to the schematic for the hurricane?
aldune is offline  
Reply With Quote
Old 11-13-2006, 10:40 AM
  #2631
fahaka
 
Join Date: Sep 2006
Location: Mesa, AZ
Posts: 103
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: OFFICIAL Redcat Racing TRUCK thread

I should have taken pictures for you i just built up my diff and it all came together fine. If you have a specific question i can try to help I'll see if i have a parts breakdown in my catalog tonight.
fahaka is offline  
Reply With Quote
Old 11-13-2006, 01:22 PM
  #2632
naviuk
 
Join Date: Feb 2006
Location: Southfields, UNITED KINGDOM
Posts: 129
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: OFFICIAL Redcat Racing TRUCK thread

Hey Guys

Long time no chat, been awhile since i visited thise forum,
I finally got back to South Africa and things are going great here, I got to run my trucks at the local BMX track and man what a difference!

I need a favour from someone, Please can someone tell me a site that would be willing to sip a electric truck to South Africa???
My nephew really wants one and they soooo expensive over here and it works out cheaper to buy one and ship one here. The nitro's over here are double the price in some places...

PLease send me a site if you know of one.

Thanks
naviuk is offline  
Reply With Quote
Old 11-19-2006, 04:56 AM
  #2633
graymatters
 
Join Date: Nov 2006
Location: Mesa, AZ
Posts: 33
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: OFFICIAL Redcat Racing TRUCK thread

hello all.

I have had my Earthquake now for about a month but have not run it much. I have now run 5 tanks through the truck but have not fully tuned the truck. i was working on this when after a short lived run, i noticed something weird about my pull start.
basically i can only get one good crank out of the pull start. it is pretty tight and then turns over once. i noticed i have to pretty much let go of the pull start a couple inches from in and let it hit just so i can pull again. if not, the pull start winds up but it is completely loose. i decide tonight to take the engine (SH .28) out and make sure everything was okay. The clutch springs were good and everything seemed to be fine except i think the pull start is slipping and not making snug contact with the nut on the Engine Backhousing.
Has any one had any problems like this before.

Thanks in advance.

graymatters is offline  
Reply With Quote
Old 11-19-2006, 06:17 PM
  #2634
graymatters
 
Join Date: Nov 2006
Location: Mesa, AZ
Posts: 33
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: OFFICIAL Redcat Racing TRUCK thread

never mind on the engine question I just posted. I went out today and ran with "Fahaka" (from these forums) and he told me that he noticed this issue when he was not getting fuel properly. I am glad I took everything apart because I was able to locktite the engine. Everything seems to work except for the fact that now I broke a tab of the Universal Front Dogbone (large poles will do that when you clip em). No worries, just part of this week's order.
Overall I must say the Earthquake is pretty tough and alot of fun. They will last longer if your friends do not do cartwheels with them too!!

graymatters is offline  
Reply With Quote
Old 11-19-2006, 11:33 PM
  #2635
seanm729
 
Join Date: Jun 2006
Location: naples, FL
Posts: 50
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: OFFICIAL Redcat Racing TRUCK thread

f
seanm729 is offline  
Reply With Quote
Old 11-19-2006, 11:56 PM
  #2636
seanm729
 
Join Date: Jun 2006
Location: naples, FL
Posts: 50
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: OFFICIAL Redcat Racing TRUCK thread

hey what's up guys[8D] does any one know how the 02034-Universal joint A ataches to the rear dif because mine fell off (along with the dog bone but i fond that) and by looking at the rear diff. i cant figure out how it was stuck on there securely in the first place?[X(]
seanm729 is offline  
Reply With Quote
Old 11-20-2006, 12:10 AM
  #2637
seanm729
 
Join Date: Jun 2006
Location: naples, FL
Posts: 50
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: OFFICIAL Redcat Racing TRUCK thread

one more Q. does the 02072-Servo horn shown here in the instruction manual fit both the front and back servos is the picture in the manual wrong??
seanm729 is offline  
Reply With Quote
Old 11-24-2006, 12:35 PM
  #2638
aldune
 
Join Date: Sep 2006
Location: Reedsport, OR
Posts: 5
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: OFFICIAL Redcat Racing TRUCK thread

The earthquake engine seized up!
what replacement (stock) do you recommend?
looking for a reliable not racing engine with rotostart if possible

aldune is offline  
Reply With Quote
Old 12-24-2006, 03:46 PM
  #2639
tamu
 
Join Date: Dec 2006
Location: , LA
Posts: 4
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: OFFICIAL Redcat Racing TRUCK thread

at what point do I take the glow plug igniter off as of now the truck just shuts off
tamu is offline  
Reply With Quote
Old 12-24-2006, 04:05 PM
  #2640
ehroof
 
Join Date: Feb 2006
Location: howard beach, NY
Posts: 16,490
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: OFFICIAL Redcat Racing TRUCK thread

a few seconds after it starts, you may need to change the glow plug if you broke the engine in already.
ehroof is offline  
Reply With Quote
Old 12-24-2006, 04:07 PM
  #2641
tamu
 
Join Date: Dec 2006
Location: , LA
Posts: 4
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: OFFICIAL Redcat Racing TRUCK thread

this is a brand new truck do I have to leave the igniter on during the breakin and thanks for the info this is my first truck
tamu is offline  
Reply With Quote
Old 12-24-2006, 04:23 PM
  #2642
seanm729
 
Join Date: Jun 2006
Location: naples, FL
Posts: 50
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: OFFICIAL Redcat Racing TRUCK thread

hyugvyu8gyv8
seanm729 is offline  
Reply With Quote
Old 12-24-2006, 04:27 PM
  #2643
seanm729
 
Join Date: Jun 2006
Location: naples, FL
Posts: 50
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: OFFICIAL Redcat Racing TRUCK thread

sorry i was testing my computer, i don't think your supposed to leave that thing on for more than a few seconds. im not sure if it would mess anything up though.[8D]
seanm729 is offline  
Reply With Quote
Old 12-24-2006, 04:29 PM
  #2644
seanm729
 
Join Date: Jun 2006
Location: naples, FL
Posts: 50
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: OFFICIAL Redcat Racing TRUCK thread

but it sounds to me like your glo plug is no good $7.00 LHS[8D]
seanm729 is offline  
Reply With Quote
Old 12-24-2006, 04:34 PM
  #2645
tamu
 
Join Date: Dec 2006
Location: , LA
Posts: 4
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: OFFICIAL Redcat Racing TRUCK thread

well thats great it still glows but now I can't buy a new one until tuesday
tamu is offline  
Reply With Quote
Old 12-24-2006, 04:40 PM
  #2646
ehroof
 
Join Date: Feb 2006
Location: howard beach, NY
Posts: 16,490
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: OFFICIAL Redcat Racing TRUCK thread

is the idle low when the ignitor is on, maybe you need to raise the idle or lean the mixture a little, it may be too rich and needs the ignitor on to burn the excess fuel, did you break the engine in yet? How bright, large is the light in the plug, does it light up the whole coil?
ehroof is offline  
Reply With Quote
Old 12-24-2006, 04:43 PM
  #2647
seanm729
 
Join Date: Jun 2006
Location: naples, FL
Posts: 50
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: OFFICIAL Redcat Racing TRUCK thread

OS A5 is what i use in my stx. any one know how to re-seal a carb.???
seanm729 is offline  
Reply With Quote
Old 12-24-2006, 04:43 PM
  #2648
tamu
 
Join Date: Dec 2006
Location: , LA
Posts: 4
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: OFFICIAL Redcat Racing TRUCK thread

thanks alot guys I am sure I will have more questions no haven't broken the engine thanks
tamu is offline  
Reply With Quote
Old 12-24-2006, 04:47 PM
  #2649
seanm729
 
Join Date: Jun 2006
Location: naples, FL
Posts: 50
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: OFFICIAL Redcat Racing TRUCK thread

good idea ehroof[8D] i would try that before going and getting a new glo plug.
seanm729 is offline  
Reply With Quote
Old 12-28-2006, 04:58 PM
  #2650
truckerbruce
 
Join Date: Nov 2006
Location: springhill, LA
Posts: 16
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: OFFICIAL Redcat Racing TRUCK thread

Hi, this is my first post love the forum. Anyways can someone tell me why my box for my volcano sv pro says "The following are the accessories for optional purchase to facilitate your opperations" , and gives part #70110 for the starter box that does not work with the truck? I ordered that box it didn't "fit" the truck now I'm out $29.99 plus shipping, and I still had to buy the roto power starter. Any help would be nice , but an answer from Redcat would be even better. Thanks B.Allen
truckerbruce is offline  
Reply With Quote
Reply


Thread Tools
Search this Thread
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 03:47 PM.