Redcat Racing Support Moderated Support Forum for all Redcat Racing Cars, Trucks & Buggies

"OFFICIAL"Redcat Racing 1/10th BUGGY

Reply
Old 07-25-2006, 08:31 PM
  #551
hondaidiot
 
Join Date: Jun 2006
Location: Olympia, WA
Posts: 92
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: "OFFICIAL"Redcat Racing 1/10th BUGGY

do the gp ignitors hold a charge or do they slowly lose a charge even if u dont use them that would be nice to know thanks
hondaidiot is offline  
Reply With Quote
Old 07-25-2006, 08:35 PM
  #552
ehroof
 
Join Date: Feb 2006
Location: howard beach, NY
Posts: 16,490
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: "OFFICIAL"Redcat Racing 1/10th BUGGY

like any battery they will loose a charge over time, a month or more.
ehroof is offline  
Reply With Quote
Old 07-25-2006, 08:42 PM
  #553
hondaidiot
 
Join Date: Jun 2006
Location: Olympia, WA
Posts: 92
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: "OFFICIAL"Redcat Racing 1/10th BUGGY

oh not mine, i can start my car with it like twice then its dead cause i dont charge it every time after i use it i thought it would be good for like a week even if i used it to start my car like 10 times or something but guess i'm wrong
hondaidiot is offline  
Reply With Quote
Old 07-25-2006, 10:16 PM
  #554
ThunderbirdJunkie
 
ThunderbirdJunkie's Avatar
 
Join Date: Jul 2004
Location: Norwood, OH
Posts: 22,101
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: "OFFICIAL"Redcat Racing 1/10th BUGGY

http://www2.towerhobbies.com/cgi-bin...&I=LXMN95&P=ML check that sucker out. 5,000 mah!!
ThunderbirdJunkie is offline  
Reply With Quote
Old 07-26-2006, 12:25 AM
  #555
bluecaka69
 
bluecaka69's Avatar
 
Join Date: Feb 2006
Location: bILLINGS, MT
Posts: 2,169
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: "OFFICIAL"Redcat Racing 1/10th BUGGY

TBJ well ya finally got internet in da crib huh HAHA
bluecaka69 is offline  
Reply With Quote
Old 07-26-2006, 12:26 AM
  #556
nitro_racer_1
 
Join Date: Jun 2004
Location: clarkston, WA
Posts: 541
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: "OFFICIAL"Redcat Racing 1/10th BUGGY

if u dont charge them for the full 14 hours they wont last very long. i dont like the hot shot one. the one i had fell apart and there really expensive you can get one that excepts duracell bateries and is aluminum and has a batery meter for that much.
nitro_racer_1 is offline  
Reply With Quote
Old 07-26-2006, 01:02 AM
  #557
ThunderbirdJunkie
 
ThunderbirdJunkie's Avatar
 
Join Date: Jul 2004
Location: Norwood, OH
Posts: 22,101
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: "OFFICIAL"Redcat Racing 1/10th BUGGY

LOL yup, had it for over a month now

BTW I've had a hot shot for YEARS now, and it's just now starting to not hold a charge. I've never had a glow plug ignitor fall apart on me...that's weird.

you drop yours a lot? you're supposed to bash your CAR not your glow plug ignitor
ThunderbirdJunkie is offline  
Reply With Quote
Old 07-26-2006, 01:39 AM
  #558
bluecaka69
 
bluecaka69's Avatar
 
Join Date: Feb 2006
Location: bILLINGS, MT
Posts: 2,169
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: "OFFICIAL"Redcat Racing 1/10th BUGGY

cool i was just bein an A^% cause i remembered that you say you didnt have it
bluecaka69 is offline  
Reply With Quote
Old 07-26-2006, 01:49 AM
  #559
ThunderbirdJunkie
 
ThunderbirdJunkie's Avatar
 
Join Date: Jul 2004
Location: Norwood, OH
Posts: 22,101
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: "OFFICIAL"Redcat Racing 1/10th BUGGY

LOL I know
ThunderbirdJunkie is offline  
Reply With Quote
Old 07-26-2006, 10:00 AM
  #560
nitro_racer_1
 
Join Date: Jun 2004
Location: clarkston, WA
Posts: 541
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: "OFFICIAL"Redcat Racing 1/10th BUGGY

lol no i didnt drop it alot, but the batery fell of of it
nitro_racer_1 is offline  
Reply With Quote
Old 07-26-2006, 12:12 PM
  #561
Popper252
 
Popper252's Avatar
 
Join Date: Mar 2006
Location: Tallahassee, FL
Posts: 1,005
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: "OFFICIAL"Redcat Racing 1/10th BUGGY

Haha the battery fell off of my glow plug charger too man. Completely sucks. I ended up glueing it all back together. I guess It could be worse. I could have stripped a gear.
Popper252 is offline  
Reply With Quote
Old 07-26-2006, 02:27 PM
  #562
jguitarsandcars
 
Join Date: Jul 2006
Location: Rocky Hill, CT
Posts: 276
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: "OFFICIAL"Redcat Racing 1/10th BUGGY

well, the one that comes with the starter kit is just some cheap shrink tube holding the battery on....How long do the batteries last in the non-rechargables...I was gonna get one, but thought I'd spend too much on batteries.
jguitarsandcars is offline  
Reply With Quote
Old 07-26-2006, 07:29 PM
  #563
nitro_racer_1
 
Join Date: Jun 2004
Location: clarkston, WA
Posts: 541
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: "OFFICIAL"Redcat Racing 1/10th BUGGY

they last just as long as the rechargables and u dont gotta wait for them to charge when there dead, and propper i DO have stripped gears i stripped the spur gear in the tranny, dose anyone no of any steel gears that might work?
nitro_racer_1 is offline  
Reply With Quote
Old 07-26-2006, 09:23 PM
  #564
jguitarsandcars
 
Join Date: Jul 2006
Location: Rocky Hill, CT
Posts: 276
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: "OFFICIAL"Redcat Racing 1/10th BUGGY

Ah, I think i'd rather have 2 rechargables...if they don't last any longer, I think I'd be spending a lot of dough on the batteries...
jguitarsandcars is offline  
Reply With Quote
Old 07-27-2006, 12:08 AM
  #565
nitro_racer_1
 
Join Date: Jun 2004
Location: clarkston, WA
Posts: 541
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: "OFFICIAL"Redcat Racing 1/10th BUGGY

one pac of c batteries lasts a long time
nitro_racer_1 is offline  
Reply With Quote
Old 07-27-2006, 12:18 AM
  #566
nitro_racer_1
 
Join Date: Jun 2004
Location: clarkston, WA
Posts: 541
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: "OFFICIAL"Redcat Racing 1/10th BUGGY

heres some pic of my exhaust set up, holy crap with that header the truck is TOTALY different! waaay more power! and you can see my new tiger drive system. and i wanted to ask everyones opinon on something; do u think this, http://www.redcatracing.com/itemdeta...?partno=02115B would look good on my truck instead of what i got? tell me what you think.
Attached Thumbnails
Click image for larger version

Name:	Sq46169.jpg
Views:	8
Size:	130.7 KB
ID:	497477  
nitro_racer_1 is offline  
Reply With Quote
Old 07-27-2006, 12:26 AM
  #567
Popper252
 
Popper252's Avatar
 
Join Date: Mar 2006
Location: Tallahassee, FL
Posts: 1,005
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: "OFFICIAL"Redcat Racing 1/10th BUGGY

Nah, i'd stick with the purple. It matches better.
That thing is a beast man. Nice work.
Just curious, how much heavier is it now? And is the drivetrain holding up with all that extra weight?
Popper252 is offline  
Reply With Quote
Old 07-27-2006, 12:47 AM
  #568
nitro_racer_1
 
Join Date: Jun 2004
Location: clarkston, WA
Posts: 541
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: "OFFICIAL"Redcat Racing 1/10th BUGGY

yeah mabey your right but i wish the whole thing was blue lol, it holds up great its insane as son as i puy that header pn is had awesome acceleration, and way better to speed, and its holding up perfect, after a half hour in 105 degree heat at mostly full speed the motor temp is about 180 degrees!
nitro_racer_1 is offline  
Reply With Quote
Old 07-27-2006, 12:48 AM
  #569
nitro_racer_1
 
Join Date: Jun 2004
Location: clarkston, WA
Posts: 541
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: "OFFICIAL"Redcat Racing 1/10th BUGGY

and yeah it deffinetly whighs more but its not too bad
nitro_racer_1 is offline  
Reply With Quote
Old 07-27-2006, 12:51 AM
  #570
nitro_racer_1
 
Join Date: Jun 2004
Location: clarkston, WA
Posts: 541
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: "OFFICIAL"Redcat Racing 1/10th BUGGY

oops i screwed up, as soon as i put that header on .. is what i meant lol
nitro_racer_1 is offline  
Reply With Quote
Old 08-04-2006, 10:19 PM
  #571
hondaidiot
 
Join Date: Jun 2006
Location: Olympia, WA
Posts: 92
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: "OFFICIAL"Redcat Racing 1/10th BUGGY

well i took my little buggy to the local rc track and i'm proud to say it was fun and exciting and quite irriating and i must say i was probably putting around the track at about 2mph lol it survived all the jumps the had there about 5-6 i think and they were all pretty good sized anywhere from 4-10inches high i think and luckily nothing broke or bent or anything it even with stood about 3flips and my dad smacking it into the concrete wall around the track i was like here dad wanna drive it since u helped buy and he was like not really but he did and i dont even think he made it 15mins before he smacked the wall and it started making a loud noise and i was oh god *** did u do to it now your done, shut it off and the exhaust pipe had popped loose and that happend about 5-6 times over a half hour and i finally got frustrated and said forget it i'm done so now i think i am gonna try and build an rc track in the back yard, but ya i was impressed nothing flipped and granted i didnt go at any of the jumps full throttle but with some of the posts i had read i was kinda worried about bending or breaking something, and i never changed out any of the shocks or changed the shock oil it is all still stock.
hondaidiot is offline  
Reply With Quote
Old 08-09-2006, 01:40 PM
  #572
lucasdon17
 
Join Date: May 2006
Location: Newmarket, NH
Posts: 49
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: "OFFICIAL"Redcat Racing 1/10th BUGGY

HI ALL

I need some help here.
When i prime the engine...i notice fuel drip down from near the engine where the flywheel is mounted. This leak is pretty obvious and i am just not able to get my engine to start. Once more issue is..if at all my engine starts..when i open the fuel tank , it just dies.

Whats goin on here.? Has any one faced this issue or tried to seal it ?. Any pcitures or guidelines to open from this end .

Thank you
lucasdon17 is offline  
Reply With Quote
Old 08-09-2006, 02:24 PM
  #573
TopSpeedToys
 
TopSpeedToys's Avatar
 
Join Date: Mar 2006
Location: Los Angeles, California, CA
Posts: 523
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: "OFFICIAL"Redcat Racing 1/10th BUGGY


Quote:
ORIGINAL: lucasdon17

HI ALL

I need some help here.
When i prime the engine...i notice fuel drip down from near the engine where the flywheel is mounted. This leak is pretty obvious and i am just not able to get my engine to start. Once more issue is..if at all my engine starts..when i open the fuel tank , it just dies.

Whats goin on here.? Has any one faced this issue or tried to seal it ?. Any pcitures or guidelines to open from this end .

Thank you

Someone correct me here if I'm wrong but... seems your engine bearing is no good. I don't think you
can seal it. Only option is to replace the bearing or get enother engine.

Mark

TopSpeedToys is offline  
Reply With Quote
Old 08-09-2006, 04:20 PM
  #574
Lordmik
 
Lordmik's Avatar
 
Join Date: Jun 2006
Location: jackson, TN
Posts: 242
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: "OFFICIAL"Redcat Racing 1/10th BUGGY

If I'm hearing you right, you said when you open the fuel tank, it dies? It should. If you open the fuel tank, it releases the pressure that sends the fuel to the carb. The tank has to be sealed for the exhaust pressure to push the fuel to the carb. If I'm wrong about that, someone please correct me.
Lordmik is offline  
Reply With Quote
Old 08-09-2006, 05:04 PM
  #575
leesmack
 
Join Date: Jul 2006
Location: mexico, MO
Posts: 104
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: "OFFICIAL"Redcat Racing 1/10th BUGGY

hey nitro_racer_1, i was wondering what the aluminum upper plate you have on your car is for? im guessing for reinforcment?? is it a worthy buy?
leesmack is offline  
Reply With Quote
Reply


Thread Tools
Search this Thread
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 11:18 AM.