Redcat Racing Support Moderated Support Forum for all Redcat Racing Cars, Trucks & Buggies

someone please help

Reply
Old 02-01-2006, 10:39 AM
  #1
chopper22980
Thread Starter
 
chopper22980's Avatar
 
Join Date: Jan 2006
Location: madison heights, VA
Posts: 191
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default someone please help

Ive got the volcano stx 1/10 scale truck.Well ive just put a new clutch and spring in it.That went great no problems.Now its back together and im having problems with the way its running.It starts fine and will run great.The problem is when I try and stop it or even slow it down it will cut right off.Ive made adjustments to it and still the same problem.It wont just sit and idle,it either has to move or it cuts off.Ive adjusted the idle screw and still the same o same o.Please if any one can help that would be great,thanks.
chopper22980 is offline  
Reply With Quote
Old 02-01-2006, 11:18 AM
  #2
Chubbysdad
 
Join Date: Jun 2005
Location: Clermont, FL
Posts: 2,824
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: someone please help

check your opening in the top of carb. It seems to me it is too low. Also, you might have to lean out the ls screw. Does it take off good? Also, check when you apply your brake, the the opening doesn't close. If so adjust it so it doesn't . Just take off air cleaner and apply brake and see if the opening closes. Just an idea.
Chubbysdad is offline  
Reply With Quote
Old 02-01-2006, 06:23 PM
  #3
wildwilly
 
Join Date: Jan 2006
Location: Newcastle, AUSTRALIA
Posts: 70
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: someone please help

the only time ive had this problem is when the clutch spring has broken. Try sitting the truck on something so that the wheels can all spin freely and fiddle with the idle then. If you cant get it to a point where the wheels will stop and the engine stays on then the clutch spring is probably broken, or maybe its not strong enough. I have replaced the spring and the one of got currently is only just strong enough to stop the clutch engaging at idle.
wildwilly is offline  
Reply With Quote
Old 03-19-2006, 03:23 AM
  #4
Trav 09
 
Join Date: Mar 2006
Location: Shenandoah, PA
Posts: 20
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: someone please help

ive had the same problem and its your clutch bell you need a new one there cheap like 5 bucks what happens is they stick and wont let it turn thats why it shuts off im positve this is the problem
Trav 09 is offline  
Reply With Quote
Old 03-19-2006, 09:38 AM
  #5
ehroof
 
Join Date: Feb 2006
Location: howard beach, NY
Posts: 16,490
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: someone please help

if you got the clutch spring from redcat, it is possinle it broke again, i bought a traxxas spring since the clutch spring redcat uses is very inferior.
ehroof is offline  
Reply With Quote
Reply


Thread Tools
Search this Thread
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 02:10 AM.