Redcat Racing Support Moderated Support Forum for all Redcat Racing Cars, Trucks & Buggies

CAR STALLS

Reply
Old 03-22-2006, 04:00 AM
  #1
left_lane_69
Thread Starter
 
Join Date: Mar 2006
Location: Harbor Springs, MI
Posts: 6
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default CAR STALLS

Hi all... here's my problem: I own a 1:10 th scale tornado xl, when I start my buggy it starts up well but as soon as I take the glow ignitor off the glow plug it quits on me. I have cleaned all the fuel lines and taken the carbuerator off and cleaned them and blown them all out. Is this a glow plug problem or something deeper? Any thoughts on this will be much appreciated Thanx, Brian[&o]
left_lane_69 is offline  
Reply With Quote
Old 03-22-2006, 06:59 AM
  #2
chopper22980
 
chopper22980's Avatar
 
Join Date: Jan 2006
Location: madison heights, VA
Posts: 191
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: CAR STALLS

Hey Brian...Try leaving your ignitor on for about 20-30 seconds.Especially when you are first starting
it.It needs time to warm up.Myself I wil hold my truck in the air.Then I will pull on the throttle a few
quick times.While the ignitor is still on.That works for me.
chopper22980 is offline  
Reply With Quote
Old 03-22-2006, 07:08 AM
  #3
left_lane_69
Thread Starter
 
Join Date: Mar 2006
Location: Harbor Springs, MI
Posts: 6
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: CAR STALLS

Well Chopper I tryed that also even revved it up for a little bit.... reassuring it was warm, when I first got it, it stayed running without a problem.Not really sure whats going on but I'm really discouraged here. Thanks for your input though! Anyone else?
left_lane_69 is offline  
Reply With Quote
Old 03-22-2006, 07:21 AM
  #4
wildspeed
 
Join Date: Jan 2006
Location: winter haven, FL
Posts: 30
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: CAR STALLS

Try to get a new plug, sound yours went bad
wildspeed is offline  
Reply With Quote
Old 03-22-2006, 07:33 AM
  #5
chopper22980
 
chopper22980's Avatar
 
Join Date: Jan 2006
Location: madison heights, VA
Posts: 191
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: CAR STALLS

Like wildspeed said,it could be your plug.Have you been able to run it at all?For any certain length of time?This is what happened to me.When I would start mine I had to turn the throttle trim back some.So that way it was getting a little fuel.Come to find out,the clutch spring was broken,which caused mine to do that.

Not saying that is your problem,but when I replaced the spring I had no further problem.
There are some guy's on here who seem to know what they are talking about.So hopefully
one will answer you and it will help you out.Good luck......
chopper22980 is offline  
Reply With Quote
Old 03-22-2006, 02:13 PM
  #6
left_lane_69
Thread Starter
 
Join Date: Mar 2006
Location: Harbor Springs, MI
Posts: 6
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: CAR STALLS

Yeah I can run the car if I keep my finger on the trigger and keep the rpm's up but when I slow the car down to turn or just try to stop it, it immediately stops. I'm pretty sure that the clutch is ok. Driveline is all good. i guess I'll just wait till I get the new glow plug and do it by elimination...... Thanks for you input. Brian
left_lane_69 is offline  
Reply With Quote
Old 03-22-2006, 05:28 PM
  #7
jeeperscreapers
 
jeeperscreapers's Avatar
 
Join Date: Mar 2006
Location: Halls, TN
Posts: 254
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: CAR STALLS

do your wheels spin while its idle'n or do they stay still at idle?????
jeeperscreapers is offline  
Reply With Quote
Old 03-22-2006, 06:08 PM
  #8
left_lane_69
Thread Starter
 
Join Date: Mar 2006
Location: Harbor Springs, MI
Posts: 6
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: CAR STALLS

The wheels stay still at idle...... everything is normal except for the stalling.
left_lane_69 is offline  
Reply With Quote
Old 03-22-2006, 07:01 PM
  #9
jeeperscreapers
 
jeeperscreapers's Avatar
 
Join Date: Mar 2006
Location: Halls, TN
Posts: 254
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: CAR STALLS

could be to rich on the lsn
jeeperscreapers is offline  
Reply With Quote
Old 03-22-2006, 08:44 PM
  #10
ehroof
 
Join Date: Feb 2006
Location: howard beach, NY
Posts: 16,490
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: CAR STALLS

set the idle higher so it will idle in neurtral, then fool with the low end setting if needed at idle.
ehroof is offline  
Reply With Quote
Reply


Thread Tools
Search this Thread
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 02:31 PM.