Redcat Racing Support Moderated Support Forum for all Redcat Racing Cars, Trucks & Buggies

Car rolling forward at idle

Reply
Old 01-10-2007, 02:13 PM
  #1
darylbz
Thread Starter
 
Join Date: Jan 2007
Location: Lake Bluff, IL
Posts: 2
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Car rolling forward at idle

I am new to the nitro rc cars. I have a Tornado BB with a .18 Taiwan motor. When I start the car it wants to take off. I have adjusted the idle screw all the way out to killing the engine and back in slightly. At the lowest I can possibly get this car to idle, the clutch is still engaging. What am I missing?
darylbz is offline  
Reply With Quote
Old 01-10-2007, 02:15 PM
  #2
{GBI}Harryball
 
{GBI}Harryball's Avatar
 
Join Date: Jul 2006
Location: lansing, MI
Posts: 1,261
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Car rolling forward at idle

If you lift the car and start it and the wheels are running, then you clutch spring is bad. There are detail instruction in the stickies at the top of the forums.
{GBI}Harryball is offline  
Reply With Quote
Old 01-10-2007, 02:25 PM
  #3
MiniCwik
 
MiniCwik's Avatar
 
Join Date: Jan 2007
Location: New Baltimore, MI
Posts: 1,035
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Car rolling forward at idle

^^^ What he said ... ^^^

Mine went bad last night, but I had a new spring and cb housing on order already.

Also be sure that your throttle trim isn't advanced either.
MiniCwik is offline  
Reply With Quote
Old 01-10-2007, 03:41 PM
  #4
darylbz
Thread Starter
 
Join Date: Jan 2007
Location: Lake Bluff, IL
Posts: 2
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Car rolling forward at idle

Thank you everyone. That was what I was afraid of. Can I order just the spring from Redcat, or do I have to order the entire Clutch Assembly. If I have to order the clutch assembly, do I just replace the whole thing instead of the spring?
darylbz is offline  
Reply With Quote
Old 01-10-2007, 03:43 PM
  #5
MiniCwik
 
MiniCwik's Avatar
 
Join Date: Jan 2007
Location: New Baltimore, MI
Posts: 1,035
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Car rolling forward at idle

Check out the sticky clutch thread towards the top of this Redcat Forum area, I ordered my MPI springs and they should be in soon as well as my bro-in-law picked up the Traxxas 4146 spring (with clutch shoes that he did not use) at a local hobby shop and resolved the problem.

While you're there ordering or purchasing, look into a new clutch bell housing as well, see the stock one is out of round and causing the spring issue to begin with.
MiniCwik is offline  
Reply With Quote
Old 01-10-2007, 09:38 PM
  #6
dclintonh
 
Join Date: Dec 2006
Location: greenville, SC
Posts: 434
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Car rolling forward at idle

if its broken on the end just make a loop and put it back together. that will get you through till your spring and clutch bell get there.
i did this about 7 tanks ago and it still works.
i did order the high stall spring from the sticky thread for back up though. cannot wait to see the diff.
and you will need the clutch bell and gears too. like they said
dclintonh is offline  
Reply With Quote
Reply


Thread Tools
Search this Thread
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 06:13 PM.