Redcat Racing Support Moderated Support Forum for all Redcat Racing Cars, Trucks & Buggies

Redcat Racing Tornado Thread

Reply
Old 07-22-2009, 03:02 AM
  #3476
basketballfan60123
 
Join Date: Jun 2009
Location: Elgin, IL
Posts: 568
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Redcat Racing Tornado Thread

How do you put the clutchbell together ? I am having problems with shredding my 47 tooth spur gear on my tornado buggy; have gone through 5 of them regardless of how i set the gear mesh.
I have an sh18 engine; will this work for mine?
If so can you send me some pics on how this is done.
basketballfan60123@lycos.com
basketballfan60123 is offline  
Reply With Quote
Old 07-22-2009, 08:32 AM
  #3477
neyou86
 
Join Date: Dec 2007
Location: murdock, MN
Posts: 1,065
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Redcat Racing Tornado Thread

what do you mean put the clutchbell together? did you get the hpi one? or did u buy a new one from redcat? do u want to know how to put the bearings in?
neyou86 is offline  
Reply With Quote
Old 07-22-2009, 08:52 AM
  #3478
neyou86
 
Join Date: Dec 2007
Location: murdock, MN
Posts: 1,065
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Redcat Racing Tornado Thread

alright guys now im having tuning trouble. i had my car tuned for about 60 degrees farenheit(outside temp) and now that its 80 degrees it runs terrible. if i do a high speed run then turn round and start to do another it doesnt have enough power to make it move. ive got the hsp at 3 turns out and the low speed flush cuz that seems to be what it used to like. ive changed the plug and fixed the fuel tank leak. also when i try starting it, it will run for a second and then shut off, so i keep trying and i gotta sit and pul for 15 minutes. its starting to get old and the guy that wants to trade is taking forever to reply.
neyou86 is offline  
Reply With Quote
Old 07-22-2009, 08:03 PM
  #3479
basketballfan60123
 
Join Date: Jun 2009
Location: Elgin, IL
Posts: 568
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Redcat Racing Tornado Thread

the hpi one. I want to know how to put it together and how to install it in my tornado bb
basketballfan60123 is offline  
Reply With Quote
Old 07-22-2009, 11:48 PM
  #3480
BigDave09
 
Join Date: May 2009
Location: tallmadge, OH
Posts: 117
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Redcat Racing Tornado Thread


Quote:
ORIGINAL: neyou86

alright guys now im having tuning trouble. i had my car tuned for about 60 degrees farenheit(outside temp) and now that its 80 degrees it runs terrible. if i do a high speed run then turn round and start to do another it doesnt have enough power to make it move. ive got the hsp at 3 turns out and the low speed flush cuz that seems to be what it used to like. ive changed the plug and fixed the fuel tank leak. also when i try starting it, it will run for a second and then shut off, so i keep trying and i gotta sit and pul for 15 minutes. its starting to get old and the guy that wants to trade is taking forever to reply.
i used to have the same problem I adjusted the idle screw and now runs great and u might wanna check your glow plug
BigDave09 is offline  
Reply With Quote
Old 07-23-2009, 07:52 AM
  #3481
neyou86
 
Join Date: Dec 2007
Location: murdock, MN
Posts: 1,065
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Redcat Racing Tornado Thread

did u raise it or lower it?
neyou86 is offline  
Reply With Quote
Old 07-23-2009, 07:53 AM
  #3482
neyou86
 
Join Date: Dec 2007
Location: murdock, MN
Posts: 1,065
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Redcat Racing Tornado Thread

basketballfan- look back some pages in this thread, its been covered alot. i would help you but i dont have the hpi one
neyou86 is offline  
Reply With Quote
Old 07-25-2009, 12:03 PM
  #3483
shotgun32
 
Join Date: Jul 2009
Location: Barrie, ON, CANADA
Posts: 14
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Redcat Racing Tornado Thread

hello, all. Got a Tornado BB, broke it in according to manual and it ran beauty right from first pull. Fourth tank was just idling around, running at 140 degrees,decided to open it just a bit. It shifted in 2nd and I backed out of it, di this a couple times. Third time or so I noticed a clicking sound when I was slowing down. Sped it up again and no shift... but it did click when slowing down. Insepected the Centrifugal clutch and noticed the arm moved outward, half the travel it should with no resistance. I tried turning allen in to tighten spring but it still had no resistance. Now I have had this a couple hours and I'm taking the transmission out to get a closer look at the clutch . It seems the spring is fine but the ball will not go all the way to the arm... Is this something that can be fixed? should I be looking at why the ball doesn't make contact or do I need a new clutch, already? Any helps really appreciated, thanks
shotgun32 is offline  
Reply With Quote
Old 07-25-2009, 12:09 PM
  #3484
neyou86
 
Join Date: Dec 2007
Location: murdock, MN
Posts: 1,065
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Redcat Racing Tornado Thread

your grub screw most likely came out. did it seem like it accelerated slower? if so then you will need a new two speed clutch
neyou86 is offline  
Reply With Quote
Old 07-25-2009, 12:54 PM
  #3485
shotgun32
 
Join Date: Jul 2009
Location: Barrie, ON, CANADA
Posts: 14
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Redcat Racing Tornado Thread

No the grub screws were both there, actually looks like the bottom of shifting lever where balls rubs against got deformed, or at least doesn't look perfect. Does anyone know is the ball supposed totravel all the way through the clutch housing, eg: if shifting arm is out of housing will the ball go all the way through the channel? or does it stop short of falling out? I wouldn't mind replacing it if I got more then 100 feet driving, was kind of hoping a baddecision would be cause of my first replacment parts.
shotgun32 is offline  
Reply With Quote
Old 07-25-2009, 01:14 PM
  #3486
neyou86
 
Join Date: Dec 2007
Location: murdock, MN
Posts: 1,065
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Redcat Racing Tornado Thread

i have no clue about that ball thing, i didnt think there was a ball in the 2 speed clutch. is it what the arm pushes on when its lifted up?
neyou86 is offline  
Reply With Quote
Old 07-25-2009, 04:37 PM
  #3487
glk420247
 
Join Date: Aug 2006
Location: Risingsun, OH
Posts: 593
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Redcat Racing Tornado Thread

It is not shifting because your stuck in second gear. Check this tread out bro. This one is from way back. Read post # 20 about half way down [link]http://www.rcuniverse.com/forum/m_4207842/mpage_1/key_/tm.htm[/link]
You will have to take it out and clean it.. This is an age old problem with the 2 speed clutch. The little thing takes a beating when it shifts. I went though 3 of them before I got a good one. Just my 2 cents.
One more thing make sure the steel pin is there in the spur gear.

Later, Fong
glk420247 is offline  
Reply With Quote
Old 07-25-2009, 04:45 PM
  #3488
neyou86
 
Join Date: Dec 2007
Location: murdock, MN
Posts: 1,065
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Redcat Racing Tornado Thread

hey guys my tornado wishes it could fly haha. it only runs good off the ground but it starts on the ground. i got it started drove it 5 feet and it seemed like it had no power and then it died. any ideas. ill give it a full check out tommorow but i figured i would see if you guys knew what the problem could be.
neyou86 is offline  
Reply With Quote
Old 07-25-2009, 04:51 PM
  #3489
glk420247
 
Join Date: Aug 2006
Location: Risingsun, OH
Posts: 593
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Redcat Racing Tornado Thread

You broke your spring That goes around your clutch. Take your clutch bell off and you will see your spring has broken. Try replacing with this one.[link]http://www3.towerhobbies.com/cgi-bin/wti0095p?FVSEARCH=4146x&FVPROFIL=++&search3=Go[/link] You only use the spring. Good luck bro.

Check this Thread out and look into buying the Hpi A885 clutch shoe.[link=http://www.rcuniverse.com/forum/m_6517902/anchors_6520138/mpage_1/key_/anchor/tm.htm#6520138]Clutch spring[/link]

Here is a link to the Hpi A885 clutch shoe. [link]http://www3.towerhobbies.com/cgi-bin/wti0001p?&I=LXLW03&P=FR[/link]
glk420247 is offline  
Reply With Quote
Old 07-25-2009, 10:17 PM
  #3490
shotgun32
 
Join Date: Jul 2009
Location: Barrie, ON, CANADA
Posts: 14
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Redcat Racing Tornado Thread

thanks for the ideas but thinking its not dirt, thisbuggy is brand new, only driven 200 feet on clean pavement at 1/4 to half throttle, the clutch was shiney in my hand. I think the arm is damaged where the ball makes contact but can't take arm out without destroying clutch, so guess I'll order one, then maybe destroy this and see if right, thanks again.
shotgun32 is offline  
Reply With Quote
Old 07-26-2009, 10:40 AM
  #3491
neyou86
 
Join Date: Dec 2007
Location: murdock, MN
Posts: 1,065
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Redcat Racing Tornado Thread

alright i didnt find anything wrong really but i noticed i had one wheel nut too tight and it was rubbing on the nuckle. could that have caused it
neyou86 is offline  
Reply With Quote
Old 07-26-2009, 05:09 PM
  #3492
whauburger
 
Join Date: Jan 2009
Location: middletown, NY
Posts: 2
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Redcat Racing Tornado Thread

My tornado was running fine and I havn't used it in about two months, when I went to run it the other day it would shut off as soon as it shifted into 2nd gear any ideas?
whauburger is offline  
Reply With Quote
Old 07-26-2009, 05:33 PM
  #3493
neyou86
 
Join Date: Dec 2007
Location: murdock, MN
Posts: 1,065
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Redcat Racing Tornado Thread

adjust it to shift later. that should do the trick
neyou86 is offline  
Reply With Quote
Old 07-26-2009, 05:46 PM
  #3494
neyou86
 
Join Date: Dec 2007
Location: murdock, MN
Posts: 1,065
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Redcat Racing Tornado Thread

hey, im pretty sure my one way bearing is out in my pull start. which one is better the hpi one or the redcat racing one?
neyou86 is offline  
Reply With Quote
Old 07-28-2009, 01:40 AM
  #3495
BigDave09
 
Join Date: May 2009
Location: tallmadge, OH
Posts: 117
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Redcat Racing Tornado Thread

I cant really just wich owb is better but i can say i've had mine owb from redcat for three months and i haven't had a problem I would say there all pro rated the same just depends on how you use yours
BigDave09 is offline  
Reply With Quote
Old 07-28-2009, 12:56 PM
  #3496
Undetermined
 
Join Date: Jul 2009
Location: Odessa, TX
Posts: 14
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Redcat Racing Tornado Thread

Any ideas on how to keep the gas tank from letting air into the lines? When my tank gets below about 1/2 tank, and I hit some little bumps, my car gets a lot of air in the lines and chokes out. Was thinking of some rubber grommets at the bottom where it mounts to the chassis. Not sure yet.
Undetermined is offline  
Reply With Quote
Old 07-28-2009, 02:35 PM
  #3497
neyou86
 
Join Date: Dec 2007
Location: murdock, MN
Posts: 1,065
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Redcat Racing Tornado Thread

hi when i start my tornado it runs good but then i drive it 10 feet and it dies. what is the problem? could it be the fuel tank?
neyou86 is offline  
Reply With Quote
Old 07-28-2009, 09:37 PM
  #3498
chevyderek72
 
chevyderek72's Avatar
 
Join Date: Dec 2007
Location: Mesa, AZ
Posts: 1,784
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Redcat Racing Tornado Thread

Put it back to factory specs and tune from there. Its probably tuning. If you have a crack in your tank then you wont be able to go high rpms because the engine cant suck fuel to it anymore, it needs pressure from the exhaust.
chevyderek72 is offline  
Reply With Quote
Old 07-28-2009, 11:38 PM
  #3499
BigDave09
 
Join Date: May 2009
Location: tallmadge, OH
Posts: 117
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Redcat Racing Tornado Thread


Quote:
ORIGINAL: Undetermined

Any ideas on how to keep the gas tank from letting air into the lines? When my tank gets below about 1/2 tank, and I hit some little bumps, my car gets a lot of air in the lines and chokes out. Was thinking of some rubber grommets at the bottom where it mounts to the chassis. Not sure yet.
check your air lines for leaks first and if it aint that just spend the 5 bucks and get a new tank instead of replaceing the rubber and check for cracks in the tank
BigDave09 is offline  
Reply With Quote
Old 07-31-2009, 10:21 PM
  #3500
basketballfan60123
 
Join Date: Jun 2009
Location: Elgin, IL
Posts: 568
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Redcat Racing Tornado Thread

Just bought the HPI 2speed clutch parts fore my Tornado S30 just wondering how you put this thing together do you use threadlock to assemble it and how do you keep it from falling off the clutch shoes ?
basketballfan60123 is offline  
Reply With Quote
Reply


Thread Tools
Search this Thread
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 02:34 PM.