Redcat Racing Support Moderated Support Forum for all Redcat Racing Cars, Trucks & Buggies

Redcat Racing Tremor Thread

Reply
Old 07-22-2008, 06:53 PM
  #51
Swamp3r
 
Swamp3r's Avatar
 
Join Date: Jan 2008
Location: Edmonton, AB, CANADA
Posts: 1,403
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Redcat Racing Tremor Thread

pour it in don`t mix it with anything, and don`t worry about the questions a stupid question is one thats never asked, lots of peep here to help you.
Swamp3r is offline  
Reply With Quote
Old 07-22-2008, 11:02 PM
  #52
apple718
 
Join Date: Jul 2008
Location: , NY
Posts: 47
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Redcat Racing Tremor Thread

cool thanx i was wondering if the tremor xtb 1/16 buggy is a decent buy? i paid 159 shipped with a starter kit how does that sound
apple718 is offline  
Reply With Quote
Old 07-22-2008, 11:47 PM
  #53
chevyderek72
 
chevyderek72's Avatar
 
Join Date: Dec 2007
Location: Mesa, AZ
Posts: 1,784
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Redcat Racing Tremor Thread

thats good, ive always wanted a 1/16, think i would be fun
chevyderek72 is offline  
Reply With Quote
Old 07-23-2008, 01:59 AM
  #54
Swamp3r
 
Swamp3r's Avatar
 
Join Date: Jan 2008
Location: Edmonton, AB, CANADA
Posts: 1,403
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Redcat Racing Tremor Thread

post some video when you get it broke in right and running
Swamp3r is offline  
Reply With Quote
Old 07-23-2008, 04:02 PM
  #55
apple718
 
Join Date: Jul 2008
Location: , NY
Posts: 47
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Redcat Racing Tremor Thread

i sure will thanks once again
apple718 is offline  
Reply With Quote
Old 11-30-2008, 03:32 AM
  #56
jpilkinton
 
jpilkinton's Avatar
 
Join Date: Apr 2008
Location: Jacksonville, AR
Posts: 870
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Redcat Racing Tremor Thread

Anyone still running 1/16 tremors these days? Or am I the ONLY one???
jpilkinton is offline  
Reply With Quote
Old 12-01-2008, 11:22 AM
  #57
winggee
 
Join Date: Oct 2005
Location: Seattle, WA
Posts: 3
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Redcat Racing Tremor Thread

I just got one couple weeks ago. the buggy version. I managed to break it the first day while breaking it in. for whatever reason, the engine winded up and i was using my foot to keep it from moving while I tried to figure out what was going on. ended up smoking the clutch. I'm waiting on a new clutch to show up now. The plastic exhaust that came on mine is HORRIBLE. The fuel nipple port on the exhaust has no flaring. the fuel line kept popping off, it was highly annoying. I think that's what caused the engine to rev up, I was fiddling with it trying to get the line back on. I ordered a new clutch and a new exhaust, since the pictures of the exhaust looks different than the plastic one I have, it looks more like a normal pipe.
winggee is offline  
Reply With Quote
Old 12-02-2008, 01:15 AM
  #58
jpilkinton
 
jpilkinton's Avatar
 
Join Date: Apr 2008
Location: Jacksonville, AR
Posts: 870
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Redcat Racing Tremor Thread


Quote:
ORIGINAL: winggee

I just got one couple weeks ago. the buggy version. I managed to break it the first day while breaking it in. for whatever reason, the engine winded up and i was using my foot to keep it from moving while I tried to figure out what was going on. ended up smoking the clutch. I'm waiting on a new clutch to show up now. The plastic exhaust that came on mine is HORRIBLE. The fuel nipple port on the exhaust has no flaring. the fuel line kept popping off, it was highly annoying. I think that's what caused the engine to rev up, I was fiddling with it trying to get the line back on. I ordered a new clutch and a new exhaust, since the pictures of the exhaust looks different than the plastic one I have, it looks more like a normal pipe.
Check your throttle linkage to see if it moves without any binding. Don't worry about the muffler, it's like that on all of them. When oil gets on the nipple, the fuel line doesn't like to stay on. What I do is clean the exhaust pipe and fuel line with some cleaner(anything that will remove oil) and take some good super glue and go around the nipple on the pipe and slide the fuel line on the nipple all the way and wait till the glue dries. It will stay there untill you pull it off.
Did you check the drivetrain to make sure nothing is loose? I always check each dogbone for side-to-side play and use fuel tubing to take up the play. I have noticed there is quite a bit of side play in all of the dogbones.
These cars almost need to be taken completely apart and inspected for gear mesh, dogbone play, drive cups, ect..... when you first get them.
Plus it helps you to know how they work and what does what.
If you ever have any problems with your tremor, let me know. I know these things inside and out. I only have 8 of these tremors...... 8-)

jpilkinton is offline  
Reply With Quote
Old 12-25-2008, 03:38 PM
  #59
skifamily88
 
Join Date: Dec 2008
Location: , VA
Posts: 2
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Redcat Racing Tremor Thread

I just got my Tremor XTR today. The directions that came with it are very hard to follow as they are in broken english. I got it started right away and then messed with the needle valve after I shut it down. In the directions it says, "Break-in period 2 and 1/2 turns from full closed position." Are they talking about the needle valve?
skifamily88 is offline  
Reply With Quote
Old 12-25-2008, 06:06 PM
  #60
jpilkinton
 
jpilkinton's Avatar
 
Join Date: Apr 2008
Location: Jacksonville, AR
Posts: 870
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Redcat Racing Tremor Thread


Quote:
ORIGINAL: skifamily88

I just got my Tremor XTR today. The directions that came with it are very hard to follow as they are in broken english. I got it started right away and then messed with the needle valve after I shut it down. In the directions it says, "Break-in period 2 and 1/2 turns from full closed position." Are they talking about the needle valve?
Yes, they are talking about the high speed needle(on the Sh07). If the engine is the 05 Japan engine, there is only one needle to adjust. And they are talking about that one. 2 1/2 turns out.
jpilkinton is offline  
Reply With Quote
Old 12-26-2008, 08:02 PM
  #61
bdobson
 
Join Date: Dec 2008
Location: oakville, ON, CANADA
Posts: 39
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Redcat Racing Tremor Thread

hay guys have a tremor buggy new go to do the break in and the and the wheels dont move even with bit of throttle not too much but should have moved have gone through the break in gas wise but the thing stilll does not move at all????my 1/10 buggy work great cant figer this one out mabby u guys have a clue?
bdobson is offline  
Reply With Quote
Old 12-28-2008, 03:45 AM
  #62
jpilkinton
 
jpilkinton's Avatar
 
Join Date: Apr 2008
Location: Jacksonville, AR
Posts: 870
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Redcat Racing Tremor Thread


Quote:
ORIGINAL: bdobson

hay guys have a tremor buggy new go to do the break in and the and the wheels dont move even with bit of throttle not too much but should have moved have gone through the break in gas wise but the thing stilll does not move at all????my 1/10 buggy work great cant figer this one out mabby u guys have a clue?
Is the spur gear turning with the clutchbell?
Is the wheels too tight from the factory?
How can you do the break-in without the car moving?
Unless you did the idle method which is not affective..
jpilkinton is offline  
Reply With Quote
Old 12-28-2008, 11:04 AM
  #63
shadow21
 
Join Date: Jan 2008
Location: Johns Island, SC
Posts: 52
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Redcat Racing Tremor Thread

I bought my nephew a tremor for his b-day. i went through it and made sure everything was right then we went to break it in. So were taking it easy just very litle throttle and whatnot to break the motor in and boom it shuts off and the pull start is IMPOSSIBLE to pull. I took the motor apart and come to find out a little piece of flash metal came from the port and got wedged in between the piston and sleeve. I was so P-ISSED!! I threw it in the corner and bought him an electric truck. Now he wants to run the thing and im not putting anymore money into it. I mean hell.. We got to see it BARELY roll during the 2nd tank of break in.................
shadow21 is offline  
Reply With Quote
Old 12-28-2008, 02:49 PM
  #64
jpilkinton
 
jpilkinton's Avatar
 
Join Date: Apr 2008
Location: Jacksonville, AR
Posts: 870
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Redcat Racing Tremor Thread


Quote:
ORIGINAL: shadow21

I bought my nephew a tremor for his b-day. i went through it and made sure everything was right then we went to break it in. So were taking it easy just very litle throttle and whatnot to break the motor in and boom it shuts off and the pull start is IMPOSSIBLE to pull. I took the motor apart and come to find out a little piece of flash metal came from the port and got wedged in between the piston and sleeve. I was so P-ISSED!! I threw it in the corner and bought him an electric truck. Now he wants to run the thing and im not putting anymore money into it. I mean hell.. We got to see it BARELY roll during the 2nd tank of break in.................
When and Where did you buy it? Was it new? If you just bought it new, I would talk to Nick at Redcat Racing and see if they can swap the engine out for another one. They have a good engine replacement program. What size engine is in it? Sh .07 or Japan .05?

jpilkinton is offline  
Reply With Quote
Old 12-28-2008, 04:30 PM
  #65
shadow21
 
Join Date: Jan 2008
Location: Johns Island, SC
Posts: 52
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Redcat Racing Tremor Thread

Yea i bought it new. It was really sad because the little guy was so excited about having his first nitro and then BAM it all went down the drain. Im sure one day ill get it back up and going but for now im done with it. Ive spent farrrrrr too much money in the past 4 months on r/c's.
shadow21 is offline  
Reply With Quote
Old 12-28-2008, 04:38 PM
  #66
jpilkinton
 
jpilkinton's Avatar
 
Join Date: Apr 2008
Location: Jacksonville, AR
Posts: 870
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Redcat Racing Tremor Thread


Quote:
ORIGINAL: shadow21

Yea i bought it new. It was really sad because the little guy was so excited about having his first nitro and then BAM it all went down the drain. Im sure one day ill get it back up and going but for now im done with it. Ive spent farrrrrr too much money in the past 4 months on r/c's.
FYI, if you just got it, contact Nick at Redcat Racing and see if he can swap the engine out for a new one since it is new and you just got it. If you throw it in a corner now and not worry about it, you won't have the chance to swap engines since it will be out of warranty.
Talk about throwing money away........
jpilkinton is offline  
Reply With Quote
Old 12-28-2008, 05:18 PM
  #67
bdobson
 
Join Date: Dec 2008
Location: oakville, ON, CANADA
Posts: 39
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Redcat Racing Tremor Thread

hi guys have a tremor buggy new 2 tanks of gas the engine is going the weels dont have any ideas?
bdobson is offline  
Reply With Quote
Old 12-28-2008, 06:43 PM
  #68
jpilkinton
 
jpilkinton's Avatar
 
Join Date: Apr 2008
Location: Jacksonville, AR
Posts: 870
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Redcat Racing Tremor Thread

Quote:
ORIGINAL: bdobson

hi guys have a tremor buggy new 2 tanks of gas the engine is going the weels dont have any ideas?
I asked you earlier how can you break it in with two tanks without the wheels turning?
You may have the brakes set wrong.
To help you further, I need a video or something to show me what it is doing.
Because it is harder to help people that are not mechanically inclined(know how stuff works).
jpilkinton is offline  
Reply With Quote
Old 12-28-2008, 06:51 PM
  #69
bdobson
 
Join Date: Dec 2008
Location: oakville, ON, CANADA
Posts: 39
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Redcat Racing Tremor Thread

i think there might be a drivetrain problem not to sure going to take it a part and c too much friction on the cluch bell i gess
bdobson is offline  
Reply With Quote
Old 01-06-2009, 10:40 PM
  #70
skifamily88
 
Join Date: Dec 2008
Location: , VA
Posts: 2
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Redcat Racing Tremor Thread

I have a nearly new Tremor that won't start. Broke it in and then ran it hard once. Now it won't start. I'm assuming I need new glow plug and have ordered some medium hot ones from Redcat Racing. Is there anything else I need to be doing or should try while they are in the mail? Is med hot the right temp?

Thanks,
Chris
skifamily88 is offline  
Reply With Quote
Old 01-07-2009, 03:26 AM
  #71
jpilkinton
 
jpilkinton's Avatar
 
Join Date: Apr 2008
Location: Jacksonville, AR
Posts: 870
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Redcat Racing Tremor Thread

Quote:
ORIGINAL: skifamily88

I have a nearly new Tremor that won't start. Broke it in and then ran it hard once. Now it won't start. I'm assuming I need new glow plug and have ordered some medium hot ones from Redcat Racing. Is there anything else I need to be doing or should try while they are in the mail? Is med hot the right temp?

Thanks,
Chris
Pull the plug and insert it in the glow igniter and see if the coil glows bright red or orange. If it does, you have a tuning issue. If it don't, charge your igniter and/or try a different plug. Try setting the needles back to stock.
What engine is in it anyways? I have both, the SH .07 and the Infinity .05 engines.
Also, need to know whay brand of fuel you are using. If your using Traxxas Top Fuel 20% Nitro, discard it. That stuff is garbage.
Oh, about the plugs.... I use HOT plugs in all of my small engines. Medium hot should be fine also.
jpilkinton is offline  
Reply With Quote
Old 02-05-2009, 12:22 AM
  #72
EzWired
 
Join Date: Jan 2009
Location: Mission, BC, CANADA
Posts: 1
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Redcat Racing Tremor Thread

Hey guys, Thought i would give my thumbs up to the 1/16th Tremor, what a blast for a first time nitro user. I ended up buying 2 tremors and 2 volcano's almost 2 weeks ago now and so far only have the one tremor broken in,fixed and broken again tonite lol . The day after I purchased them , my room mate had to try and keep up and grabbed 2 tremors as well. We both started with e-maxxes and now wish we started with nitro's lol . I have recently found this forum and a big thanx to the knowledge here, which has slowed me in my normal rip it outa the box and fire it up lol. It should be manditory for beginner nitro's to spend 4 hours here first befor they fire it up lol. I will try and get some pics and footage together soon, hopefully befor i post my first help topic lol .
EzWired is offline  
Reply With Quote
Old 04-11-2009, 01:17 AM
  #73
ginorc
 
Join Date: Feb 2009
Location: , OR
Posts: 4
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Redcat Racing Tremor Thread

Hey, Redcat Tremor Owners,
Do you guys have any troubles with the front, rear, or center diffs on these buggys? I hear that the Sportwerks Chaos diffs alway blow up or melt and I was wondering if Redcat is the same, or all 1:16 scale nitros have the same problem. I want to know before I buy one.
Thanks
ginorc is offline  
Reply With Quote
Old 04-12-2009, 06:47 PM
  #74
thesoulcrusher
 
Join Date: May 2008
Location: worcester, MA
Posts: 120
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Redcat Racing Tremor Thread

Gino.V:

I have two redcat tremor XTK's ... These were the first nitros i ever bought. I had a ton of trouble getting them running and keeping them running initially,, i left them sitting for a yr or so, and recently just took them back out.. I got a bigger engine for one, but i had trouble with the carb so i am waiting on a new one from trinity (who is awful by the way....) ... and the other , the motor works excellent now, but I AM having an issue with the back end. One wheel will stick, the back left wheel, it sticks when you give it throttle, but if you move it and look at it, all looks good... I even took the whole rear-end apart, including the gearbox, and all looked good.. So ,, for now I took out both driveshafts in the rear, so it is only Front wheel drive... It drives excellent, but since its now only Front-wheel drive, it doesn't do as well in the grass and rocks... But I do admit, I have pushed this chasis quite a bit, so I may have damaged the rear end..

I am looking to sell this one cheap if anyone wants it,, looking for about $80... if i cannot sell it, I am considering buying the wheels for the tremor xtr - the 1/16 scale car redcat makes, and turning this into a quick onroad car...

to be honest, i dont think the 1/16th scale monster trucks are worth it, i would go 1/10 or 1/8.. i got a 1/8th Duratrax RT-X27 for only $200!! ...

But I have had many issues with that too.. the motor is a disaster to break in,, and the rotostart backing plate already broke, i would reccommend getting the pullstart if you get this truck..
thesoulcrusher is offline  
Reply With Quote
Old 04-13-2009, 12:28 AM
  #75
chevyderek72
 
chevyderek72's Avatar
 
Join Date: Dec 2007
Location: Mesa, AZ
Posts: 1,784
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Redcat Racing Tremor Thread

Ya the 1/16ths dont do that great in rough terrain, they dont have the ground clearance. If one wheel doesnt wanna spin make sure the wheel nut isnt too tight.
chevyderek72 is offline  
Reply With Quote
Reply


Thread Tools
Search this Thread
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 11:16 PM.