Redcat Racing Support Moderated Support Forum for all Redcat Racing Cars, Trucks & Buggies

WHY ME!!!???!?!?!?

Reply
Old 02-04-2007, 11:19 PM
  #1
nitrospeed33
Thread Starter
 
Join Date: Dec 2006
Location: Denver, CO
Posts: 540
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default WHY ME!!!???!?!?!?

my freind came over for the super bowl today, but it was still early and the weather was great, it was in the 50s with a clear blue sky. so i wanted to show off my car, and he wanted to see it. so it was running really good and it had lots of power. we then made a jump for it. it wasn't high, it was just a small jump and we didn't push it too hard. while my friend was driving it. i made him go really slow though though. he brought it off the jump and as it landed it started to rev high, so i took the controler and gave it some gas and the car didn't move, just revved. so i knew right away that it was the gears, and sure enough my brand new never used gears were shredded to bits. and i was 1000000% sure that the mesh was perfect and that the motor wasn't crooked. so i let it idel till it ran out of fuel, and while we were bringing it in, i realized the engine came loose, so that was why it shredded the gears. so i thought it was no big deal, and i could just retighten the screws and use some thread lock, but 2 of the screws had fallen out! and the engine mount was stripped. so now i need a new engine mount and new screws and new spur gears. i ordered 2 of each spur gear from allaboutfun, but he only sent me one of each cause he was out of stock! man, why does this happen to me. its happened 3 times, 1st time it didn't strip luckily. now i know why this has been happening, i needed new screws and a mount and some thread lock.
nitrospeed33 is offline  
Reply With Quote
Old 02-05-2007, 12:08 AM
  #2
bluecaka69
 
bluecaka69's Avatar
 
Join Date: Feb 2006
Location: bILLINGS, MT
Posts: 2,169
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: WHY ME!!!???!?!?!?

That sucks one thing ive learned is never SHOW OFF your cars I did that when i fisrt got mine told my buddy watch this i ran it full speed right into his truck tire
bluecaka69 is offline  
Reply With Quote
Old 02-05-2007, 07:20 AM
  #3
ehroof
 
Join Date: Feb 2006
Location: howard beach, NY
Posts: 16,490
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: WHY ME!!!???!?!?!?

2 words, BLUE LOCKTITE
ehroof is offline  
Reply With Quote
Old 02-05-2007, 09:56 AM
  #4
nitrospeed33
Thread Starter
 
Join Date: Dec 2006
Location: Denver, CO
Posts: 540
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: WHY ME!!!???!?!?!?

i have the locktite that i used for the cooling head screws, so thats what im useing. hopefully this will never happen again. or else, im getting metal gears, lol
nitrospeed33 is offline  
Reply With Quote
Reply


Thread Tools
Search this Thread
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 05:55 AM.