Redcat Racing Support Moderated Support Forum for all Redcat Racing Cars, Trucks & Buggies

engine problem

Reply
Old 07-26-2007, 02:28 PM
  #1
DS
Thread Starter
 
DS's Avatar
 
Join Date: Dec 2006
Location: Rock Hill, SC
Posts: 1,768
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default engine problem

i have a brand new tornado bb got it tuesday and is having problems. ok when i start the engine it runs but when i pull the glow plug out it stops. can someone please help this is pissing me off[:@]
DS is offline  
Reply With Quote
Old 07-26-2007, 02:57 PM
  #2
Redcat Nick
 
Redcat Nick's Avatar
 
Join Date: Jun 2007
Location: Mesa, AZ
Posts: 493
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: engine problem

Sounds like you have a bad glow plug. It happens after break in and just from normal driving conditions. Some plugs last 1 tank others from the same pack last 1/2 gallon. Just replace it and you shouldn't have any other problems.
Redcat Nick is offline  
Reply With Quote
Old 07-27-2007, 07:50 AM
  #3
{GBI}Harryball
 
{GBI}Harryball's Avatar
 
Join Date: Jul 2006
Location: lansing, MI
Posts: 1,261
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: engine problem


Quote:
ORIGINAL: derek_18mt

i have a brand new tornado bb got it tuesday and is having problems. ok when i start the engine it runs but when i pull the glow plug out it stops. can someone please help this is pissing me off[:@]
Are you pulling the glow plug out of the motor while its running?
{GBI}Harryball is offline  
Reply With Quote
Old 07-27-2007, 08:29 AM
  #4
rclynx
 
rclynx's Avatar
 
Join Date: Sep 2006
Location: Modesto, CA
Posts: 3,965
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: engine problem

Thats what I was wondering[&:]
rclynx is offline  
Reply With Quote
Old 07-27-2007, 10:50 AM
  #5
DS
Thread Starter
 
DS's Avatar
 
Join Date: Dec 2006
Location: Rock Hill, SC
Posts: 1,768
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: engine problem

yes pull it out as soon as it starts
DS is offline  
Reply With Quote
Old 07-27-2007, 11:03 AM
  #6
BaLLZaCH
 
Join Date: Jun 2007
Location: Piedmont, AL
Posts: 84
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: engine problem


[X(][:-] WOW !!!


Will it stay running if you leave it in ??? [sm=omg_smile.gif]

[:-]i hope he is kidding[:-]
BaLLZaCH is offline  
Reply With Quote
Old 07-27-2007, 12:03 PM
  #7
rclynx
 
rclynx's Avatar
 
Join Date: Sep 2006
Location: Modesto, CA
Posts: 3,965
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: engine problem

Are you talking about the glow starter,,,,,,,,,,,,thats the thing you put on top of the glow plug when you start, and when you take it off it dies?[&o]
rclynx is offline  
Reply With Quote
Old 07-27-2007, 12:05 PM
  #8
skrotch
 
Join Date: Jun 2007
Location: , AZ
Posts: 73
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: engine problem

Doesn't everyone that it might be a little obvious that he is talking about the glow plug starter! Give the guy some sort of credit.
skrotch is offline  
Reply With Quote
Old 07-27-2007, 09:42 PM
  #9
DS
Thread Starter
 
DS's Avatar
 
Join Date: Dec 2006
Location: Rock Hill, SC
Posts: 1,768
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: engine problem

thankyou skrotch get a little confused
DS is offline  
Reply With Quote
Reply


Thread Tools
Search this Thread
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 12:08 AM.