Redcat Racing Support Moderated Support Forum for all Redcat Racing Cars, Trucks & Buggies

WISH I HAD MY CAMERA GOING!!!!

Reply
Old 03-19-2008, 07:32 PM
  #1
need2drag
Thread Starter
 
Join Date: Jan 2008
Location: Abilene, KS
Posts: 661
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default WISH I HAD MY CAMERA GOING!!!!

So I jimmy rigged a battery to my starter gun for my Tornado, and got her started and was running in the back yard. Decided to pull out the ramp, and try out some big jumping. After about 5-6 really high jumps, and crashing, I thought about getting the camera, but wife was taking a bath, so I went at the ramp again, good head of steam, and jumping a good 10-15 ft in the air, I thought for sure I was going to wreck. I didn't, landed, bounced a little and off I went. YIPPEE So I come back around and hit it again with even more speed and another good 15 ft jump and landing, I decided to try a flip. Hit the ramp with about the same amount of speed and once it took off I punched the gas, and slowly it started to flip and the flip got faster as momentum of the wheels picked up. Unfortunately I never made it all the way around and landing dead on the tail wing. Rear end is basically gone now. It would have been an awesome sight to get on camera though. But unfortunately I didn't have it out. So I took pics of the damage.
Attached Thumbnails
Click image for larger version

Name:	Ca80846.jpg
Views:	7
Size:	89.3 KB
ID:	908062   Click image for larger version

Name:	Up47620.jpg
Views:	5
Size:	90.5 KB
ID:	908063   Click image for larger version

Name:	Kp35174.jpg
Views:	8
Size:	102.7 KB
ID:	908064   Click image for larger version

Name:	Zt53955.jpg
Views:	6
Size:	119.4 KB
ID:	908065   Click image for larger version

Name:	Uf51467.jpg
Views:	9
Size:	103.3 KB
ID:	908066  

Click image for larger version

Name:	Cs15811.jpg
Views:	6
Size:	116.9 KB
ID:	908067   Click image for larger version

Name:	Ce71895.jpg
Views:	9
Size:	103.8 KB
ID:	908068  
need2drag is offline  
Reply With Quote
Old 03-19-2008, 07:45 PM
  #2
ehroof
 
Join Date: Feb 2006
Location: howard beach, NY
Posts: 16,490
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: WISH I HAD MY CAMERA GOING!!!!

wow, that sucks
ehroof is offline  
Reply With Quote
Old 03-19-2008, 07:47 PM
  #3
need2drag
Thread Starter
 
Join Date: Jan 2008
Location: Abilene, KS
Posts: 661
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: WISH I HAD MY CAMERA GOING!!!!

yeah it does, but I am really not mad about the car being broken....mad that I didn't have a camera going though. I think I could have won the "biggest air" contest...lol It is all good though. Dad gave me his condor a week or so ago for spare parts and I think the rear end is a lot a like. I might be able to make something work.\
need2drag is offline  
Reply With Quote
Old 03-19-2008, 08:11 PM
  #4
Chubbysdad
 
Join Date: Jun 2005
Location: Clermont, FL
Posts: 2,824
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: WISH I HAD MY CAMERA GOING!!!!

if not I might have an extra used chasis for ya.. let me know.
Chubbysdad is offline  
Reply With Quote
Old 03-19-2008, 08:18 PM
  #5
need2drag
Thread Starter
 
Join Date: Jan 2008
Location: Abilene, KS
Posts: 661
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: WISH I HAD MY CAMERA GOING!!!!

what would you want for it?
need2drag is offline  
Reply With Quote
Old 03-19-2008, 08:19 PM
  #6
Chubbysdad
 
Join Date: Jun 2005
Location: Clermont, FL
Posts: 2,824
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: WISH I HAD MY CAMERA GOING!!!!

you pay the shipping and you can have it. I will double check the store tomorrow. I think its from a tsunami so it is purple though if the color doesn't matter.
Chubbysdad is offline  
Reply With Quote
Old 03-19-2008, 08:29 PM
  #7
need2drag
Thread Starter
 
Join Date: Jan 2008
Location: Abilene, KS
Posts: 661
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: WISH I HAD MY CAMERA GOING!!!!

so what all is on the chassis?
need2drag is offline  
Reply With Quote
Old 03-19-2008, 08:41 PM
  #8
Chubbysdad
 
Join Date: Jun 2005
Location: Clermont, FL
Posts: 2,824
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: WISH I HAD MY CAMERA GOING!!!!

most of the front and rear suspension, servo tray, batter box and I think a stripped out gear box lol.
Chubbysdad is offline  
Reply With Quote
Old 03-19-2008, 08:58 PM
  #9
need2drag
Thread Starter
 
Join Date: Jan 2008
Location: Abilene, KS
Posts: 661
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: WISH I HAD MY CAMERA GOING!!!!

sounds good. So will all of that should work on my tornado I am guessing, and no color does not matter. Let me know how much shipping would be and I will let you know when I can do it.
need2drag is offline  
Reply With Quote
Old 03-19-2008, 09:00 PM
  #10
Chubbysdad
 
Join Date: Jun 2005
Location: Clermont, FL
Posts: 2,824
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: WISH I HAD MY CAMERA GOING!!!!

probably about 5-6.00 is all. I am not looking to make money on it just to help ya out.
Chubbysdad is offline  
Reply With Quote
Old 03-19-2008, 09:03 PM
  #11
need2drag
Thread Starter
 
Join Date: Jan 2008
Location: Abilene, KS
Posts: 661
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: WISH I HAD MY CAMERA GOING!!!!

thats cool. I am really broke right now. I was off of work for a week and with no pay due to an injury so even 5 bucks is tight. I will see what I can do to get it though. Wife is getting mad that I keep spending money on my 2 cars. he he. I will let you know when I can do it, but I definitely want it.
need2drag is offline  
Reply With Quote
Old 03-19-2008, 09:04 PM
  #12
jumpanddrop
 
Join Date: Feb 2008
Location: , BC, CANADA
Posts: 808
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: WISH I HAD MY CAMERA GOING!!!!


Quote:
ORIGINAL: need2drag

So I jimmy rigged a battery to my starter gun for my Tornado, and got her started and was running in the back yard. Decided to pull out the ramp, and try out some big jumping. After about 5-6 really high jumps, and crashing, I thought about getting the camera, but wife was taking a bath, so I went at the ramp again, good head of steam, and jumping a good 10-15 ft in the air, I thought for sure I was going to wreck. I didn't, landed, bounced a little and off I went. YIPPEE So I come back around and hit it again with even more speed and another good 15 ft jump and landing, I decided to try a flip. Hit the ramp with about the same amount of speed and once it took off I punched the gas, and slowly it started to flip and the flip got faster as momentum of the wheels picked up. Unfortunately I never made it all the way around and landing dead on the tail wing. Rear end is basically gone now. It would have been an awesome sight to get on camera though. But unfortunately I didn't have it out. So I took pics of the damage.
hey need2drag, how did you jimmy rig the battery for your starter. i love my roto start but i hate when my battery go's dead and im to cheap to buy a new battery right now. have any pics??
jumpanddrop is offline  
Reply With Quote
Old 03-19-2008, 09:08 PM
  #13
need2drag
Thread Starter
 
Join Date: Jan 2008
Location: Abilene, KS
Posts: 661
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: WISH I HAD MY CAMERA GOING!!!!

ok, don't laugh too hard....I took a battery from my 18V drill and wrapped some speaker wire around the positive and negative ends, and then clamped the wire down with vice grips, and then stuck the other end into the corresponding ends of the plug for the starter. Thus giving me power to start my car. pretty cheap and cheezy................and ghetto, but it worked.
need2drag is offline  
Reply With Quote
Old 03-19-2008, 09:09 PM
  #14
jumpanddrop
 
Join Date: Feb 2008
Location: , BC, CANADA
Posts: 808
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: WISH I HAD MY CAMERA GOING!!!!

nice. lol why didint you just use your drill lol.
jumpanddrop is offline  
Reply With Quote
Old 03-19-2008, 09:13 PM
  #15
need2drag
Thread Starter
 
Join Date: Jan 2008
Location: Abilene, KS
Posts: 661
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: WISH I HAD MY CAMERA GOING!!!!

cuz the drill doesn't spin fast enough. Kinda weird I know, but it doesn't so I read up on my drill and I found out the drill was built more for torgue than speed. Sounds like I am talking about a car, but I swear I am talking about my drill.
need2drag is offline  
Reply With Quote
Old 03-19-2008, 09:17 PM
  #16
jumpanddrop
 
Join Date: Feb 2008
Location: , BC, CANADA
Posts: 808
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: WISH I HAD MY CAMERA GOING!!!!


Quote:
ORIGINAL: need2drag

cuz the drill doesn't spin fast enough. Kinda weird I know, but it doesn't so I read up on my drill and I found out the drill was built more for torgue than speed. Sounds like I am talking about a car, but I swear I am talking about my drill.
lol mine dose. well it kinda pi$$ed me off b/c i found that my cordless drill and my roto starter was dead[>:], so i tryed a regular cord drill,man they dont have to turn fast at all. just give it a little gas and it should start. lol my engine was barly turning over and it still started. the cordlesss drills spin way faster to so i think it should work if it has 2 speeds
jumpanddrop is offline  
Reply With Quote
Old 03-19-2008, 09:19 PM
  #17
need2drag
Thread Starter
 
Join Date: Jan 2008
Location: Abilene, KS
Posts: 661
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: WISH I HAD MY CAMERA GOING!!!!

mine doesn't. Trust me. I tried to start it with the drill several times and it never turned it over. It is one of those things you have to see to believe. Once I hooked the battery up to the actual starter and pulled that trigger my car started right up. It is crazy the difference in the 2. I don't have a speed control on my drill, just torque settings.
need2drag is offline  
Reply With Quote
Old 03-19-2008, 09:20 PM
  #18
need2drag
Thread Starter
 
Join Date: Jan 2008
Location: Abilene, KS
Posts: 661
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: WISH I HAD MY CAMERA GOING!!!!

I will put it to you this way. When I tried my drill I went through one compression cycle about every 4-5 seconds. That is how slow it spins.
need2drag is offline  
Reply With Quote
Old 03-19-2008, 09:32 PM
  #19
jumpanddrop
 
Join Date: Feb 2008
Location: , BC, CANADA
Posts: 808
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: WISH I HAD MY CAMERA GOING!!!!

ohhh. ya thats way to slow. mine was turning like 1 cycle a sec. man 18v on the roto starter must have been fast. you usaly have like 7 or 8 volts. what happend to your battery???
jumpanddrop is offline  
Reply With Quote
Old 03-19-2008, 09:33 PM
  #20
need2drag
Thread Starter
 
Join Date: Jan 2008
Location: Abilene, KS
Posts: 661
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: WISH I HAD MY CAMERA GOING!!!!

nothing. I don't even think it took that much power away from it. And yeah, it spun pretty damn fast. lol.
need2drag is offline  
Reply With Quote
Old 03-19-2008, 09:36 PM
  #21
jumpanddrop
 
Join Date: Feb 2008
Location: , BC, CANADA
Posts: 808
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: WISH I HAD MY CAMERA GOING!!!!

lol i ment like the battery for the roto.w/e it dosent matter
jumpanddrop is offline  
Reply With Quote
Old 03-19-2008, 09:37 PM
  #22
Swamp3r
 
Swamp3r's Avatar
 
Join Date: Jan 2008
Location: Edmonton, AB, CANADA
Posts: 1,403
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: WISH I HAD MY CAMERA GOING!!!!


Quote:
ORIGINAL: Clermont Hobby

probably about 5-6.00 is all. I am not looking to make money on it just to help ya out.
This is why I love this community.
Swamp3r is offline  
Reply With Quote
Old 03-19-2008, 09:43 PM
  #23
Chubbysdad
 
Join Date: Jun 2005
Location: Clermont, FL
Posts: 2,824
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: WISH I HAD MY CAMERA GOING!!!!

send your address in an email to clermonthobby@embarqmail.com and say its for the chasis. i will send it out. we will work something out. 5.00 isn't going to kill me
Chubbysdad is offline  
Reply With Quote
Old 03-19-2008, 09:43 PM
  #24
firebird78
 
Join Date: Dec 2007
Location: lewis, KS
Posts: 3,141
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: WISH I HAD MY CAMERA GOING!!!!

the reason he had to engineer a battery for his roto start is because his lame friend hasnt shipped him a battery pack yet...lol
firebird78 is offline  
Reply With Quote
Old 03-20-2008, 05:16 AM
  #25
need2drag
Thread Starter
 
Join Date: Jan 2008
Location: Abilene, KS
Posts: 661
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: WISH I HAD MY CAMERA GOING!!!!


Quote:
ORIGINAL: jumpanddrop

lol i ment like the battery for the roto.w/e it dosent matter
I got the gun from my dad, and he didn't have a battery for it.
need2drag is offline  
Reply With Quote
Reply


Thread Tools
Search this Thread
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 11:46 PM.