Redcat Racing Support Moderated Support Forum for all Redcat Racing Cars, Trucks & Buggies

TornadoBB with HPI clutchbell problems.

Reply
Old 04-17-2008, 11:14 AM
  #1
yamanube
Thread Starter
 
Join Date: Oct 2006
Location: forest lake, MN
Posts: 22
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default TornadoBB with HPI clutchbell problems.

Been lurking around gathering info and advice on my new BB. Just bought it a couple weeks ago and figured I would upgrade the clutchbell, spring and gears before running it. Finally got around to giving it a once over, checking all the hardware and started to install my new clutchbell last night but hit a snag. I put the orginal bearings in the bell and used the original screw and washers but it seems the surface between the bearings is thinner on the new bell causing the PTO shaft to protrude past the bearing and thus allowing the assembly to walk back and forth on the shaft when the screw is tightened down. I ordered all the parts listed in the sticky thread and thought it would be a direct swap....it doesnt look to me like adding washers behind the bearings would work because that would push the gears out of alignment. Any help would be appreciated, I really want to get this thing running, will probably end up swapping the stock bell back on for break in.
yamanube is offline  
Reply With Quote
Old 04-17-2008, 03:15 PM
  #2
ehroof
 
Join Date: Feb 2006
Location: howard beach, NY
Posts: 16,490
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: TornadoBB with HPI clutchbell problems.

which clutch bell are you using?
ehroof is offline  
Reply With Quote
Old 04-17-2008, 03:26 PM
  #3
yamanube
Thread Starter
 
Join Date: Oct 2006
Location: forest lake, MN
Posts: 22
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: TornadoBB with HPI clutchbell problems.

Sent you a PM ehroof
yamanube is offline  
Reply With Quote
Old 04-17-2008, 03:32 PM
  #4
ehroof
 
Join Date: Feb 2006
Location: howard beach, NY
Posts: 16,490
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: TornadoBB with HPI clutchbell problems.

no problem bro, we will figure it out
ehroof is offline  
Reply With Quote
Old 04-17-2008, 05:44 PM
  #5
chevyderek72
 
chevyderek72's Avatar
 
Join Date: Dec 2007
Location: Mesa, AZ
Posts: 1,784
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: TornadoBB with HPI clutchbell problems.

mine does the same thing, slides back and forth a little bit, and its been workin great, had no problems
chevyderek72 is offline  
Reply With Quote
Old 04-17-2008, 08:11 PM
  #6
yamanube
Thread Starter
 
Join Date: Oct 2006
Location: forest lake, MN
Posts: 22
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: TornadoBB with HPI clutchbell problems.

By a little I mean 1/10" maybe more.
yamanube is offline  
Reply With Quote
Reply


Thread Tools
Search this Thread
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 09:40 AM.