Redcat Racing Support Moderated Support Forum for all Redcat Racing Cars, Trucks & Buggies

WHO RAN WHAT???

Reply
Old 08-11-2008, 05:48 PM
  #1
chevyderek72
Thread Starter
 
chevyderek72's Avatar
 
Join Date: Dec 2007
Location: Mesa, AZ
Posts: 1,784
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default WHO RAN WHAT???

Come on guys nobody ever responds to this, who ran this weekend. i just got back from running in this parking lot with the girlfriend, she is doin better but hit a curb and busted the steering hub on the volcano, easy fix. but other than that the tornado bb and volcano were runnin great. put a couple tanks on each and then she had ot go to the dentist [:'(] so when she gets back were goin to her house to drive around. she lives in the desert area. im in more of the city, but where she is its just dirt, cactuses, and bushes and stuff. tons on stuff to romp too
chevyderek72 is offline  
Reply With Quote
Old 08-11-2008, 05:58 PM
  #2
Kemo
 
Join Date: May 2004
Posts: 7,071
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: WHO RAN WHAT???

Happily ran the TT5 this weekend at work. Everyone absolutely loves it... and thankfully, still have yet to break a part! *knocks on wood*
Kemo is offline  
Reply With Quote
Old 08-11-2008, 06:01 PM
  #3
Defmeq
 
Join Date: Jul 2007
Location: Lexington, IL
Posts: 219
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: WHO RAN WHAT???

I ran my Avalanche at a buddies farm for several hours on sunday afternoon. He had out his electric traxxas stampede and as usual the avalanche stold the show. We built a few small ramps and did a little dirt pile crawling. No parts broke! Still thinking really hard about getting a Sandstorm or a Tornado S30!

Defm
Defmeq is offline  
Reply With Quote
Old 08-11-2008, 06:10 PM
  #4
amf66
 
amf66's Avatar
 
Join Date: Apr 2008
Location: Houston, TX
Posts: 595
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: WHO RAN WHAT???

Just get the hurricane from [link]http://www.affordablerc.com[/link]. I think that they have the best prices on Redcats and the owner has responded fast to my questions.
amf66 is offline  
Reply With Quote
Old 08-11-2008, 06:28 PM
  #5
Kodiac400
 
Join Date: Oct 2007
Location: Richibucto, NB, CANADA
Posts: 309
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: WHO RAN WHAT???

I put 2 tanks through the Tsunami Sunday and 2 more tonight. Its still holding strong. Had it going full speed and had it doing pounding cartwheels. I was sure something was going to break...................... after the dust settled all I broke was the antenna tube...............ya baby I love this thing. Almost have my first gallon through it.
Kodiac400 is offline  
Reply With Quote
Old 08-11-2008, 08:36 PM
  #6
mrlee2071
 
mrlee2071's Avatar
 
Join Date: Jan 2008
Location: Clovis, CA
Posts: 147
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: WHO RAN WHAT???

In between remodeling my bathroom and work I managed to get one tank through my Hurricane. Ran SWEET
mrlee2071 is offline  
Reply With Quote
Old 08-12-2008, 11:04 AM
  #7
madmarty
 
Join Date: Sep 2007
Location: phoenix, AZ
Posts: 111
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: WHO RAN WHAT???

ran my monsoon for about 30 min. just too bloody hot out to run any longer. but it still is ripping up the desert!!!
madmarty is offline  
Reply With Quote
Old 08-12-2008, 12:59 PM
  #8
chevyderek72
Thread Starter
 
chevyderek72's Avatar
 
Join Date: Dec 2007
Location: Mesa, AZ
Posts: 1,784
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: WHO RAN WHAT???

ya its hot, but i doesnt bother me (no ac in my truck). and its so worth it though.
chevyderek72 is offline  
Reply With Quote
Old 08-17-2008, 09:30 PM
  #9
stagga
 
Join Date: Apr 2008
Location: Bay, BERMUDA
Posts: 136
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: WHO RAN WHAT???

my tornado was runnin good on saturday. my buddy had his jato out, breakin in his new engine. so for once my car was quicker than his lol. we got to talkin about how his jato looks a lot more stable on corners since it has a much wider stance. then he had an idea that his wheels should fit on my car, so i put a spare jet of the stock jato wheels on my tornado....and yes they do it!!....sort of lol. the threaded axel isn't quite long enough for the hex to to go fully on. so after a couple laps with rear jato wheels on my rear....one of the wheels came off!! i engine revved all the way up and blew the exhaust gasket as well. 3 of us spent the next 10-15mins walkin around the parkin lot in the 90degree sun for the hex nut. EVENTUALLY my friend found it along with a dog bone that had popped out n i had no idea it came out lol. i got the car started back up n took a couple laps roudn the parking lot and the car cut out. and then it refused to start back up. i have no idea what the problem is. there was gas in it, changed the glow plug, checked to see if the engine was flooded and even used 3 different glow starters...NOTHING! so that was it for the day. i'll try diagnose the problem this week. any suggestions?
stagga is offline  
Reply With Quote
Old 08-18-2008, 06:33 AM
  #10
Kemo
 
Join Date: May 2004
Posts: 7,071
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: WHO RAN WHAT???

check to see if you damaged the rod when it over rev'd.
Kemo is offline  
Reply With Quote
Old 08-24-2008, 09:50 AM
  #11
Kemo
 
Join Date: May 2004
Posts: 7,071
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: WHO RAN WHAT???

update to what was ran this weekend...

Discovered a few issues with the Rampage. All 4 gears transferring power from engine to the center "diff" are all melted/chewed up. Driveshafts are losing their pins, and the tires are literally falling apart on the sidewalls (note that I run on dirt and grass).

Cant wait to hear from redcat on the 050009 universal shafts! Hoping they are the grand solution to this shafty problem!
Kemo is offline  
Reply With Quote
Old 08-24-2008, 08:02 PM
  #12
Chubbysdad
 
Join Date: Jun 2005
Location: Clermont, FL
Posts: 2,824
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: WHO RAN WHAT???

very common. the heat from friction kills them. I have a different brand and that was the first thing I upgraded.
Chubbysdad is offline  
Reply With Quote
Old 08-25-2008, 04:06 PM
  #13
Kemo
 
Join Date: May 2004
Posts: 7,071
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: WHO RAN WHAT???

yeah I figured it had something to do with me haulin tail out in a field (could only see the wing). Had a blast killing the gears though, everyone had a blast watching the tall grass getting mowed over.

Supposedly CVD's/universal joints cant possibly be made strong enough for the power these engines are capable of producing... hopefully HSP can bust that myth. Last time I checked, HPI was doing pretty well with theirs!

As far as the replacement shafts, anyone notice a difference? or are they not improved yet?
Kemo is offline  
Reply With Quote
Old 08-25-2008, 05:59 PM
  #14
Chubbysdad
 
Join Date: Jun 2005
Location: Clermont, FL
Posts: 2,824
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: WHO RAN WHAT???

also go with a metal pinion. The heat from the clutchbell melts the pinions pretty fast. well at least on all other brands. I dont have the redcat
Chubbysdad is offline  
Reply With Quote
Old 08-26-2008, 12:17 PM
  #15
Kemo
 
Join Date: May 2004
Posts: 7,071
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: WHO RAN WHAT???

Actually, the pinion is the only gear that is salvageable. Everything else is like dried up wax. We'll see what the aftermarket has to throw at us.
Kemo is offline  
Reply With Quote
Old 08-26-2008, 04:21 PM
  #16
stagga
 
Join Date: Apr 2008
Location: Bay, BERMUDA
Posts: 136
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: WHO RAN WHAT???

well i broke my switch again on my tornado...the 1 that turns on the power to the servos. so i just plugged my hump pack directly into the receiver. this worked well for a while...until it slipped out and the steering and throttle died (luckily i was almost to a stop).....that SHOULD have been a sign...but i just plugged it back in and raced up n down the parking lot some more. about a tank later the car was wide open and the same thing happened again! but this time the car stayed wide open and headed straight for a small curb...smacked it!! and flew across a small road and into a chain link fence on the other side looking like a platform diver in the olympics with a 3.7 degree of difficulty. (missing a telephone pole by about a foot) luckily the fence somewhat caught the car...rather than it smashing into a solid wall or the telephone pole. when it landed it was still wide open on its hood until it stalled. didin't really break anything...just a few things flew off. 1 rear shock came off, dog bone was severely bent, dog bone for the front drive shaft popped out but i lost the drive cup for it and the air filter came off (it didn't seem to suck in any dirt while it was laying on its top) i put the parts that came off back on and ran it as rear wheel drive...good as new! lol
stagga is offline  
Reply With Quote
Reply


Thread Tools
Search this Thread
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 11:39 PM.