Redcat Racing Support Moderated Support Forum for all Redcat Racing Cars, Trucks & Buggies

Steering question about Vortex.

Reply
Old 09-07-2009, 08:35 PM
  #1
tolofrhr
Thread Starter
 
Join Date: Jan 2007
Location: San Antonio, TX
Posts: 36
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Steering question about Vortex.

Quick question about the steering. Has anyone noticed that the vehicle seems to really slow down when turning? It seems like the truck binds up when making turns. I'm using the stock electronics except for a Tower Hobbies steering servo. The stock one was EXTREMELY slow. It just seems kind of odd the way it does. Maybe it's just me or just a trait of the truck.[8D]
tolofrhr is offline  
Reply With Quote
Old 09-08-2009, 01:36 PM
  #2
rjsdad
 
Join Date: Dec 2007
Location: hutto, TX, AMERICAN SAMOA (USA)
Posts: 247
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Steering question about Vortex.

Once I upgraded my steering and throttle, i could not believe has responsive my buggy was. I did not think that I would notice that much.
rjsdad is offline  
Reply With Quote
Old 09-08-2009, 11:15 PM
  #3
chevyderek72
 
chevyderek72's Avatar
 
Join Date: Dec 2007
Location: Mesa, AZ
Posts: 1,784
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Steering question about Vortex.

Are you talking about the electric vortex?
chevyderek72 is offline  
Reply With Quote
Old 09-13-2009, 07:55 PM
  #4
AllAboutFunHobbies
 
AllAboutFunHobbies's Avatar
 
Join Date: Dec 2006
Location: Euless, TX
Posts: 3,096
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Steering question about Vortex.


Quote:
ORIGINAL: tolofrhr

Quick question about the steering. Has anyone noticed that the vehicle seems to really slow down when turning? It seems like the truck binds up when making turns. I'm using the stock electronics except for a Tower Hobbies steering servo. The stock one was EXTREMELY slow. It just seems kind of odd the way it does. Maybe it's just me or just a trait of the truck.[8D]
I believe he is talking about the electric one.

If in fact you are talking about the electric one, then the reason it slows down is because the whole car works off that one battery that you are using. If you are using NIMH battery packs then that is normal depending on the Milli amps of the battery. If you are using anything less than 2200mah battery than you will get approximately 10 to 15 minutes of run time with noticeable lag when you are steering. My suggestion if you REALLY REALLY want to enjoy hobby grade electric Upgrade to a 3300mah or better battery or go lipo.
AllAboutFunHobbies is offline  
Reply With Quote
Old 09-13-2009, 08:41 PM
  #5
tolofrhr
Thread Starter
 
Join Date: Jan 2007
Location: San Antonio, TX
Posts: 36
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Steering question about Vortex.


Quote:
ORIGINAL: chevyderek72

Are you talking about the electric vortex?
Yes. It's Exceed's version but it's the same thing.
I'm running some 4600 packs. It does it no matter which batteries I use. It's not terrible, it's just noticable. Either I've never noticed with my other R/C's or it's just a trait of this one. I have about 35 other cars and trucks.
tolofrhr is offline  
Reply With Quote
Old 09-14-2009, 01:57 AM
  #6
chevyderek72
 
chevyderek72's Avatar
 
Join Date: Dec 2007
Location: Mesa, AZ
Posts: 1,784
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Steering question about Vortex.

Well it should be because your servo it taking some of the power from the battery so the motor can get as much. What you can do is get a hump pack or a 4 cell reciever pack and plug it into the reciever so the servo get power from those vs taking it from the main battery.
chevyderek72 is offline  
Reply With Quote
Old 09-14-2009, 07:10 PM
  #7
AllAboutFunHobbies
 
AllAboutFunHobbies's Avatar
 
Join Date: Dec 2006
Location: Euless, TX
Posts: 3,096
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Steering question about Vortex.

Oh good thinking. Never thought of that. I think this slowing down thing is a trait of these cars. I never noticed it in my SC10 when I was running NIMH at least not until the battery was nearly dead. Don't have it at all with the lipos.
AllAboutFunHobbies is offline  
Reply With Quote
Reply


Thread Tools
Search this Thread
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 09:25 PM.