RCU Forums

RCU Forums (http://www.rcuniverse.com/forum/)
-   Redcat Racing Support (http://www.rcuniverse.com/forum/redcat-racing-support-427/)
-   -   Redcat Sandstorm HELP! PLEASE HELP ME! (http://www.rcuniverse.com/forum/redcat-racing-support-427/11589916-redcat-sandstorm-help-please-help-me.html)

joed23 11-13-2013 05:01 AM

Redcat Sandstorm HELP! PLEASE HELP ME!
 
Hellp again please! http://youtu.be/CHLYhYyv1VM

RedCat-Billy 11-13-2013 01:51 PM

Hello,

Your problem seems to be that you have the plug from the ESC plugged into the VCC port in the receiver, when it should be plugged into CH2. This is why you are still getting power to your servo, but your radio trigger is not controlling the ESC.

Thanks,
Billy Fischer
Redcat Racing

joed23 11-13-2013 03:10 PM

Thanks for your support! But even when i put the ESC cable in the CH2 spot the car never seems to move

RedCat-Billy 11-13-2013 03:12 PM

No problem! Your best bet will be to give our shop a call and speak to one of our technicians when you have your vehicle and radio in front of you. They will help you through some troubleshooting and will hopefully be able to get you up and running over the phone. (602) 454-6445. We are open Monday-Friday, 8:00am-4:00pm, Arizona time.

joed23 11-13-2013 03:35 PM

Thanks man!

RedCat-Billy 11-14-2013 08:01 AM

No problem! I really hope we can get this worked out over the phone.

nitrosportsandrunner 11-14-2013 03:43 PM

my guess is your throttle trim on the radio got moved....so when you turn on the car it does not sense Neutral position from the radio and thus will not arm.
Put the truck on a box or something so that the wheels are not on the ground. turn it on, and then slowly adjust the throttle trim until the motor starts to move a little. then back it off a tad and it should be in neutral position and the throttle should now work.
The other option which will accomplish the same thing is to recalibrate the ESC.
Hold that button by the on/off switch while turning it on. the eSC should beep. hit the button again. then pull full throttle on the radio and hold and hit that button a 2nd time. (again, have the truck off the ground when doing this) Now apply full brakes and then hit the button a 3rd time.
Release the radio trigger. turn off the car and then the radio.

Of course, you must have the ESC plugged into port #2 on the receiver as Redcatbilly said.
turn back on and see if it works.

joed23 11-14-2013 05:08 PM

Thanks but it seems to still not work im going to post a vid up again of me doing the steps that you instructed me to do!

joed23 11-15-2013 01:12 PM

http://www.youtube.com/watch?v=bHmBD...ature=youtu.be

RedCat-Billy 11-15-2013 02:05 PM

Thank you for the video. If you can, please give me a call directly here at our shop (with your vehicle and radio in front of you) within the next hour, and I will gladly help walk you through everything. There is a chance that something else may be wrong, and we can walk through some more troubleshooting. (602) 454-6445.

Thanks,
Billy

sandstorm55 05-21-2014 04:47 AM

[QUOTE=joed23;11661334]Hellp again please! http://youtu.be/CHLYhYyv1VM[/QUO

Sounds like you have the same issue as I did I called redcat racing and it was determined to be my ESC that was the problem they sent me a new one no questions asked and it was shipped quick and my Sandstorm is was back in running condition that was the problem now I broke something else as now it barely moves guess I stripped the spur gear have to tear into it and figure what I broke. Redcat support was awesome with the ESC troubleshooting give them a call I'm sure they will help you out.


All times are GMT -8. The time now is 09:35 AM.