RCU Forums

RCU Forums (http://www.rcuniverse.com/forum/)
-   Redcat Racing Support (http://www.rcuniverse.com/forum/redcat-racing-support-427/)
-   -   Has this happened to anyone??? (http://www.rcuniverse.com/forum/redcat-racing-support-427/3863284-has-happened-anyone.html)

ryang20 02-03-2006 11:28 AM

Has this happened to anyone???
 
I just got my Volcano Stx and was doing the breakin. I had the engine running and I flipped the switch for more breaking on the control. The truck took off at full speed, without touching the gas on the control and crashed. The whole front end was totally destroyed. I had it for 1 hour and now it's trashed. The parts will probably cost well over 100.00. Wondering what went wrong. There was no mention in the owners manual on how to use the switches or what to do if you wanted to change settings on the controller.

stampede100 02-03-2006 03:23 PM

RE: Has this happened to anyone???
 
a little advise is to set the truck on a block so the tires arnt touching the ground, then turn it on, and then turn the controller on, then if it starts to go play with the controller until the tires stop turning, or it could need an ajustment on the engine some where, the parts are not exspencive, just go to www.himoto.com click on red cat rides, and click the truck, then on the right side of the sceen there should be a little grey box, in there it should say parts or something like,
good luck,
shane

wildspeed 02-03-2006 04:00 PM

RE: Has this happened to anyone???
 
Check http://www.rcuniverse.com/forum/m_3775380/tm.htm
I ask the same thing about the controller switches and got the answer.

fastarmyguy 02-05-2006 01:56 PM

RE: Has this happened to anyone???
 
does any one have any idea why i cant get my new red cat started. I have the 1/10 buggy .18 motor, and it fluds. I have done the adjustments on the carb with no luck. Also, does the glow plug only work off and on with the igniter attached or should it stay hot the whole time the igniter is attached. This crap is frustrating to try and get this car running.

Thanks

Xeller8 02-05-2006 04:35 PM

RE: Has this happened to anyone???
 
The glow plug should glow bright orange the ENTIRE time the ignitor is hooked up.

I found that it seems to help if you leave the ignitor hooked up when you first get it running to do your initial tuning before putting her on the ground and start running....take it off before you start driving around of course.

j-boy 02-11-2006 12:36 PM

RE: Has this happened to anyone???
 
a good trick I learned is to warm up my engine with a blow dryer before starting. The first time I try'd to start mi cyclone it was really cold outside. I got frustrated and went to the universe to get help. Nobody said anything abouty blow dryers but I did hear a lot of talk about weather temperature affecting the engine and thats what gave me the idea. As soon as I warmed up the engine it started right up. The only problem was that by this time I was so convinced that it wasn't going to start that I wasn't ready when it did. If it had been on the ground it would have taken off like a shot. Luckily the first thing I did after recieving my cyclone was to build a stand to set it on that keeps the wheels off the ground.( I'm not trying to flame you ryang20 and I can feel for you because The first time I actually drove the buggy I wasn't ready for how fast it was and drove it straight into a fence post. So I messed up my front end right out of the gate too!:() Anywhoo Try the blow dryer if the temp outside is below around 40 degrees F. good luck and stay with it. Now that I've got the basics figured out this hobby is so much fun. By the way, for me, "figuring out the basaics" took about 2 months and a lot of tears, but it was all worth it!

chopper22980 02-13-2006 02:12 PM

RE: Has this happened to anyone???
 
Ive found that if you take off the hose from the end of the exhaust and blow in a few times.
That will prime your carb.Just watch as the fuel goes down the line into the carb.I found that
easier then to open the carb and adding a couple drops of fuel.It may take a few times doing it
to get the feel for it.Hope this will help with the flooding problem.

Chubbysdad 02-13-2006 04:01 PM

RE: Has this happened to anyone???
 
Just hold your finger over the exhaust, and pull easy a few times and you will watch the fuel go right up the line to the carb.

redrooster 02-22-2006 08:21 PM

RE: Has this happened to anyone???
 
i was just going through the forums and when i came upon this one it made me laugh cause i did the same thing when i first got my car ( tornado xl )switching that button and seeing the car take off scared the crap out of me. luckly it only jumped a 4 foot tall snow bank landed on its wheels took off from there and hit another snow bank and fliped over where i caught up to it, riped the top off and kinked the gas line so i could shut it off. the only thing that broke was the top when i ripped it off. im really lucky that my car was pointing in the right direction when i came up with that good idea to switch that button. and iv seen a few other forums that said they did the same thing also so it makes me feel better that im not the only one that has done that. but we all learn from it, and im sure im not going to do that again. i think they should put a warining sing in the manual for the beginers to make ajustments with the car on a block or something. cause in my manual there was no warning.


All times are GMT -8. The time now is 12:58 AM.