Scratch Building, Aircraft Design, 3D/CAD If you are starting/building a project from scratch or want to discuss design, CAD or even share 3D design images this is the place. Q&A's.

Delta 16" scroll saw blade clamp problem

Reply
Old 03-25-2006, 08:22 PM
  #1
edygert
Thread Starter
 
Join Date: Nov 2003
Location: Winter Springs, FL,
Posts: 100
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Delta 16" scroll saw blade clamp problem

I know that a lot of you use scroll saws and Delta support is not available right now so I thought I would take a chance.

I just bought the Delta SS350LS 16" scroll saw today. I can't get the quickset clamps to hold on to the blade; they just pop open again. I have adjusted the clamp strength every which way I know how but the clamps just won't hold. Any ideas?
edygert is offline  
Reply With Quote
Old 03-25-2006, 11:15 PM
  #2
David Cutler
 
David Cutler's Avatar
 
Join Date: Sep 2002
Location: Los Angeles, CA
Posts: 2,162
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Delta 16" scroll saw blade clamp problem

I had the same problem at first with the blades that don't have a peg in each end. As you are probably aware, there are two types of blades, with and without a cross-peg on each end, and the jaws are normally designed for use with both.

The jaws that hold the blade (the blades with no peg to hold the ends in the jaws) are very stiff and it's very difficult to get a good tight grip on the blade, but it is possible if you apply enough force to the allen key that tightens the jaw.

Remember to cut slowly, and if you feel you are cutting off the line, just stop moving the workpiece and change the angle slightly. Don't try to 'chase' the cut if it goes slightly adrift as the blades tend to twist slightly, and you will never get back to cutting straight and true.

Having a scroll saw available completely changes the way you look at cutting things like ply and very thick block balsa. You'll love it being around!

-David C.

Remember too there are circular blades available that don't need the workpiece to be swivelled to make a cut in a different direction.
David Cutler is offline  
Reply With Quote
Old 03-26-2006, 07:37 AM
  #3
edygert
Thread Starter
 
Join Date: Nov 2003
Location: Winter Springs, FL,
Posts: 100
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Delta 16" scroll saw blade clamp problem

The problem is the blade clamps. They are a quick-release style and when I close them they just pop open again. Sometime I can get the top clamp to work but the bottom clamp just won't stay shut. I don't even get to the point where I can start using the saw. Very frustrating.
edygert is offline  
Reply With Quote
Old 03-26-2006, 08:13 PM
  #4
tucker1865
 
Join Date: Jul 2004
Location: HIGHLAND, CA
Posts: 447
Default RE: Delta 16" scroll saw blade clamp problem

Hello...I am not familiar with the Delta but I will try to help. If this is a cam lock system, you might try adding a small shim between the blade and the cam and see if this makes the blade clamp stay shut or just use a thicker blade.. Or you could try a local delta dealer for help. Is it too loose and vibrates open when run. Mine uses the pinned blades, but that doesnt help. I had an old Delta that used a screw or allen screw to hold the blade but that was 30 years ago. It was a pain. You could also try emery paper epoxied to the cam.
tucker1865 is offline  
Reply With Quote
Old 03-26-2006, 09:07 PM
  #5
edygert
Thread Starter
 
Join Date: Nov 2003
Location: Winter Springs, FL,
Posts: 100
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Delta 16" scroll saw blade clamp problem

I did some research on the web and found out that the problem is probably the oil/grease that is on the clamp when it is packaged. I will clean it up and try again sometime tomorrow or Tuesday. Thanks for the help!
edygert is offline  
Reply With Quote
Old 03-26-2006, 09:19 PM
  #6
David Cutler
 
David Cutler's Avatar
 
Join Date: Sep 2002
Location: Los Angeles, CA
Posts: 2,162
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Delta 16" scroll saw blade clamp problem


Quote:
ORIGINAL: edygert

I did some research on the web and found out that the problem is probably the oil/grease that is on the clamp when it is packaged. I will clean it up and try again sometime tomorrow or Tuesday. Thanks for the help!
Now I come to think about it, that was probably what caused the similar problems I had originally with mine.

-David C.
David Cutler is offline  
Reply With Quote
Old 03-26-2006, 10:11 PM
  #7
edygert
Thread Starter
 
Join Date: Nov 2003
Location: Winter Springs, FL,
Posts: 100
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Delta 16" scroll saw blade clamp problem

David, always good to have confirmation. I will post the results in the next day or two.
edygert is offline  
Reply With Quote
Old 03-27-2006, 09:43 PM
  #8
flipstart
 
Join Date: Aug 2003
Location: Andersonville, TN
Posts: 666
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Delta 16" scroll saw blade clamp problem

I have a 16" Delta Scroll Saw, but it is an older model, I had to buy the toggle blade clamps as an option. On your blade clamps, do they have a bolt and aircraft nut that can be adjusted to varying blade thicknesses. On mine this bolt has to be loosened or tightened so the clamp will toggle over with correct amount of clamp pressure. Also it is possible to get too much of blade in bottom holder so top does not have enough to clamp onto. Excessive blade tension can also cause a problem, especially with a new blade that has oil on the surface. Wipe clamps and blades clean, adjust proper clamp pressure, center blade, and you should be on your way. Let me know is you still have problems, and we can discuss further.
flipstart is offline  
Reply With Quote
Old 03-28-2006, 09:06 AM
  #9
kitfoxkid
 
Join Date: Sep 2003
Location: Buenos Aires, ARGENTINA
Posts: 77
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Delta 16" scroll saw blade clamp problem

if you like to see what i build using mostly the Delta saw, and the dremel tool, please take a look at
http://members.fortunecity.com/holzfarben
kitfoxkid is offline  
Reply With Quote
Old 03-31-2006, 08:12 PM
  #10
edygert
Thread Starter
 
Join Date: Nov 2003
Location: Winter Springs, FL,
Posts: 100
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Delta 16" scroll saw blade clamp problem

Sure enough. I took the blade clamps apart and washed them in water and dishwashing liquid to get the grease off. After drying and reassembling, it worked great!
edygert is offline  
Reply With Quote
Old 03-31-2006, 09:06 PM
  #11
flipstart
 
Join Date: Aug 2003
Location: Andersonville, TN
Posts: 666
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Delta 16" scroll saw blade clamp problem

Good to hear you got the problem solved-Delta in general makes good tools-even though they have outsourced most of their large power tools. Wish I had bought a Delta band saw instead of the delta copy. Good luck on your saw.
flipstart is offline  
Reply With Quote
Reply


Thread Tools
Search this Thread
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 06:24 AM.