Search: Posts Made By: tiemac
Showing results 1 to 25 of 140
Search took 0.38 seconds.
05-10-2009, 07:19 PM
Replies: 7
Views: 1,509
Posted By tiemac

RE: Fouling glow plugs

Going to clean filter and try again. Bought some McCOY plugs. I asked for medium LHS said I should run cold in my 4.6. I got 2 MC-9 and MC-8
05-10-2009, 07:03 PM
Replies: 7
Views: 1,509
Posted By tiemac

RE: Fouling glow plugs

Plugs are black and oily. Could it be that I am using to much filter oil? I recently started using Factory Team Foam Pre-filter Treatment by Team Associated as my filter oil. LHS said I should use...
05-09-2009, 06:07 PM
Replies: 7
Views: 1,509
Posted By tiemac

RE: Fouling glow plugs

Tried that. Last plug Idle was way high.
05-09-2009, 06:01 PM
Replies: 7
Views: 1,509
Posted By tiemac

Fouling glow plugs

My latest problem with this piece of ****. My savage X 4.6 rtr keeps fouling glow plugs. New plug will run 10 or fifteen minutes then die. It will restart but soon as igniter is removed it dies. I...
05-03-2009, 05:20 PM
Replies: 14
Views: 703
Posted By tiemac

RE: Checked EVERYTHING, Tranny still not engaging.

had the same problem. check the pin m3/12 in gears 4995. took mine apart a few times bought a OWB then noticed pin missing.
05-03-2009, 10:50 AM
Replies: 14
Views: 10,827
Posted By tiemac

RE: Savage X. All sorts of starting, idle, running, problems.

My savage only runs well in the 260-280 range. I use O'Donnell 30%. I am no expert but I still got smoke at pipe. My 4.6 seems to go thru a lot of plug's. Most of the time a new plug does the trick...
04-19-2009, 10:06 PM
Replies: 13
Views: 604
Posted By tiemac

RE: Missing drive-shaft mystery?

I was snapping one every time I would run. Rest of drive train was fine. Installed CVD's, Solved the problem.
03-29-2009, 04:29 PM
Replies: 8
Views: 632
Posted By tiemac

RE: Is it OK to run a 30% in a Savage XL

My savage X 4.6 has been on 30% since new. 3 or 4 gallons with no problems.
03-27-2009, 10:05 PM
Replies: 8
Views: 896
Posted By tiemac

RE: Firehammer???????

I have a Firehammer M/T Great gasser.

my firehammer videoQ
03-17-2009, 07:22 PM
Replies: 9
Views: 687
Posted By tiemac

RE: fuel good or bad

I've been running Helicopter fuel in my savage. It is 30% nitro 20%oil 29.00 per gal. Little more smoke but more lube is good. My savage runs great on it. 30% nitro truck fuel is 44.00 per gal here...
03-01-2009, 02:41 AM
Replies: 5
Views: 324
Posted By tiemac

RE: SLC Bashers??? Anyone???

We have about six of us that go all the time. Going to run tomorrow if I can get some bearings for my rear diff. PM me.
02-27-2009, 08:15 PM
Replies: 17
Views: 1,018
Posted By tiemac

RE: what do you think?

Nitro's can be frustrating. But once you get it going there's nothing like it. Some days it don't want to start without a hassle but one day of feeding my savage a half gallon of fuel running tank...
02-23-2009, 02:37 PM
Replies: 5
Views: 587
Posted By tiemac

02-23-2009, 01:16 PM
Replies: 5
Views: 587
Posted By tiemac

what brand and model is this?

Can anyone help me identify this car? I am planing on purchasing it tonight for 40.00. Pull start is broke but engine has good compression. comes with transmitter and all electrics.
02-21-2009, 08:20 PM
Replies: 12
Views: 460
Posted By tiemac

RE: Pro 15 tranny problem

It was the pin in gear #4995 Thanks for all your help.
02-20-2009, 12:59 AM
Replies: 12
Views: 460
Posted By tiemac

RE: Pro 15 tranny problem

OK I see it M 3/12 in the #4995 gear. I will take it apart and check that pin. It is a threaded pin unless its the old style? Mine is the newer style.
02-20-2009, 12:55 AM
Replies: 12
Views: 460
Posted By tiemac

RE: Pro 15 tranny problem

4995 shows a gear. Is there a pin in it? So it should not spin on shaft?
02-20-2009, 12:52 AM
Replies: 35
Views: 4,256
Posted By tiemac

RE: RC trucks/cars are toys and for kids

I am 46 and love my nitro trucks. My 10yr old daughter and 13yr old son love there nitro's (they can only run with my supervision). My 36 yr old girlfriend has a Firehammer. I think they are fun TOYS...
02-20-2009, 12:33 AM
Replies: 12
Views: 460
Posted By tiemac

RE: Pro 15 tranny problem

Just put an OS 15 in it Goes pretty good, nothing like my savage.

Where is this pin at I don't see anything on the exploded view. Can you give me a part number so I can find it on exploded....
02-20-2009, 12:17 AM
Replies: 12
Views: 460
Posted By tiemac

RE: Pro 15 tranny problem

Took off the linkage at the servo and manually moved in and out. no difference.
02-20-2009, 12:12 AM
Replies: 12
Views: 460
Posted By tiemac

RE: Pro 15 tranny problem

Seems to be fine and operating smoothly.
02-19-2009, 11:23 PM
Replies: 12
Views: 460
Posted By tiemac

Pro 15 tranny problem

My sons pro 15 transmission just stopped working. First thing we did was check the clutch and slipper. Its getting power to Transmission input shaft. Tore it apart and found no stripped gears. The...
02-09-2009, 04:43 PM
Replies: 16
Views: 1,141
Posted By tiemac

RE: How to start a savage X???"..

Take the fuel lines off at the carb and exhaust. Blow into the tube from the exhaust. You should have good amount of fuel coming out if not tank might be clogged. I just bought a used savage and the...
02-02-2009, 11:47 PM
Replies: 21
Views: 1,983
Posted By tiemac

RE: Breaking rear drive shafts

I would feel alot better if they broke after a 20' jump with a cartwheel landing. They always seen to break when i am being mellow. (rare). Dont have a picture but its right at the ball but in the...
02-01-2009, 10:34 PM
Replies: 21
Views: 1,983
Posted By tiemac

RE: Breaking rear drive shafts

It aint no fun if it wont run! It was hard pack sand. the other tree I broke in the dirt. My Savage is supposed to be tough. Maybe I should get some street tires and run it in the parking lot. LOL...
Showing results 1 to 25 of 140
 


 
Forum Jump

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service