Smart-Fly (Quest Engineering) Support Forum Support forum for all Smart-Fly products. Equalizers, Batshare, Ignition Cutoff, Regulators.

Newbie Setup Confusion - Pwr Expndr Pro

Reply
Old 03-20-2010, 09:12 PM
  #1
GPutt33
Thread Starter
 
GPutt33's Avatar
 
Join Date: May 2002
Location: CO
Posts: 917
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Newbie Setup Confusion - Pwr Expndr Pro

Hi Guys - I'm trying to set up my 1st SF PowerExpander Pro in my first giant scale. I have plugged in my Spektrum AR9100 DSM-2 9 channel with the 3 wire receiver power leads going into the 1st slot and the last slot. Power is supplied with two FMA A123 2300 mAh batts connected to the SF board's dean connectors. I also have a SF fail safe switch installed on the board. This Rx has heavy leads for two batteries coming out the opposite end of the servo connections so I don't have any pigtails accidentally plugged into a batt slot.

Here is my problem - When I turn the fail safe switch on (pull the pin flag) I get all of my green LED's lit up on the board but no power to the receiver. I have disconnected the Rx and hooked it up as I normally would have before in the smaller planes and it light's up along with all three antenna's. I also got it to bind. I have plugged everything back in, checked the wires for proper polarity and still no power to the Rx.

Any help would be appreciated because right now I am stumped []

Does anything in the pics jump out as being wrong??

Thanks for the help and advise.
Attached Thumbnails
Click image for larger version

Name:	Db86195.jpg
Views:	20
Size:	117.0 KB
ID:	1401799   Click image for larger version

Name:	Sn40711.jpg
Views:	13
Size:	117.9 KB
ID:	1401800  
GPutt33 is offline  
Reply With Quote
Old 03-21-2010, 09:05 AM
  #2
rrritchey
 
Join Date: Sep 2004
Location: Tempe, AZ
Posts: 949
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Newbie Setup Confusion - Pwr Expndr Pro

Hi Gregg,
The AR9100 and JR922 and JR1222s were not designed to be used with anyone's power system, ours, PowerBox, Emotec or anyone elses. It can be done but it is a lot of work. Here is how you need to it.

1) On the two end receiver leads on the PowerExpander Pro that have 3 wires, you need to CAREFULLY pull out the white wire of each plug and put the white wire in its own plug (so you end up with two plugs on this lead)
2) You have to solder on a JR Female connector to each of the AR9100 power leads. Be careful to get the polarity in the female correct or you could hurt your receiver and/or the Pro
3) Plug the Pro plug on each end of the receiver connection block that has red and black into the JR female you soldered onto the AR9100 power leads. This powers the receiver.
4) Plug the single white wires into the servo ports on the receiver.

If this is all done correctly the AR9100 will work just fine. Its much easier to just use an AR9000 if you have one.
rrritchey is offline  
Reply With Quote
Old 03-21-2010, 08:04 PM
  #3
GPutt33
Thread Starter
 
GPutt33's Avatar
 
Join Date: May 2002
Location: CO
Posts: 917
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Newbie Setup Confusion - Pwr Expndr Pro

Thanks Robert - What you describe needing to do is more then it's worth. I had a brand new JR921, so I just stuffed it in and it works fine.

I guess I wish I had known that the SF was not compatible with the 9100, would have saved me a few $$. Ah well, I'll just use it on another plane somewhere down the line
GPutt33 is offline  
Reply With Quote
Old 03-22-2010, 08:58 AM
  #4
rrritchey
 
Join Date: Sep 2004
Location: Tempe, AZ
Posts: 949
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Newbie Setup Confusion - Pwr Expndr Pro

Hi Gregg,
We have done what we can with posts to RCU, Flying Giants and Flying Circus saying we do not advise using any PowerSafe receiver with our systems. Its hard to know where to put this information because it seems anytime I try to make an notice that someone always overlooks it.
rrritchey is offline  
Reply With Quote
Reply


Thread Tools
Search this Thread
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 10:14 AM.