T-Rex heli For all you T-Rex lovers out there, this where you can post!

TREX 450 pro help on repair

Reply
Old 04-18-2015, 02:28 PM
  #1
PDF
Thread Starter
 
Join Date: Dec 2002
Location: Peabody, MA
Posts: 204
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default TREX 450 pro help on repair

Hello all,
I'm new to heli's and bought a used built trex 450 pro. I few it for some time and the inevitable happened, it went in. Now I'm trying to get it up and running, and since I never built it or one from scratch it's a bit intimidating. First the damage, bent main shaft, have to replace the rotor bearings, two of the servos have slop in them. Again, since I didn't build this it's a learning curve. I took the main rotor bearing parts and replaced the bearings, I bought new servo gears and replaced them also. Now for the issue, I plugged my battery in the see if the servos works prior the installing them and saw one of them hummed, so I took it apart thinking I maybe didn't install the new bearing gears correctly and it was bound. So I took the gears out and free'd up the drive gear so there was no resistance and plugged the battery back in. The servo that didn't have the gear assembly in was still loud and the small gear was just spinning without any input from the radio. One of the servos didn't even move (I can't tell you what that serve operates since I'm new at this) and what baffled me most was that the ESC was hot without me even running the motor. I'd appreciate some advice how to trouble shoot what is culprit here.
Thanks for your help,
Pat
PDF is offline  
Reply With Quote
Reply


Thread Tools
Search this Thread
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 08:28 AM.