Test Posting Forum Want to test to see if you can post or test a feature like smilies, avatars or images but don't want to pollute the main forums? Test it out right here.

Saito 125

Reply
Old 05-07-2012, 05:32 AM
  #1
rjd
Thread Starter
 
Join Date: Oct 2003
Location: Mumbai, INDIA
Posts: 4
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Saito 125


I have been running a Saito 125A for over a year and was very satisfied with it until a week back suddenly no compression… found that one valve spring on the rocker arm was stuck... touched it with a screwdriver and it came into place... What caused that to happen...? Anyways had 5 flights after that and all well.

Yesterday, tried to start it up, same problem and same solution.

Has anyone one faced a similar situation, any suggestions what needs to be done?

Thanks.
rjd is offline  
Reply With Quote
Old 09-28-2012, 04:03 PM
  #2
GoNavy
 
Join Date: Jan 2002
Location: Rib Lake, WI
Posts: 528
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Saito 125

Bot a saito 125 1 year ago and just got around to break in. Was no compression. Turned it over maybe 50 times and finally got compression. Engine runs fine.
GoNavy is offline  
Reply With Quote
Reply


Thread Tools
Search this Thread
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 04:02 AM.