Thunder Tiger Engine Support Ask Bill Baxter your questions about Thunder Tiger Engines here!

TT 75 FS won't fire

Reply
Old 05-30-2013, 08:51 AM
  #1
Mtthwacrss
Thread Starter
 
Mtthwacrss's Avatar
 
Join Date: Jun 2009
Location: Lancaster, KS
Posts: 190
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default TT 75 FS won't fire



I bought this engine second hand. It seems to have decent compression but it will not fire at all. I am getting fuel. I have a new glow plug but still no fire. I have checked and the valves are working. I don't have the feeler gage or know what should be used. Any help would be appreciated.>>

Mtthwacrss is offline  
Reply With Quote
Old 05-30-2013, 01:11 PM
  #2
N1EDM
 
Join Date: Jul 2002
Location: Brockton, MA
Posts: 4,139
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: TT 75 FS won't fire

I'm presuming that you've already checked the usual stuff, i.e., the fuel is fresh, there are no problems with the fuel lines (you didn't accidentally put a tiny 1/2A fuel line to the carb?) and that the carb itself is OK, HSN about 2-1/2 to 3 turns out. You said that bought the engine used. Has the engine been apart? If the engine is otherwise in good shape, and the fuel system is OK, the piston sleeve might have been installed backwards.

Back to the piston sleeve, I think that the exhaust ports are usually higher than the intake ports.

Bob
N1EDM is offline  
Reply With Quote
Old 05-31-2013, 07:50 AM
  #3
Mtthwacrss
Thread Starter
 
Mtthwacrss's Avatar
 
Join Date: Jun 2009
Location: Lancaster, KS
Posts: 190
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: TT 75 FS won't fire

Yes all the usual stuff has been checked. Fuel is not a problem I am getting plenty. I do not know if it has been apart. I will have to check the sleeve.

Thanks

Matt

Mtthwacrss is offline  
Reply With Quote
Old 05-31-2013, 01:59 PM
  #4
tande
 
Join Date: Dec 2003
Location: Millington, MI
Posts: 990
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: TT 75 FS won't fire


Quote:
ORIGINAL: N1EDM

I'm presuming that you've already checked the usual stuff, i.e., the fuel is fresh, there are no problems with the fuel lines (you didn't accidentally put a tiny 1/2A fuel line to the carb?) and that the carb itself is OK, HSN about 2-1/2 to 3 turns out. You said that bought the engine used. Has the engine been apart? If the engine is otherwise in good shape, and the fuel system is OK, the piston sleeve might have been installed backwards.

Back to the piston sleeve, I think that the exhaust ports are usually higher than the intake ports.

Bob
No sleeve ports on a four/cycle......just say'in...
tande is offline  
Reply With Quote
Old 06-01-2013, 04:52 PM
  #5
N1EDM
 
Join Date: Jul 2002
Location: Brockton, MA
Posts: 4,139
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: TT 75 FS won't fire

My bad... Of course, you're absolutely right. In my haste, I thought that it was a 2S.... The FS should have been a dead give-away, eh???

In that case, there are 3 things that I would look for, in this order:

1. Open the valve cover housings. Are the pushrods actually connected to the rockers? I've seen where an engine took a rough landing and the pushrods came out of their sockets.

2. How is the valve lash? It probably calls for a 0.4mm feeler gage. There has to be SOME play in the rockers, but not a lot.

3. Has the cam been properly 'timed' to the crankshaft? You'll need an instruction book to find out what to look for in timing marks.

Again, this all presumes that all the simple boiler-plate things have been checked, a good 4-stroke glow plug (OS type F or equivalent), fresh fuel, tight plumbing, etc.

Just my $.02

Bob
N1EDM is offline  
Reply With Quote
Old 06-02-2013, 03:11 AM
  #6
tande
 
Join Date: Dec 2003
Location: Millington, MI
Posts: 990
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: TT 75 FS won't fire


Quote:
ORIGINAL: N1EDM

My bad... Of course, you're absolutely right. In my haste, I thought that it was a 2S.... The FS should have been a dead give-away, eh???

Bob
No problem......trust me, it won't get any better......don't get old! ......
tande is offline  
Reply With Quote
Old 06-02-2013, 04:02 PM
  #7
N1EDM
 
Join Date: Jul 2002
Location: Brockton, MA
Posts: 4,139
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: TT 75 FS won't fire

Hmmmm, what does the word "old" mean. I don't have that in my vocabulary...
N1EDM is offline  
Reply With Quote
Reply


Thread Tools
Search this Thread
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 07:32 AM.