raptor 50 v2 problems

Reply
Old 12-05-2011, 06:56 PM
  #1
lbeach001
Thread Starter
 
Join Date: Sep 2007
Location: greenville, MI
Posts: 49
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default raptor 50 v2 problems

hi everyone, i just bought my first raptor 50. it was allready built but is new, question about blades, book says they use 600mm but this one has carbon fiber blades that are 650 mm. is that going to cause the heli to wag back and fourth and spin faster when you excelerate. i just dont see anything that is wrong with anything else. also, does any body have the same set up with radio and gyro. im useing a hitec eclipse 7 with a gy401 gyro. what should the settings be at for hover mode and the other ones. please help, sorry, also what would cause a rattle noise when starting to spool up but then stops after the blades are moving. thanks
lbeach001 is offline  
Reply With Quote
Old 12-06-2011, 07:33 AM
  #2
BarracudaHockey
Community Moderators
 
BarracudaHockey's Avatar
 
Join Date: Jul 2003
Location: Jacksonville, FL
Posts: 21,802
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: raptor 50 v2 problems

Belt loose is probably causing the noise.

The Raptor should have 600mm blades, are you sure they are 650?

http://www.raptortechnique.com has a ton of info on radio setups. Tail wag is a gyro problem
BarracudaHockey is offline  
Reply With Quote
Old 12-06-2011, 05:07 PM
  #3
lbeach001
Thread Starter
 
Join Date: Sep 2007
Location: greenville, MI
Posts: 49
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: raptor 50 v2 problems

thats why i was asking about the radio set up. i have looked at that site but it dont show that radio with that gyro. so will them blades cause a problem or not.
lbeach001 is offline  
Reply With Quote
Old 12-09-2011, 12:47 PM
  #4
AKPhill
 
Join Date: Sep 2010
Location: Soldotna, AK
Posts: 49
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: raptor 50 v2 problems

Those blades could cause a blade strike with the rotor blades a 50 shouldnt have more than 600mm blades unless it is a titan 50 se then it could have 620 mm blades
measured from the blade bolt hole
AKPhill is offline  
Reply With Quote
Old 07-20-2012, 08:00 PM
  #5
Lins
 
Join Date: Oct 2005
Location: Yellowknife, NT, CANADA
Posts: 748
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: raptor 50 v2 problems

I see this is an old thread, but the pin backing out of the tail pulley can cause the rattle/clicking noise similar to the belt.
Lins is offline  
Reply With Quote
Reply


Thread Tools
Search this Thread
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 08:28 PM.