OS 50 Hyper

Reply
Old 03-10-2013, 08:06 AM
  #1
highlander84
Thread Starter
 
Join Date: Apr 2007
Location: Schweinfurt, GERMANY
Posts: 172
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default OS 50 Hyper

So when i went to fly today, my heli would not crank... here is the extended discripton of what I notced.

The engine sounds like it wants to crank but does not quiet make it. the muffler is war, not hot. There seems to be fuel spitting out the carb. I removed the glow (and swtiched it with a new one) and spun the engine incase it was hydro locked, it was not. From what ive read its to rich if its spitting fuel? But my needle is 1 1/4 turns I dont really wanna take it in anymore...unless BH says so lol. the other needle is untoched out of the box. Ive only really got the engine to run once (then crashed because I was an idiot) since then no love... fustrating!
highlander84 is offline  
Reply With Quote
Old 03-10-2013, 09:08 AM
  #2
Goggles
 
Goggles's Avatar
 
Join Date: Dec 2001
Location: Abbotsford, BC, CANADA
Posts: 1,026
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: OS 50 Hyper

If you think you have to much fuel to the carb, pinch off the fuel line from the tank and see if it starts. If it does start then you have your needles open to far. If it doesn't start then maybe you have a blockage in the line some where, or the carb. Would you be able to provide some pictures of your set up? I noticed you had another post from January having the same problem, maybe some pics could help us assess your setup.
Goggles is offline  
Reply With Quote
Old 03-10-2013, 02:56 PM
  #3
highlander84
Thread Starter
 
Join Date: Apr 2007
Location: Schweinfurt, GERMANY
Posts: 172
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: OS 50 Hyper

I'll take some of it in the morning. Its midnight here. I have already took it all apart and checked to see if anything goes was closed. The only thing it could be is the needle settings... I think anyways...
highlander84 is offline  
Reply With Quote
Old 03-11-2013, 06:48 AM
  #4
BarracudaHockey
Community Moderators
 
BarracudaHockey's Avatar
 
Join Date: Jul 2003
Location: Jacksonville, FL
Posts: 21,466
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: OS 50 Hyper

Take a picture so I can see the low end needle.

Even if the needles are jacked up, it should run, maybe like crap but it will run. Fuel spitting usually means too rich though.
BarracudaHockey is online now  
Reply With Quote
Old 03-12-2013, 02:58 AM
  #5
highlander84
Thread Starter
 
Join Date: Apr 2007
Location: Schweinfurt, GERMANY
Posts: 172
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: OS 50 Hyper

ok here are some pics, hope they show what ya need, if not tell me and i will make some more.
Attached Thumbnails
Click image for larger version

Name:	Xv64685.jpg
Views:	36
Size:	97.6 KB
ID:	1861093   Click image for larger version

Name:	Rp44425.jpg
Views:	33
Size:	98.9 KB
ID:	1861094  
highlander84 is offline  
Reply With Quote
Old 03-12-2013, 05:45 AM
  #6
BarracudaHockey
Community Moderators
 
BarracudaHockey's Avatar
 
Join Date: Jul 2003
Location: Jacksonville, FL
Posts: 21,466
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: OS 50 Hyper

Turn the low end screw slightly clockwise so its parallel with the ground and give it a try
BarracudaHockey is online now  
Reply With Quote
Old 03-12-2013, 05:47 AM
  #7
highlander84
Thread Starter
 
Join Date: Apr 2007
Location: Schweinfurt, GERMANY
Posts: 172
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: OS 50 Hyper

ok thx ill give it a try, its snowing like crazy here so boo Ill post the results ASAP. Otherwise everything looks good? And the main needle is 1 1/2 leave it there or lean it out?
highlander84 is offline  
Reply With Quote
Old 03-12-2013, 06:07 AM
  #8
BarracudaHockey
Community Moderators
 
BarracudaHockey's Avatar
 
Join Date: Jul 2003
Location: Jacksonville, FL
Posts: 21,466
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: OS 50 Hyper

Depends on nitro content, 30 percent maybe but still probably on the rich side, lower nitro, thats well rich.

What hell is snow?? LOL
BarracudaHockey is online now  
Reply With Quote
Old 03-12-2013, 06:23 AM
  #9
highlander84
Thread Starter
 
Join Date: Apr 2007
Location: Schweinfurt, GERMANY
Posts: 172
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: OS 50 Hyper

Running 15% so ill take it to 1 1/4 Thanks! Hope she cranks wanna fly in the snow... you know germany, beer, brats, and SNOW! lol
highlander84 is offline  
Reply With Quote
Old 03-13-2013, 05:15 AM
  #10
highlander84
Thread Starter
 
Join Date: Apr 2007
Location: Schweinfurt, GERMANY
Posts: 172
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: OS 50 Hyper

So, same problem...exhause gets warm. but it wont start... and I still have fuel dripping from the motor...which leads me to think i have a compression leak, or well a leak somewhere on the motor....what do you think? Where should I check?
highlander84 is offline  
Reply With Quote
Old 03-13-2013, 05:26 AM
  #11
BarracudaHockey
Community Moderators
 
BarracudaHockey's Avatar
 
Join Date: Jul 2003
Location: Jacksonville, FL
Posts: 21,466
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: OS 50 Hyper

The usual culprits are the muffler, head bolts, and making sure the carb is seated all the way.

Replace the plug and make sure you fuel lines are ok.
BarracudaHockey is online now  
Reply With Quote
Old 03-13-2013, 05:58 AM
  #12
highlander84
Thread Starter
 
Join Date: Apr 2007
Location: Schweinfurt, GERMANY
Posts: 172
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: OS 50 Hyper

Then I shall check it all...
highlander84 is offline  
Reply With Quote
Old 03-13-2013, 06:24 AM
  #13
highlander84
Thread Starter
 
Join Date: Apr 2007
Location: Schweinfurt, GERMANY
Posts: 172
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: OS 50 Hyper

hey BH is there a way I could chat with you for a bit?
highlander84 is offline  
Reply With Quote
Old 03-25-2013, 02:43 PM
  #14
bklambdin
 
Join Date: Jul 2006
Location: London, KY
Posts: 112
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: OS 50 Hyper

Mine wont start with a dewalt drill... Sounds just like your problem. Got a flight box starter and used it, fired right up.
The drill starts my OS 37 on my 30 V2, but don't spin fast enought to start the 50 SX-H Hyper
bklambdin is offline  
Reply With Quote
Old 03-26-2013, 03:16 AM
  #15
highlander84
Thread Starter
 
Join Date: Apr 2007
Location: Schweinfurt, GERMANY
Posts: 172
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: OS 50 Hyper

not 100% sure yet because waiting on some new bolts, but my exhause was not tight enough because the exhaust bolt hole is stripped. So I ordered some M3.5X40 bolts so I can put some nuts on the end of it. Also first thing to always try it changing the glow plug.
highlander84 is offline  
Reply With Quote
Old 07-05-2013, 02:56 PM
  #16
bklambdin
 
Join Date: Jul 2006
Location: London, KY
Posts: 112
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: OS 50 Hyper

If you use a bit longer bolts, then you can put on those lock nuts with the plastic inside. They don't come loose.
Also use JB weld the 24 hr drying stuff for the gasket. Just a thin film and zero leaks.

Brian
bklambdin is offline  
Reply With Quote
Old 07-14-2013, 12:15 AM
  #17
highlander84
Thread Starter
 
Join Date: Apr 2007
Location: Schweinfurt, GERMANY
Posts: 172
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: OS 50 Hyper

thats exactly what I did. But i used normal nuts with locktight. Was worried about the rubber overheating and melting while flying. after fixing that I came to the conclusing it is my fuel. it was neglected and seems to be the problem. thanks for the tip.
highlander84 is offline  
Reply With Quote
Old 07-14-2013, 04:22 AM
  #18
BarracudaHockey
Community Moderators
 
BarracudaHockey's Avatar
 
Join Date: Jul 2003
Location: Jacksonville, FL
Posts: 21,466
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: OS 50 Hyper

Locktite is by and large ineffective in muffler situations, we use heat to remove stubborn locktite, and what happens is it liquefies and makes a very nice lubricant.

There is high temp stuff available but you have to go looking for it.
BarracudaHockey is online now  
Reply With Quote
Old 07-14-2013, 07:32 AM
  #19
highlander84
Thread Starter
 
Join Date: Apr 2007
Location: Schweinfurt, GERMANY
Posts: 172
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: OS 50 Hyper

Well, now I feel like an idiot because i already knew that. looks like the 2 nut method will be used....
highlander84 is offline  
Reply With Quote
Old 07-20-2013, 03:29 AM
  #20
highlander84
Thread Starter
 
Join Date: Apr 2007
Location: Schweinfurt, GERMANY
Posts: 172
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: OS 50 Hyper

So BH (lol) 

I have New fuel, new glow. The only difference that has made is the engine now gets HOT when I try to crank it. Nothing more. I have tried needle settings (main) from the 1.5 out. 3 out and 1 turn out. Same result every time. I'm beginning to think this engine is defective. Unless you have something else for me to try I am going to contact Ron Lund and request a replacement.  Since I have owned this engine I have not got it to run... not once... 
highlander84 is offline  
Reply With Quote
Reply


Thread Tools
Search this Thread
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 08:06 PM.