Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 17 of 17

  1. #1

    Join Date
    Dec 2009
    Location
    cairo-----, EGYPT
    Posts
    25
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    revo 3.3 problem driving me crazy

    hi guys
    this problem is driving me crazy , iv been trying to solve it for more then 3 months now.
    basically when i squeeze the throtte , the engine rev's loud but the car moves pretty slow .
    i changed the following which almost means i replaced anything that could be the cause
    1- transmission
    2- 3 piece clutch
    3-clutch bell
    4- piston and ring
    5- clutch pads


    i dont think there is anything else that need to be replaced
    the slipper clutch nuts is tightened.

    i noticed i can hold the spur gear with my finger and squeeze the throttle and the gear dosent move.!!
    i think the problem is either in the clutch bell or the 3 peice clutch , i also bought a new traxxas 2 piece clutch to try it on , but still the problem is not solved.

    please help me guys.. i know you can

    thanks

  2. #2

    Join Date
    May 2010
    Location
    viviers, FRANCE
    Posts
    123
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: revo 3.3 problem driving me crazy

    Well its obviously a problem coming from the clutch as your spur isnt turning and the only thing before that is the clutch.
    Things to check are
    1 is the flywheel nut securely fixed down on the flywheel, because if its not then the shaft will turn but not the clutch system.
    2 is the flywheel brass collar too big ? if it is this will stop the nut before it holds down the flywheel
    3 re check the clutch but i would imagine this to be ok as there arent 100 ways to fit a clutch

    i would think its more a flywheel problem.

  3. #3

    Join Date
    Dec 2009
    Location
    cairo-----, EGYPT
    Posts
    25
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: revo 3.3 problem driving me crazy

    i installed the 2 piece clutch as per the manual.
    i dont know how to explain it , but if your facing the clutch , the hinge ( pin ) is on the left and the clutch opens to the left .

    is this correct ?

  4. #4

    Join Date
    May 2010
    Location
    midland, TX
    Posts
    204
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: revo 3.3 problem driving me crazy

    only 2 things i can think offlywheel and slipper clutch

    the pads wont do that

    did you put the beviled peice before the flywheel

  5. #5

    Join Date
    Apr 2010
    Location
    rochester, NY
    Posts
    1,116
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: revo 3.3 problem driving me crazy

    I have to say the flywheel is slipping on the engine shaft. As for the stock two piece clutch you can put it on either way, I prefer one way over another but it should always work. If the flywheel looks like it is turning then you've done something wrong with the clutch spring. As for the piston and ring, there is no ring, and why the piston? It was running before right?
    Losi xxl, Picco 26 t-maxx 4907, Sirio s27 revo, revo 2.5 with modded 18tm, EMBE, mostly stock 4908 maxx, pos mini lst2.

  6. #6

    Join Date
    Dec 2009
    Location
    cairo-----, EGYPT
    Posts
    25
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: revo 3.3 problem driving me crazy

    ok a quick update.. i removed the engine from the truck to recheck everything
    i noticed than when i spin the fly wheel counter clock wise , i have a good compression.
    but i can also spin it clock wise.. and when i do so , i can hear the EZ START spinning.

    is that normal ?

  7. #7

    Join Date
    Apr 2010
    Location
    rochester, NY
    Posts
    1,116
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: revo 3.3 problem driving me crazy

    As long as the ez-start is functional that is perfectly normal. I think that you have something wrong with your clutch. Not the best video but you get the idea. I usually put the spring together then kind of roll it on over the shoes. http://www.youtube.com/watch?v=dqLWqAtiukg
    Losi xxl, Picco 26 t-maxx 4907, Sirio s27 revo, revo 2.5 with modded 18tm, EMBE, mostly stock 4908 maxx, pos mini lst2.

  8. #8

    Join Date
    Dec 2009
    Location
    cairo-----, EGYPT
    Posts
    25
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: revo 3.3 problem driving me crazy

    is it possible that the spring is too tight ? its just a brand new spring..!
    what could be the cause of the clutch not having pressure on the bell ? im sure the problem is in the clutch / bell / flywheel .



  9. #9

    Join Date
    Apr 2010
    Location
    rochester, NY
    Posts
    1,116
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: revo 3.3 problem driving me crazy

    Do you have the correct size bell? Not the gear teeth, but actual bell size? Any way you can show pics of your clutch and parts?
    Losi xxl, Picco 26 t-maxx 4907, Sirio s27 revo, revo 2.5 with modded 18tm, EMBE, mostly stock 4908 maxx, pos mini lst2.

  10. #10

    Join Date
    Dec 2009
    Location
    cairo-----, EGYPT
    Posts
    25
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: revo 3.3 problem driving me crazy

    yes im sure the bell size is correct.

  11. #11

    Join Date
    Apr 2011
    Location
    Lincoln, NE
    Posts
    31
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: revo 3.3 problem driving me crazy

    I have a revo 3.3 and having the same problem wondering if you found out what the cause is . appreciate any help THANKS

  12. #12
    Curious if anyone has found the answer yet??

  13. #13

    Join Date
    Nov 2009
    Location
    kings mountain, NC
    Posts
    47
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback
    Sounds to me like (A) already stated flywheel is slipping...the collet could be doing the free spinning...if the clutch bell is to big..if a different spring is used other than what came with clutch...using the collet from one flywherlbto another? The problem is right there in that area..if crank want turn motor isn't running...if spur isn't turning when revving its between the flywheel assy. To the clutch assy. There isn't nothing else ...unless gear mesh isn't even touching..can you put picture or a video would be great..if we see it im sure we can fix it.
    Speed cost money !!!!!
    How fast you wanna go !!!!!

  14. #14

    Join Date
    Nov 2009
    Location
    kings mountain, NC
    Posts
    47
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback
    You said when engine revving loud car moving slow...how did u hold spur and rev it up? Right there u should see something slipping...with car running go from bottom side use the handle of a screwdriver and put it against flywheel..if flywheel is tight motor will die instantly...if it doesn't then flywheel is slipping..
    Speed cost money !!!!!
    How fast you wanna go !!!!!

  15. #15
    please help me guys.. i know you can


  16. #16

    Join Date
    Nov 2009
    Location
    kings mountain, NC
    Posts
    47
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback
    Im not able to see what you posted..its a question mark..
    Speed cost money !!!!!
    How fast you wanna go !!!!!

  17. #17

    Join Date
    Nov 2009
    Location
    kings mountain, NC
    Posts
    47
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback
    Did you try stopping engine by flywheel on the underside of truck with a screwdriver handle?? Some people just have a glove on and use there hand..that's gonna tell if collet or flywheel is slipping not allowing it to move.
    Speed cost money !!!!!
    How fast you wanna go !!!!!


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 10:48 PM.

SEO by vBSEO 3.6.1 ©2011, Crawlability, Inc.