Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 19 of 19

  1. #1

    Join Date
    Mar 2007
    Location
    springfield, TN
    Posts
    23
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    should this be happening?

    i just recieved my trx 2.5 engine back from traxxas, (they replaced the piston and sleeve by the way) and i just got done with the break in and i just got brought my truck in and there is a stream of smoke comming from the cooling head of my engine. the grass is dry and i didnt drive through any water or anything. what is causing the smoke? is it normal? plz help me.
    Trnt_West

  2. #2
    Danju's Avatar
    Join Date
    Feb 2007
    Location
    thousand oaks, CA
    Posts
    1,669
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: should this be happening?

    its running lean....richen it out a bit...or ive heard that sometimes residual oil (WD-40) evaporates from the cooling head when the engine is hot.

  3. #3
    MJAsony2305@aol.com's Avatar
    Join Date
    Dec 2007
    Location
    Dallas, GA
    Posts
    1,025
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: should this be happening?

    tighten the plug also.
    thats your 2.5 cents but this is my 3.3 cents.
    rustler 3.3 come on try me.

  4. #4

    Join Date
    Mar 2007
    Location
    springfield, TN
    Posts
    23
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: should this be happening?

    at first i thought i was running it a little to lean but i checked and it was still 4 turns out and i even richend it up to 4 and a half turns just to make sure it wasnt running lean, and it still had a small stream of smoke.[]
    Trnt_West

  5. #5
    MJAsony2305@aol.com's Avatar
    Join Date
    Dec 2007
    Location
    Dallas, GA
    Posts
    1,025
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: should this be happening?

    TIGHTEN THat plug man even that can make it run lean and what model is it? also check your low speed needle it could be that too.
    thats your 2.5 cents but this is my 3.3 cents.
    rustler 3.3 come on try me.

  6. #6

    Join Date
    Mar 2007
    Location
    springfield, TN
    Posts
    23
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: should this be happening?

    ok, ill try that, but its a tmaxx 2.5
    Trnt_West

  7. #7
    MJAsony2305@aol.com's Avatar
    Join Date
    Dec 2007
    Location
    Dallas, GA
    Posts
    1,025
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: should this be happening?

    yeah i would also check for an airleak and make sure the cooling head is tightened all the way. and also check the carb and fuel lines along w/ the exhaust line, o rings, and coupler, also i would check the fuel tank lid.
    thats your 2.5 cents but this is my 3.3 cents.
    rustler 3.3 come on try me.

  8. #8

    Join Date
    Mar 2007
    Location
    springfield, TN
    Posts
    23
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: should this be happening?

    ok thank you, but one more question. whats the best way to check for leaks in all of these places? ..exhaust, carb, fuel line, tank, etc..
    Trnt_West

  9. #9

    Join Date
    Nov 2007
    Location
    hervey bay, AUSTRALIA
    Posts
    1,276
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: should this be happening?

    Air compressor while engine is running blow over it, LOL not the air filter dah, if its got a leak it'll likely stall , and its not normanl for ANY nitro engine to smoke, other than exhaust smoke, check ya clutch isnt fried or frying, and that oil or like someone said WD 40 or RP7 whatever one you use hassnt clagged up with grit on the block, usually that is a sign the heads to hot via lean running, but as you have richened it , it must be something else, either something rubbing or cooking, lol clutch or gunk !

  10. #10
    MJAsony2305@aol.com's Avatar
    Join Date
    Dec 2007
    Location
    Dallas, GA
    Posts
    1,025
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: should this be happening?

    replace all o-rings and couplers and then take then engine off and rub it down with a tooth brush dipped in soapy water(make sure to plug the exhaust hole and carb whole...oh yeah take the carb off and put copper RTV sealant around the screws NOT needles just the screws) and after the soapy water just blow in the fuel line going to the carb or blow into the carb whole if carb removed and see where bubbles form the put copper RTV sealant around those areas.,...or you can just seal the whole thing with sealant to be on the safe side.
    thats your 2.5 cents but this is my 3.3 cents.
    rustler 3.3 come on try me.

  11. #11

    Join Date
    Mar 2007
    Location
    springfield, TN
    Posts
    23
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: should this be happening?

    ok well thank you both for your help. its good to know that there are actually nice people on here, unlike other forums.
    Trnt_West

  12. #12
    MJAsony2305@aol.com's Avatar
    Join Date
    Dec 2007
    Location
    Dallas, GA
    Posts
    1,025
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: should this be happening?

    lol no problem we have all been there through the hell of our R/C not working.
    thats your 2.5 cents but this is my 3.3 cents.
    rustler 3.3 come on try me.

  13. #13
    youwish16's Avatar
    Join Date
    Jun 2006
    Location
    Milledgeville, GA
    Posts
    1,379
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: should this be happening?

    BUY A TEMP GAUGE! lol
    Losi 8ight,Precirotate 3 Port Modified Engine,Avid Bearings,Dynamite,Sprektrum Radio,Ace Servos,Fastlane Graphix,Stickman RC

  14. #14
    matts6887's Avatar
    Join Date
    Mar 2008
    Location
    scottsdale, AZ
    Posts
    3,007
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: should this be happening?

    Like the above mentioned; if u have it set that rich and it it still seems like its running hot; then more than likely u do have a air leak somewhere. Check the o-rings in the carb, the fuel tank and lines for possible pinholes that u cant see, and u also might want to take the backplate gasket off to check/inspect the backplate gasket for any possible nics or tears which indeed can and a lot of times will cause a air leak by allowing air to seep in....
    \"If U havent broken anything....U arent driving it hard enough\"

  15. #15

    Join Date
    Mar 2007
    Location
    springfield, TN
    Posts
    23
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: should this be happening?

    ok ill check for all of hese things, and does traxxas have a pack of like all the o rings and gaskets that i can buy?
    Trnt_West

  16. #16
    MJAsony2305@aol.com's Avatar
    Join Date
    Dec 2007
    Location
    Dallas, GA
    Posts
    1,025
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: should this be happening?

    yessir they do its on towerhobbies.com
    thats your 2.5 cents but this is my 3.3 cents.
    rustler 3.3 come on try me.

  17. #17
    matts6887's Avatar
    Join Date
    Mar 2008
    Location
    scottsdale, AZ
    Posts
    3,007
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: should this be happening?

    i believe they do, but I'm not totally sure of the part # off hand. If I have a chance I will look it up and post it in here for ya; otherwise I'm sure someone else might get to doing that before I do.
    \"If U havent broken anything....U arent driving it hard enough\"

  18. #18

    Join Date
    Mar 2007
    Location
    springfield, TN
    Posts
    23
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: should this be happening?

    ok, and once again thank you all.
    Trnt_West

  19. #19
    matts6887's Avatar
    Join Date
    Mar 2008
    Location
    scottsdale, AZ
    Posts
    3,007
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: should this be happening?


    ORIGINAL: trnt_west

    ok, and once again thank you all.

    Not a problem! Any further questions; just ask away and someone will be glad to help!! [8D]
    \"If U havent broken anything....U arent driving it hard enough\"


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 07:51 AM.

SEO by vBSEO 3.6.1 ©2011, Crawlability, Inc.