Go Back  RCU Forums > Radios, Batteries, Clubhouse and more > Unusual R/C
Reload this Page >

LB Getting Ready for SNOW - Kyosho EP Blizzard DF-300 Thread!

Unusual R/C Discuss Airships, Blimps, LTA, VTOL, Ground Effect Vehicles, Hovercaft and more.

LB Getting Ready for SNOW - Kyosho EP Blizzard DF-300 Thread!

Reply

Old 02-08-2015, 03:37 PM
  #2076  
damfurst
 
Join Date: Aug 2007
Location: Lewistown, MT
Posts: 437
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Here's a couple of videos of my Blizzard EV.

http://youtu.be/j8hia2jR-gk http://youtu.be/lA0w3xsuBc8
damfurst is offline  
Reply With Quote
Old 02-12-2015, 10:20 AM
  #2077  
TechyJoe
Senior Member
 
Join Date: Mar 2004
Location: Wayne, PA
Posts: 245
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Can anyone help me with a Nitro Blizzard build?

I've built the entire chassis + motor etc., only to start it and find that I have a grinding issue in the gears. The vehicle seems to work great with the transmission in reverse but when in the forward condition, I get the grind. I've done all of the basic trouble shooting such as remove the tracks and check everything for binding as well as make sure the shifter doohickey is either fixed in forward or fixed in reverse just to make sure the servo is not chattering and moving it.

The transmission is the only thing that comes in the kit pre-assembled and I'm pretty sure the issue starts there. When I built the model, I made sure everything was greased and moving smoothly. I'd hate to have to take the whole thing apart to remove the transmission,

Last edited by TechyJoe; 02-12-2015 at 10:23 AM.
TechyJoe is offline  
Reply With Quote
Old 02-18-2015, 07:31 AM
  #2078  
TechyJoe
Senior Member
 
Join Date: Mar 2004
Location: Wayne, PA
Posts: 245
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

I guess this thread is dead!
TechyJoe is offline  
Reply With Quote
Old 02-19-2015, 07:32 AM
  #2079  
Lunchboxer
Thread Starter
 
Lunchboxer's Avatar
 
Join Date: Mar 2006
Location: Longmeadow, MA
Posts: 56,174
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

The issue is that the geartrain on the nitro Blizzard is quite different than the electric one, so it is hard for people to comment. Most on the thread have the electric ones, that's most likely the reason why people don't have useful experience to share with you.
Lunchboxer is offline  
Reply With Quote
Old 04-22-2015, 08:31 AM
  #2080  
Pah co chu puk
 
Pah co chu puk's Avatar
 
Join Date: Apr 2010
Location: Ridgway, CO
Posts: 2,651
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

A guy posted pictures and a movie about a snow blower he 3d printed that fits on a Blizzard here...

3D Printed Snow Blower
Pah co chu puk is offline  
Reply With Quote
Old 01-07-2016, 08:49 AM
  #2081  
AKSean
Junior Member
 
Join Date: Jan 2016
Posts: 1
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

I just picked up a used blizzard with single motor, super excited about building it

Last edited by AKSean; 01-07-2016 at 08:55 AM.
AKSean is offline  
Reply With Quote
Old 01-08-2016, 02:32 AM
  #2082  
Lunchboxer
Thread Starter
 
Lunchboxer's Avatar
 
Join Date: Mar 2006
Location: Longmeadow, MA
Posts: 56,174
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Post some pics of your new-to-you Blizzard!
Lunchboxer is offline  
Reply With Quote
Old 02-09-2016, 04:34 PM
  #2083  
chucky004
Junior Member
 
Join Date: Sep 2007
Location: vernal, UT
Posts: 9
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Is anyone interested in a DF 300 nitro blizzard, I bought it a couple years ago off e bay drove it once and the gears chattered so I put it away. Today I was messing with it and finally figured out it was missing the spring on the throttle linkage, so all is well it runs great. It comes with everything even a radio if anyone is interested make me an offer. I have too many things going on to mess with rc anymore..
chucky004 is offline  
Reply With Quote
Old 01-15-2019, 05:46 PM
  #2084  
Pah co chu puk
 
Pah co chu puk's Avatar
 
Join Date: Apr 2010
Location: Ridgway, CO
Posts: 2,651
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Anyone ever come here anymore?

I have a Blizzard that has one side that has less power than the other side. I don't know if it's the motor or the ESC. Any ideas?
Pah co chu puk is offline  
Reply With Quote
Old 01-29-2019, 04:48 AM
  #2085  
Lunchboxer
Thread Starter
 
Lunchboxer's Avatar
 
Join Date: Mar 2006
Location: Longmeadow, MA
Posts: 56,174
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Which version of Blizzard do you have? If it is the same as the one I have in the thread, then it is not the motor nor the ESC, since it is a single motor / ESC setup. One side is weaker due to the "brake" dragging most likely.



Originally Posted by Pah co chu puk View Post
Anyone ever come here anymore?

I have a Blizzard that has one side that has less power than the other side. I don't know if it's the motor or the ESC. Any ideas?
Lunchboxer is offline  
Reply With Quote

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service