XHeli.com Support Forum If you have a question, problem or concern about your product from xheli.com, please use this forum to get answers to your questions.

Axee 100cp low on power.

Reply
Old 06-17-2013, 03:14 PM
  #1
trav1
Thread Starter
 
Join Date: Dec 2011
Location: Houston, TX
Posts: 13
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Axee 100cp low on power.

New pilot and LOVING this sport...I got a New Axe 100cp about a month ago. Flies great but I am noticing it takes more and more power to stay in air. I am at max throttle setting on TX, but it takes about 70%-80% throttle to stay up. I have 4 bats and fly it almost every day. After a month or so is the motor just wearing out? I am a newb and have crashed it several time. Replaced 2 tail booms is only repairs. The blades are a little nicked up but no cracks or chuncks missing, (still oringinals) would that make that much a difference? All other controlls are fine. Also...I have seen on other threads that this is a copy of the Nine Eagles solo125. If so, can i swap out for a more powerful motor without having to go brushless and change anything else? Not gona mess with the 100ss model, My next heli will be.. BIGGER....ANY tips or hints are appreaciated. Thanks. (Oringinaly posted in wrong forum..sorry, new to this.)
trav1 is offline  
Reply With Quote
Reply


Thread Tools
Search this Thread
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 04:03 PM.