YS Engines Support Direct support from YS Performance Engines by Dave Shadel

DZ 200 CDI NEW, Problem in mid rang

Reply

Old 09-29-2018, 05:25 AM
  #1  
kobi
Thread Starter
 
Join Date: Feb 2007
Location: RESHON LEZIYYON, ISRAEL
Posts: 97
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default DZ 200 CDI NEW, Problem in mid rang

Hello
Problem with my engine:
engine 200 cdi NEW , prop 21.5x10.5 , fuel morgan cool power 30% heli
main needle open 1 1/4, The regulator is slightly open half a turn from manufacturer mode
On the ground everything is fine , mex rpm 7000 , idel 2000 rpm
In the air when I rise above half throttle , hear a loud, strange noise like detontions
And I also see that there is a mismatch in the smoke ,
Do you have suggestions what to do ?
thanks
Kobi
kobi is offline  
Reply With Quote
Old 10-08-2018, 11:53 PM
  #2  
Union Models
 
Join Date: Jan 2008
Location: Manchester, UNITED KINGDOM
Posts: 128
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

I had a similar problem with my YS170 with a CDI conversation. It would miss fire on take off.
I traced the problem to a faulty CDI unit.

To find my fault, I disconnected the CDI unit spark plug cap and the three wires from the rear crankcase.
Replaced the spark plug with a new OS F glow plug. Set the needle rich and flew. For me the problem went away on glow.
Going back to spark again. I tryed another after market CDI unit borrowed from a friend, and the engine ran perfect

Bought another CDI box, and all is good.

Hope this might be of use.
Mike
Union Models is offline  
Reply With Quote
Old 10-09-2018, 08:39 PM
  #3  
kobi
Thread Starter
 
Join Date: Feb 2007
Location: RESHON LEZIYYON, ISRAEL
Posts: 97
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Thanks friend
problem solved
The silicone tube I attached to the silencer was too long and soft
And each time I lifted the throttle over the half, the tube folded and blocked the smoke exit
This is also why there were breaks in the smoke
I changed the tube to thicker
And now the engine works great, loads of power, two clicks above half throttle gives a vertical climb that did not stop

kobi
kobi is offline  
Reply With Quote
Old 10-09-2018, 11:02 PM
  #4  
Union Models
 
Join Date: Jan 2008
Location: Manchester, UNITED KINGDOM
Posts: 128
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default

Great, glad you have the engine sorted.
Mike
Union Models is offline  
Reply With Quote

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service