RCU Forums

RCU Forums (http://www.rcuniverse.com/forum/)
-   YS Engines Support (http://www.rcuniverse.com/forum/ys-engines-support-197/)
-   -   help with idle problem on 91AC (http://www.rcuniverse.com/forum/ys-engines-support-197/11304334-help-idle-problem-91ac.html)

dbeeler 11-20-2012 04:08 PM

help with idle problem on 91AC
 
i am sure this has been addressed many times before. i could not find a posting however. my 91AC runs very good and powerful at peakandfull throttle and transitions well. no problems there.but i cannot get it to idle smoothly or dependably. ihave tried "everything".it is installed in an aeroworks extra 260 (60 size). i have sentthe engine to YSservice twice in the past couple months. the first time a pushrod, bearings, diaphram, and glow plugwere replaced. butwhen i received it back theidle problem remained. i sent it back to YSservice for a 2nd look. this time the disc valve was found to be loose and itwas tightened. i was then toldit was runningok at the shop.however, the problem continues. itwill idle for 30-45 secs on the bench (although erratic and lots of vibration) at about 2300RPM. if i fly the engine"kills" when throttling back to land. i have upped the idle to as much as 2600 RPM to try to keep it running. my fuel is 20/20 YS. it is fresh. there are no leaks in the fuel system. pressure is good.i fly at 5800 ft above sea level.
i am wondering if someone "out there" has any ideas or suggestions. thanksmuch for your help. PS this is my first YSengine.

petec 11-21-2012 07:46 AM

RE: help with idle problem on 91AC
 
Check out this link and let us know the outcome.

http://www.geistware.com/rcmodeling/index.htm

I am curious what happens when you go from full to idle.

dbeeler 11-26-2012 03:47 PM

RE: help with idle problem on 91AC
 
thank you, petec for your help. i HAVEchecked out that website and have actually followed the instructions to the letter. i have also found other articles on geistware. the steps listed on the site have not solve the problem. i think there is a leak somewhere but cannot find where. i have sent the engine to YSservice twice. the first time the piston ring was replaced along with bearings, pushrods, diaphragm and gaskets. did not solve the problem. the 2nd service was to "adjust loose backplate disc valve". still no correction to the problem. i wonder if i should replace the valves and springs. i am at a loss to figure this out.i am thinking there is an "internal" leak somewhere. i believe that would certainly cause idle problems. the fuel system does not leak. ihave not noticed any leaking fuel from the engine.i am using the proper fuel and also a new YSglowplug. soitremains a mystery.

rcstavros 11-27-2012 01:47 AM

RE: help with idle problem on 91AC
 
Having very similar idle problems as yours with my YS FZ110 and after trying almost everything else I found that the throttle barrel seal was hardened and was not sealing correctly. Following seal replacement the engine holds a steady 2000 rpm idle.
Just my 2cent advice.

dbeeler 11-27-2012 03:12 PM

RE: help with idle problem on 91AC
 
ok well i am a bit jealous of a steady 2000 RPM idle. thanks for the tip. i will check that seal as well as others. i flew the plane twice today. set the idle up a bit to about 3000 rpm. it "killed" both times when throttling back to land. i was over the runway so no big deal. it runs great at mid and full throttle and all in between.just frustrating that i cannot seem to dependupon the engineat idle.

tande 11-27-2012 04:11 PM

RE: help with idle problem on 91AC
 

Quote:

ORIGINAL: dbeeler

ok well i am a bit jealous of a steady 2000 RPM idle. thanks for the tip. i will check that seal as well as others. i flew the plane twice today. set the idle up a bit to about 3000 rpm. it ''killed'' both times when throttling back to land. i was over the runway so no big deal. it runs great at mid and full throttle and all in between. just frustrating that i cannot seem to depend upon the engine at idle.
FWIW....engine quitting when throttling back is normally caused by a "Lean" fuel mixture (assuming the idle speed/trim is set correctly).....in the case of the "YS" it's usually to "Lean' on the regulator adjustment.....OR an air/leak....

dbeeler 01-06-2013 11:41 AM

RE: help with idle problem on 91AC
 
has anyone used on board glow ignition to solve inconsistent idle? in particular in a YS engine that is mounted inverted? is it possible that upon landing approach when the engine speed is at or just above idle, and the engine is mounted inverted that the engine is not running hot enough to prevent flame out? maybe the fuel entering the cylinder is also helping to cool the glow plug? does that make any sense? if so, then maybe on board ignition would help.
thanks much
dave 

Four Stroker 01-07-2013 11:37 AM

RE: help with idle problem on 91AC
 
I use the SwitchGlo Pro, very small and uses the receiver battery. I set it up to come on at 1/4 throttle and below. Works great. You don't have to use a 4 cycle plug. Enya 3 or 4 work fine. I actually used an Enya #5 this summer when it was over 100F to stop pre-ignition on 30%.

You can knock the beep down by simple tapping the hole and putting a very short M3 screw in it. I don't like 80 dB while I am starting. You may.

I use the Sullivan Head Lock Remote Extended for the plug.

Dave Harmon 01-07-2013 01:02 PM

RE: help with idle problem on 91AC
 
These engines will idle and run great if adjusted properly.
I suggest that you put it on a test stand and get it adjusted so it idles correctly....then put it back on the plane and it should idle about the same.

tande 01-07-2013 05:08 PM

RE: help with idle problem on 91AC
 

Quote:

ORIGINAL: Dave Harmon

These engines will idle and run great if adjusted properly.
I suggest that you put it on a test stand and get it adjusted so it idles correctly....then put it back on the plane and it should idle about the same.

Dave is correct.....an on/board glow driver is simply a "Band/Aid" when used on a "YS".....FWIW

apereira 01-08-2013 04:50 PM

RE: help with idle problem on 91AC
 
dbeeler,

I went thru the exact same thing, and I have found the 91AC idles only with 30% Nitro, no matter what the engine instructions says, and it improved only after about some 25 flights when it was new.

4*60 01-09-2013 02:55 PM

RE: help with idle problem on 91AC
 
Mine idled great at 15% nitro so there you go!!

dbeeler 01-10-2013 09:40 AM

RE: help with idle problem on 91AC
 
thanks for all your responses. i understand what you say that the YS should idle fine when adjusted correctly. that makes sense. and i really DON'T want to use a "bandaid". i have spent much time on the "test stand" getting it to idle consistently at about 2000 rpm. it actually does pretty well on the bench and will pretty well for up to 30 secs or so. it is when it is in the air that it does not idle well for any length of time. the engine has "died" after throttling back on approach for landing 10 out of 10 times. that is, throttling back to just above idle RPM. so there is seems to be something "different" when flying as compared to the bench scenario. the engine is mounted in the plane INVERTED. (the YS folks bench test it in the upright position). also there is ample air flow over the engine, it is not overheating. so i thought onboard glow might help. i havent ordered it yet. before i do that i am going to dismantle the engine and inspect the o-rings and seals, particularly the throttle barrel seal. replace as necessary and reassemble and try again. is just seems to me that the source of the "problem" must be simple but it has been a frustrating effort to resolve. i still may end up trying onboard ignition after "all else" fails. it is a relatively inexpensive item. i would choose the SwitchGlo Pro. again, thank you for your help.

apereira 01-10-2013 01:02 PM

RE: help with idle problem on 91AC
 
Try 30% nitro, again, I had the exact same situation, and the engine dying on final, fixed with 30% unless the engin is fully broken in.

That engine had that problem at the time it was released, some worked some did not.


Four Stroker 01-10-2013 01:03 PM

RE: help with idle problem on 91AC
 
All F3A engines are mounted inverted and idle great. But I don't know if the 90AC was ever used this way. Dave Shadel didn't like the AC engines at all !

apereira 01-14-2013 05:38 AM

RE: help with idle problem on 91AC
 
Mine was mounted inverted, it only worked correctly, again, with 30%

Four Stroker 01-14-2013 07:17 AM

RE: help with idle problem on 91AC
 
It is my suspicion that the oil in the fuel is more of a factor than the nitro percent. I am using Cool Power 30% heli now. The engine is bone dry after a flight. I used to use CY Wildcat 30% heli. After a flight 3~4 cc of oil was still in the crankcase. You could take the plug out and it was always full of oil. A plug full of oil will not idle.


All times are GMT -8. The time now is 04:34 AM.