Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 2 of 2

  1. #1

    Join Date
    Apr 2005
    Location
    Wales, UNITED KINGDOM
    Posts
    85
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    Rough running = bang bang bang

    My ZDZ 50NG has run flawlessly for a couple of years and then today had a perfect flight without any problems and on the second flight she suddenly stopped throttling up and one could hear the engine barking, bang bang bang but ticked over sweat as ever when I reduced throttle. She wouldn't open up again. I was lucky to land on idle.

    Checked everything, nothing loose, sensor and plug looked fine, throttle servo operating correctly. Restarted and she ran as sweet usual, as nothing was wrong. A perfect tick over and throttled up several times OK in the pits. Never missed a beat. Taxied out to take off, pre throttle up check and bang bang bang, no pick up. It sounded like ignition. She would run flawslessly on idle but refused to throttle up without barking bang bang bang and no pick up on revs. Suggestions welcome?

  2. #2

    Join Date
    Apr 2005
    Location
    Wales, UNITED KINGDOM
    Posts
    85
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: Rough running = bang bang bang

    OK found the source of my problems .... ignition battery was on the way out. Voltage had dropped right off. Replaced with a new battery and all OK.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 06:44 PM.

SEO by vBSEO 3.6.1 ©2011, Crawlability, Inc.