ZDZ & RCS Support Direct support from Mike Dooley of RC Showcase for all your ZDZ and RCS Engine questions.

ZDZ 40 RV Blue Head wont choke Up Fuel

Reply
Old 02-28-2006, 01:23 AM
  #1
dspadler
Thread Starter
 
Join Date: Mar 2003
Location: Clinton, NC
Posts: 111
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default ZDZ 40 RV Blue Head wont choke Up Fuel

I just bought a new in the box ZDZ 40 RV Blue Head and cant get it to draw fuel with the choke Completey Closed. I can put my finger over the choke while it is in the choke position and it will draw fuel up to the carb instantly but it will not pull fuel up to the carb without my finger over the choke. Ive looked and cant find any thing loose or leaking. Im running a looped vent line on top of the tank and out below the cowling. A Fill LIne out the cowling with a fuel dot and a line with a fuel clunk to the carb. with an inline filter. What is the problem?.
Thanks
dspadler is offline  
Reply With Quote
Old 02-28-2006, 01:33 AM
  #2
bobzilla
 
bobzilla's Avatar
 
Join Date: Aug 2004
Location: Henderson, NV
Posts: 945
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: ZDZ 40 RV Blue Head wont choke Up Fuel

I have a zdz 50ng..and from the get go.its a bear to get gas..but I do have method that works for me.
I turn on plane, radio, but ignition off. Then I open up throttle full, close chock full and crank the heck for about 15 to 20 cranks
I then put radio to idle, take off choke, turn on ignition, and boom...it starts in first or 2nd toss.
My take is a well back in fuselage..and I think it just takes a few cranks to get up the line.
Give it a try.

Bobzilla
www.theultimategamer.net
"enjoy my rc carnage site"
bobzilla is offline  
Reply With Quote
Old 02-28-2006, 06:46 AM
  #3
dspadler
Thread Starter
 
Join Date: Mar 2003
Location: Clinton, NC
Posts: 111
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: ZDZ 40 RV Blue Head wont choke Up Fuel

Bob these engines shouldnt be such a problem to prime. I had an old BS version that didnt give this kind of priming problem. Ive heard line configuration, Servo travel adjustment, tank placement and etc. and Ive been over all of that and it is still a problem. My tank is practically on the CG but it should draw fuel if the tank is in the tail. Of course it would take longer to get to the carb. but at least it should draw......... period. Need some advise hear. Is this a typical problem with all these engines? Im really thinking about soldering up the vent hole in the choke flap. I think this would solve the whole problem.
Thanks
dspadler is offline  
Reply With Quote
Reply


Thread Tools
Search this Thread
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 06:14 AM.