ZDZ & RCS Support Direct support from Mike Dooley of RC Showcase for all your ZDZ and RCS Engine questions.

Dead ignition on a 80RV-J

Reply
Old 10-30-2006, 04:12 PM
  #1
Vismund
Thread Starter
 
Join Date: Oct 2004
Location: Stockholm, SWEDEN
Posts: 88
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default Dead ignition on a 80RV-J

I've just mounted the engine on the plane, and hooked up the ignition with battery and switch. So far, I haven't been able to produce a single spark. I have switched the spark plug and tried different battery´s, both nicads and freshly charged Li-Ions with and without the switch. I also have a 50ng which is running great, which means that I'm pretty used to setting up the ignition. Is there anything else I can do to check the status of the ignition system? I'm reluctant to send it back to TBM because I live in Sweden. Can I use the ignition system from my 50ng?
Vismund is offline  
Reply With Quote
Old 10-31-2006, 10:50 AM
  #2
Mike Dooley/RCS
 
Join Date: Jul 2002
Location: MD
Posts: 515
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: Dead ignition on a 80RV-J

question answered to your email
Mike Dooley/RCS is offline  
Reply With Quote
Reply


Thread Tools
Search this Thread
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 10:49 AM.