ZDZ & RCS Support Direct support from Mike Dooley of RC Showcase for all your ZDZ and RCS Engine questions.

RCS 140 Problems starting & top end

Reply
Old 11-06-2006, 10:32 AM
  #1
Citation01
Thread Starter
 
Join Date: Jan 2002
Location: Pahrump, NV
Posts: 77
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RCS 140 Problems starting & top end

Hello,

I have the RCS 140 which I bought because of a review done by Ray at Kangke and it has been problems from day one. I have had it and the plane (Monocoupe) for several years, never even flew the plane, just got fed up and put it aside. I have sent the engine back TWICE and they say nothing is wrong and turns 7800 rpm. Unless you use an electric starter, it WILL NOT start cold or hot. Obviously I am still using FRESH 40:1 mixture and only can get 7,000 rpm on a 16x8. I probably have over a gallon of fuel through it try different things.

Does anybody have any suggestions other than using it for a paper weight? I have a perfect rating on RCU and will not even sell it.

I am beyond being upset with this engine. I have almost as much in shipping as the engine by the time you add up the insurance and other shipping charges.

Thank you,
John
Citation01 is offline  
Reply With Quote
Old 11-06-2006, 02:54 PM
  #2
Mike Dooley/RCS
 
Join Date: Jul 2002
Location: MD
Posts: 515
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: RCS 140 Problems starting & top end

When was the last time you sent it in for service? What is your last name?
Thanks,
Mike Dooley/RCS is offline  
Reply With Quote
Reply


Thread Tools
Search this Thread
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 04:12 AM.