Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 3 of 3

  1. #1

    Join Date
    Aug 2005
    Location
    Charlotte, NC
    Posts
    119
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    ZDZ 80 runs rough

    I have a new ZDZ 80RV (blue head) installed in a 33% Laser. I have no problems starting it and it seems to idle fine. After it warms up a bit, as I advance the throttle, it sounds and pulls wonderfully until about half throttle. Then as I continue to advance the throttle it gets rough and seems to vibrate the whole airframe. As I continue to advance the throttle to WOT the rpms begin to sag. I don't leave it at any of these questionable settings...just a second or two to confirm nothing I'm doing is helping to fix the problem. I'm running 32:1 Pennzoil, fresh fuel, ZDZ brand ignition, Menz 24x10 prop, Supersonic inverted pitts muffler. The prop is perfectly balanced vertically and horizontally, the ignition has been set at 6mm and 6.5mm...makes no difference. It's not getting unusally hot (checked with pyrometer), I had the needles initially set at 1 1/2 turns each. I have now closed the low needle 1/8 turn and it smoothed out the idle. Rapid throttle increase from idle is instant with no stumbling....couldn't be any better (up to half throttle). I tried leaning the hi needle....didn't make any difference so I put it back to 1 1/2 turns. I called RCS and they were helpful, gave me some things to try ( ignition to 6.5MM) and said to just give it some time and it should smooth out. I'm afraid to fly it this way and can't run this in my driveway forever until it finally decides to smooth out. I'm also worried I might damage the engine so I'd really like to get this resolved. Is this normal for a new ZDZ engine? I've had many gas engines...unless something was really wrong, none vibrated and ran rough when you increased the throttle. Thanks, John B
    Forward is down, back is up and further back is....down?

  2. #2

    RE: ZDZ 80 runs rough

    John,
    That much vibration is not normal.
    I would recommend sending the engine in for us to look at to be sure nothing is wrong with it. I do know that some engine/airframe combinations will induce vibration. Be sure you do not have a broken motor box or engine mount etc....
    Let us know.
    Thanks,
    Mike Dooley
    RC Showcase

  3. #3

    Join Date
    Aug 2005
    Location
    Charlotte, NC
    Posts
    119
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: ZDZ 80 runs rough

    I also have a new RV-J with the same ignition. I am going to swap ignitions and carefully give it a try. If that doesn't work, I'll contact you. Thanks for your help
    Forward is down, back is up and further back is....down?


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 11:47 PM.

SEO by vBSEO 3.6.1 ©2011, Crawlability, Inc.