ZDZ & RCS Support Direct support from Mike Dooley of RC Showcase for all your ZDZ and RCS Engine questions.

ZDZ wanting to die?

Reply
Old 11-13-2007, 08:26 AM
  #1
gapple12
Thread Starter
 
Join Date: Jan 2006
Location: San Antonio, TX
Posts: 319
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default ZDZ wanting to die?

Ok, I have been running my ZDZ 80rv copper version for about 20 flights now. I have started flying 3D and when I am running the throttle up and down real quickly for hover and harrier, the engine starts to bog down and wants to die. I then have to full throttle it to keep it running. I have turned the low speed both ways little by little and cant seem to get it to stop. Could it be my high speed? I bought this engine from a guy on here when he had about 30 flights on it. I then flew it with the same Penzoil as he did for about another gallon, then switched to Mobil one 2T synthetic. I am running a Vess 26A prop and 93 unleaded fuel. Any thoughts? Maybe a bad carb?
gapple12 is offline  
Reply With Quote
Old 11-13-2007, 11:13 AM
  #2
arobatx
 
Join Date: Jan 2006
Location: Kalona, IA
Posts: 2,517
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: ZDZ wanting to die?

***EDIT***....whooooops! Posted before I realized it was a factory direct support thread. SORRY MIKE!


Chad
arobatx is offline  
Reply With Quote
Old 12-04-2007, 08:48 AM
  #3
gapple12
Thread Starter
 
Join Date: Jan 2006
Location: San Antonio, TX
Posts: 319
Gallery
My Gallery
Models
My Models
Ratings
My Feedback
Default RE: ZDZ wanting to die?

Ok, I have been running my ZDZ 80rv copper version for about 20 flights now. I have started flying 3D and when I am running the throttle up and down real quickly for hover and harrier, the engine starts to bog down and wants to die. I then have to full throttle it to keep it running. I have turned the low speed both ways little by little and cant seem to get it to stop. Could it be my high speed? I bought this engine from a guy on here when he had about 30 flights on it. I then flew it with the same Penzoil as he did for about another gallon, then switched to Mobil one 2T synthetic. I am running a Vess 26A prop and 93 unleaded fuel. Any thoughts? Maybe a bad carb?
gapple12 is offline  
Reply With Quote
Reply


Thread Tools
Search this Thread
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -8. The time now is 01:13 AM.