Register

If this is your first visit, please click the Sign Up now button to begin the process of creating your account so you can begin posting on our forums! The Sign Up process will only take up about a minute of two of your time.

Results 1 to 4 of 4

  1. #1

    Join Date
    Jun 2004
    Location
    Montague, CA
    Posts
    116
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RCS 180 engine

    I have an RCS 180 engine for about 3 + years and it has always started easily and ran smoothly. But to day I was running the engine and it was harder than usual to start and it would just stop after a few minutes. The battery tested 3.8 to 4.0 volts. It seemed to me that it was missing some top end power. Any ideas on what might be wrong?
    Thanks
    Tom

  2. #2

    Join Date
    Jan 2006
    Location
    Kalona, IA
    Posts
    2,517
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: RCS 180 engine



    Try a fully charged 4.8v ignition battery...should read above 5v when tested, you probably have weak spark at 3.8-4.0v.

    Chad

  3. #3

    Join Date
    Jun 2004
    Location
    Montague, CA
    Posts
    116
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: RCS 180 engine

    Thanks, I am discharging the battery now and will recharge it, then do another test run. I was going to fly the mustang this weekend, but not if I continue to have a problem.

  4. #4

    Join Date
    Jan 2006
    Location
    Kalona, IA
    Posts
    2,517
    Gallery
    My Gallery
    Models
    My Models
    Ratings
    My Feedback

    RE: RCS 180 engine



    ...keep us posted!

    Chad


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
All times are GMT -6. The time now is 03:38 AM.

SEO by vBSEO 3.6.1 ©2011, Crawlability, Inc.