Notices
1/16th, 1/18th, Mini & Micro RC Cars Discuss 1/16, 1/18, Minis, Micros & any RC Cars smaller than 1/10th scale in this forum

Problems with mamba

Old 07-05-2008, 11:14 PM
  #1  
PhatMan
Junior Member
Thread Starter
 
Join Date: Feb 2006
Location: Gladstone, MO
Posts: 18
Likes: 0
Received 0 Likes on 0 Posts
Default Problems with mamba

Hey guys when I accelerate with my mamba and then let off the trigger the motor continues to run for about 5 seconds and then stops do you know whats wrong this is my first mamba so I need a little help. Thanks Phatman
Old 07-06-2008, 12:00 AM
  #2  
maxxin2.5
Senior Member
 
maxxin2.5's Avatar
 
Join Date: Jan 2007
Location: vacaville, CA
Posts: 1,968
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Problems with mamba

umm idk have you programed it??
that might be the problem..
Old 07-06-2008, 12:04 AM
  #3  
t9dragon
Senior Member
My Feedback: (11)
 
Join Date: Apr 2004
Location: PDX, OR
Posts: 7,866
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Problems with mamba

What radio are you using? Sounds like it could be your trim knobs....................
Old 07-06-2008, 12:35 AM
  #4  
PhatMan
Junior Member
Thread Starter
 
Join Date: Feb 2006
Location: Gladstone, MO
Posts: 18
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Problems with mamba

Na its not the trims i checked that, i think im gonna order a castle link for it
Old 07-06-2008, 12:52 AM
  #5  
t9dragon
Senior Member
My Feedback: (11)
 
Join Date: Apr 2004
Location: PDX, OR
Posts: 7,866
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Problems with mamba

What radio are you using?
Old 07-06-2008, 01:12 AM
  #6  
PhatMan
Junior Member
Thread Starter
 
Join Date: Feb 2006
Location: Gladstone, MO
Posts: 18
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Problems with mamba

Its the stock radio
Old 07-06-2008, 01:15 AM
  #7  
t9dragon
Senior Member
My Feedback: (11)
 
Join Date: Apr 2004
Location: PDX, OR
Posts: 7,866
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Problems with mamba

Try setting your throttle know back towards the ( - ) side of 0 and see if that works.
Old 07-06-2008, 01:43 AM
  #8  
PhatMan
Junior Member
Thread Starter
 
Join Date: Feb 2006
Location: Gladstone, MO
Posts: 18
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Problems with mamba

I tried that i think it needs to be programmed
Old 07-06-2008, 08:14 AM
  #9  
HeliStyle
Senior Member
My Feedback: (2)
 
Join Date: Jul 2008
Location: heli town, CT
Posts: 1,639
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Problems with mamba

I think you have your power start off set on low, set it to normal and it should be fine, sounds like thats what is happening
Old 07-06-2008, 05:55 PM
  #10  
PhatMan
Junior Member
Thread Starter
 
Join Date: Feb 2006
Location: Gladstone, MO
Posts: 18
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Problems with mamba

Okay ill try that thanks for the responses guys
Old 02-06-2009, 01:44 AM
  #11  
str8.krooked
Senior Member
 
str8.krooked's Avatar
 
Join Date: Sep 2007
Location: Highlands Ranch, CO
Posts: 562
Likes: 0
Received 0 Likes on 0 Posts
Default RE: Problems with mamba


ORIGINAL: PhatMan

Na its not the trims i checked that, i think im gonna order a castle link for it
Castle Link is the best thing in the world! Definitely recommend it. It is well worth the money. You can make precise changes SUPER fast!

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information

Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.