Old 08-17-2011, 06:40 PM
  #1  
Tcat1000
My Feedback: (34)
 
Tcat1000's Avatar
 
Join Date: Jul 2002
Location: Ludington, MI
Posts: 180
Likes: 0
Received 0 Likes on 0 Posts
Default Hitec Optic6 TX won't bind...Please help!

Hi...........I hope some of you Hitec gurus out there can help me with a problem on my Hitec Optic6 TX.....................

I have a Optic6 TX on channel 20 that works great with my H9 Ultra Stick 40. I bought a Hitec Spectra module for it with two Optima 7 receivers. I removed the ch 20 module from the TX & installed the spectra module & antenna.

Now here is my problem......It won't bind! It looks like it tries to bind as all of the servos then jump all over the place. If I move one TX stick, all servos get the jitters but don't work. Then I tried the other Optima7 receiver & two different Optima6 receivers & none of them work. It's not the receivers.

I also have a NIB Optic6 TX that came as a 2.4 gig from the factory. IT WORKS GREAT! The NIB TX binds to all the above receivers, but the converted one from ch 20 TX does not.

OK..............I removed the TX module from the new TX & installed it in the TX that don't bind. That new module does not work in the older TX either. I then took the Spectra module & antenna from the older ch 20 TX & installed it in the NIB TX & it works (binds) fine. Geeeeese..............

My finding is that it's not either new Spectra 2.4 TX modules......the one that came in the new Optic6 TX, or the one that came with two receivers that I bought for the ch 20 TX. It's not the receivers either as the new TX with either Spectra module works with all of them.

It's not my binding procedure either as I can bind the new TX to all receivers but not the older TX.

It has to be the older ch 20 Transmitter that I converted to 2.4, but why?

Sorry if the above is confusing but wanted to give all of the things that I tried.

Anybody? What am I doing wrong? Thanks in advance for any ideas............

Tcat