View Single Post
Old 11-29-2005, 01:02 PM
  #1  
coops1
Member
 
Join Date: Aug 2005
Location: , VANUATU
Posts: 54
Likes: 0
Received 0 Likes on 0 Posts
Default esc problem no power!!

Just wondered if anyone knows how to get my esc to power up it is a tower pro 30amp brushless jobbie from ebay and i cant get any power from it!! I got power to the servos via the esc but nothing to the motor, no light or anything (there is no switch to turn it on either) it is suposed to bleep after i plug the battery in with the throttle in the up position but it won't do anything, ive tried it in every channel on the receiver/ hanset and tried reversing all the chanels and still nothing!! I don't know what to do next.
Would the servos work, ie would power still get to the receiver through it if it was dead?
Would it blow if i accidently touched the positive negative terminals together whilst powered up? there is a posability i may have done this whilst plugging the battery in!! But there is still power going through it to the receiver? Any ideas?