View Single Post
Old 03-02-2007, 02:41 PM
  #508  
its_just_seth
Junior Member
 
Join Date: Apr 2006
Location: Conroe, TX
Posts: 17
Likes: 0
Received 0 Likes on 0 Posts
Default RE: *!STORM LAUNCHER!*

ORIGINAL: ahaacobbler

So I just got my SL, charged it up, ran the battery through at slow speed 2 times and then took the SL out for the maiden voyage. I was hugely disapointed when I had all my friends gathered around to see what she could do and she wouldn't even start up.

Has anyone else had an SL that was probably working just fine, but then would not turn on when you press the start button. I already tried all of the trouble shooting ideas. I tried charging the battery again, removing/replacing the battery dozens of times. I even replaced the TX batteries, enen though i am sure they should last longer than 2 cycles on the SL battery. I opened the TX to see if something had come loose. I am running out of ideas. BTW, when I stick the battery into the SL I do hear a little buzz from the servo and if I force the elevator, it returns to neutral, however, the elevator does not respond to any TX inputs.

Any ideas? Do I just have to call Spinmaster about a return? I don't want to take it back to Target, because I am never going to find another at the $12.50 clearance price.


I got mine at clearance also though mine was aquired for $45 from wally world... anyway i am having the same problems.. ive tried the advice of others taking the battery out.. etc the elevator doesnt stop working just the motors in my case... i am running out of ideas and i may end up taking it back... have you discovered a fix for this?

i have resolved its probably not a lipo prop. I try the spinmasters and see if they have any ideas.. will report back if i find anything.

thanks in advance