View Single Post
Old 05-31-2003, 02:17 AM
  #1  
WreckRman2
Banned
My Feedback: (5)
 
Join Date: May 2002
Location: Indianapolis, IN,
Posts: 1,494
Likes: 0
Received 1 Like on 1 Post
Default Futaba 9C Range Problems...

Has anyone experienced range problems with a Futaba 9C?

Let me explain...

My radio has been used for less than 15 total flights. When I recently setup my 27% CA Extra I couldn't get 20 paces away with antenna down before the servos began to jump around. As a result I took the antenna out of the fuse and ran it down the under side of the fuse. This seemed to give me a better range test but not as solid as I'd like to have seen. It was enough for me to consider flying it and I did so. I put 8 more flights on the plane without noticing any problems in the air but still the ground range test WITHOUT the engine running wasn't as good as I'd like to have seen.

Anyway on the 9th flight of the plane as I began to turn final for landing I had a huge glitch of my servos but was able to safely land the plane. I looked everything over yet again and did some more range testing on the ground. Still not as solid as I'd like to see but good enough to feel it was ok to fly. On the 10th flight I had 3-4 major glitches in the air but again was glad to get it back down without a crash. Now I've had enough to not fly it again until I feel the range tests are ROCK SOLID so I began looking everything over very closely.

As part of my testing through process of elimation I have nothing left to blame but the radio itself and this is why I feel this.

I first by passed my switch to elminate that, I then unhooked one servo at a time to eliminate any possible problems there, then I replaced the reciever with another one... still not solid. I then called Futaba support and explained my problem. He said that he was 80% sure that the module was my problem so I borrowed a friends module pack and I still have servos jumping. I feel I have elminated everything but the radio itself and have no choice but to box it all up and send it to Futaba.

Just so you know I consider a solid range test when you can walk 30-35 paces, antenna down and not have any servos jump or move around. Something I haven't been able to do.

I am using a 148DF rx with 3-JR8411's, 2-JR4721's and 2-Futaba 3004 servos, Cermark DSC switch and running a 1650mah 6v battery. (PS. I also tried a 4.8v battery, same problems.)

Basically it seems to have gradually gotten worse with each flight.

Has anyone else experienced this problem? Would you recommend me trying anything else before I send it to Futaba support?