RCU Forums

RCU Forums (https://www.rcuniverse.com/forum/)
-   Academy Racing (MRC) Support Forum (https://www.rcuniverse.com/forum/academy-racing-mrc-support-forum-396/)
-   -   SB 960 LCD not working (https://www.rcuniverse.com/forum/academy-racing-mrc-support-forum-396/9414422-sb-960-lcd-not-working.html)

ben94gt 01-14-2010 02:16 AM

SB 960 LCD not working
 
Hello all,

I just bought a SB 960 off a friend and I charged one battery off of it completely fine, went to grab another battery, I came back and the LCD screen was off, i tried pressing buttons and unplug/ replugging it in and still nothing. Any idea as to why this has happened?

[email protected] 01-14-2010 10:52 AM

RE: SB 960 LCD not working
 
Have you tried it on 12V? Also, make sure that the 110V plug is pushed all the way into the charger. Let me know what you find.

Tim Sandor

ben94gt 01-14-2010 04:12 PM

RE: SB 960 LCD not working
 
So Icame back this afternoon to try again. Plugged it into the wall and the LCD fired up fine. Although whilst charging a battery it cut off and the Red light by the start button was blinking very rapidly and there was a faint clicking sound coming from the charger. I pressed start again and it went back to charging. I have not had a chance to try out the 12v yet, I might do that next time the screen shorts out, but the AC cord is all the way in the back of the unit, and the unit is not getting hot, though the batteries are getting fairly hot.

UPDATE: I charged one battery using the AC-same battery as above. As soon as I was done I disconnected the battery, Voltage went to 0 as expected, "Er" showed up on the LCD, the screen cut off and the red light by the start button remained on. I unplugged it and plugged it back in, same thing-no screen, red light on. Left for 20 minutes to go to the bank, came back, plugged it in, screen works again. Im going to charge one more battery to see if it cuts off again, if it does I will take it out to the car battery and hook it up to see what happens.


[email protected] 01-14-2010 05:57 PM

RE: SB 960 LCD not working
 
Well, if worse comes to worse, send it to me and I'll take care of it for you.

Tim

ben94gt 01-30-2010 05:41 PM

RE: SB 960 LCD not working
 
ok so this is the first time ive tried it out in a while, but Iplugged it in today and the red LED is flickering and the LCD screen will not come up. I took it out to the car battery and hooked it up and it did the exact same thing. At this point I think I might just send it to you, unless you have an idea on something else to try.whats the address and whats involved?

Also, I plugged in an 8.4v battery without it connected to anything else, and the red light came on and flickered, as if it was trying to draw off of that as well.


All times are GMT -8. The time now is 03:30 AM.


Copyright 2018 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.