Notices
Airtronics Support Forum Ask any questions you may have about Airtronics radios and product here and get answers direct from the Airtronics Team.

SD10G Battery charger issue - again

Old 02-20-2011, 10:15 AM
  #1  
Thread Starter
 
Join Date: Mar 2003
Location: Leesburg, VA
Posts: 94
Likes: 0
Received 0 Likes on 0 Posts
Default SD10G Battery charger issue - again

Keep reading various postings on the SD10G battery charger and the "new" charger....

I have the original SD10G battery. I cycled it a few times when I first got it but now I use ethe original wall charger it came with and it seems to work fine. I dont want the aggrevation of removing the battery when I charge it and switching to LiPo seems to be more trouble than it's worth.

Could somebody clarify the charger/battery problem and corrections.

Thanks.

Old 02-22-2011, 08:49 AM
  #2  
My Feedback: (8)
 
Jetdesign's Avatar
 
Join Date: May 2008
Location: Honolulu, HI
Posts: 7,056
Received 0 Likes on 0 Posts
Default RE: SD10G Battery charger issue - again

I think the issue was just that the battery needed to be cycled a few times. I charged my stock battery with my computer charger a couple of times, then used the stock charger. Never had an issue, but I decided to switch to lipo for extended flying time (i.e. weekend contests).
Old 02-23-2011, 07:20 AM
  #3  
Senior Member
 
MikeRuth's Avatar
 
Join Date: Mar 2006
Location: Tarzana, CA
Posts: 410
Likes: 0
Received 0 Likes on 0 Posts
Default RE: SD10G Battery charger issue - again


ORIGINAL: coupar

Keep reading various postings on the SD10G battery charger and the ''new'' charger....

I have the original SD10G battery. I cycled it a few times when I first got it but now I use ethe original wall charger it came with and it seems to work fine. I dont want the aggrevation of removing the battery when I charge it and switching to LiPo seems to be more trouble than it's worth.

Could somebody clarify the charger/battery problem and corrections.

Thanks.

I can not clarify with exactness but I can say I bought mine in October of 2010 and I had to cycle thepack several times(maybe 5) to get what I felt was a reasonable run time off of it. I used a third party charger that had a NiMH program in it to perform the cycling.

There was an issue with the charger it's self, although I do not beleive it was related to not being able to charge but how the lights functioned.

Ultimately it dosen't matter which charger or pack you got, the best senario is to cycle it preferably on a charger designed to handle NIMH batteries a few times.
There after theres no reason not to use the included charger as per the manuals instructions.
I have changed out to Lipo as well but I still use the NIMH battery once in a while as I see no reason to let it waste away.

MIke R

Old 02-23-2011, 02:34 PM
  #4  
 
Join Date: Mar 2005
Location: Orange County, CA
Posts: 384
Likes: 0
Received 0 Likes on 0 Posts
Default RE: SD10G Battery charger issue - again

Which charger are you using?
Old 02-26-2011, 08:42 AM
  #5  
Thread Starter
 
Join Date: Mar 2003
Location: Leesburg, VA
Posts: 94
Likes: 0
Received 0 Likes on 0 Posts
Default RE: SD10G Battery charger issue - again

The one that came with the system....about 14 months ago.


Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are On


Thread Tools
Search this Thread

Contact Us - Manage Preferences Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

Copyright © 2024 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.