Notices
Airtronics Support Forum Ask any questions you may have about Airtronics radios and product here and get answers direct from the Airtronics Team.

Airtronics Service Contact Information

Old 06-15-2019, 11:54 AM
  #26  
dw_crash
My Feedback: (6)
 
Join Date: Feb 2003
Location: Edmonton, AB, CANADA
Posts: 680
Likes: 0
Received 1 Like on 1 Post
Default Support???

Originally Posted by johnp793 View Post
My sons and I are long time Airtronics users, and were sad to see the transition to Sanwa. Has anyone had any luck getting support from the new distributor?
I am curious also about support. Anyone have any luck finding Airtronics support?

dw_crash
Old 09-26-2019, 11:40 AM
  #27  
FLYINW
 
Join Date: Nov 2003
Location: Downey, CA
Posts: 9
Likes: 0
Received 0 Likes on 0 Posts
Default

I'm inquiring about an ol' friend, Bobby Tom, been calling him and both numbers are not active any more ?? I've known Bobby since we worked together at K & B 1962. Last time I talked to him, around Feb.2019, he was not well. If anyone knows any information or details, please let me know - JW
Old 01-27-2021, 04:02 PM
  #28  
Rmarasky
 
Join Date: Jun 2012
Location: , MO
Posts: 74
Likes: 0
Received 0 Likes on 0 Posts
Default

Hey Ted may be you can help me with this issue, with the Taranis QX7 i have and you have helped me numerous times in the past.
i was trying to rebuild the Recruit in Companion to see if that would work.
i had the taranis connected and i redid the build for the Recruit and i got notice that there was an update for firmware and all that.
i did the update and then i wrote the saved plane to the radio then i did write for the firmware as well to the radio
after i did the write back to the radio i disconnected the cable and did exit on the screen then the power went off and now i cannot power it back on.
is there something i did wrong.
i think there may have wrote the firmware twice to the radio by mistake,
would that cause this issue cause now i cannot power it back on .

thanks Ted
Old 08-18-2021, 05:39 AM
  #29  
didge110
Junior Member
 
Join Date: Nov 2019
Posts: 2
Likes: 0
Received 0 Likes on 0 Posts
Default

HI guys, is this thread still alive? I bought a SD 10G transmitter and can not find help anywhere. I'm in Sydney, Australia.

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service - Do Not Sell My Personal Information -

Copyright 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.