RCU Forums

RCU Forums (https://www.rcuniverse.com/forum/)
-   Airtronics Support Forum (https://www.rcuniverse.com/forum/airtronics-support-forum-516/)
-   -   Elevator sliding trim not working (https://www.rcuniverse.com/forum/airtronics-support-forum-516/11683473-elevator-sliding-trim-not-working.html)

pancake 10-06-2020 04:07 AM

Elevator sliding trim not working
 
Elevator sliding trim on my infinity and a vanguard radio doesn’t work. Tried different 92765 receivers and still no elevator adjustments can be made . Any suggestions.


pancake 10-11-2020 07:45 PM

Is this forum dead?

raydebs 12-13-2020 06:00 PM


Originally Posted by pancake (Post 12636702)
Elevator sliding trim on my infinity and a vanguard radio doesn’t work. Tried different 92765 receivers and still no elevator adjustments can be made . Any suggestions.

I have the same problem with my Infinity 1000 and a couple other radios as well. It has been more than 15 years since I used my RC equipment, and now that I am trying again, I have found that a lot needs to be fixed.

I think the problem with the sliding trim is that the pots have bound up. I think it is because the lubricant has turned to glue. I was able to turn one of the pots with a screwdriver to free it up, but it still feels like a stick in the mud. I just ordered some Isopropyl Alcohol to clean them and see if I can get the radio back to working condition. If the cleaning doesn't work, then I will be looking for replacement pots to see if that route works.

I have a Futaba -T7UHP Super radio that both gimbals have frozen up. Probably the same problem.

Anyone else had any experience with these types of problems?

Thank you,
Ray

pancake 12-14-2020 09:47 AM

tv tuner spray
 
i opened up the back of the radio and eventually got the vanguard elevator sliding switch to work after i spray some cleaner inside,and working the switch while spraying. not so lucky on the infinity 660 transmitter. . i had not used them for a few years as well.

pancake 04-22-2021 04:44 PM

Fixed sliding trim vanguard infinity
 
Sliding trim pot was working but there was some kind of green glue that the plastic trim wheel and the brass pot stem had deteriorated. I cleaned that out , was able to slide the wheel back a little , then injected a little hot glue into the shaft of the pot and onto the wheel. Pressed it all back together quickly to dry. Worked good as new. Make sure the pot switch it level, compare it to a good pot for approximate angle on the switch.


All times are GMT -8. The time now is 07:13 PM.


Copyright © 2021 MH Sub I, LLC dba Internet Brands. All rights reserved. Use of this site indicates your consent to the Terms of Use.